williamh    15/07/08 19:15:20

  Modified:             vault-9999.ebuild ChangeLog
  Added:                vault-0.1.2-r1.ebuild
  Log:
  add the slot dependencies for go and go-oauth2
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x30C46538)

Revision  Changes    Path
1.4                  app-admin/vault/vault-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/vault-9999.ebuild?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/vault-9999.ebuild?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/vault-9999.ebuild?r1=1.3&r2=1.4

Index: vault-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/vault/vault-9999.ebuild,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- vault-9999.ebuild   9 Jun 2015 07:09:29 -0000       1.3
+++ vault-9999.ebuild   8 Jul 2015 19:15:20 -0000       1.4
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/vault/vault-9999.ebuild,v 1.3 
2015/06/09 07:09:29 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/vault/vault-9999.ebuild,v 1.4 
2015/07/08 19:15:20 williamh Exp $
 
 EAPI=5
 
@@ -15,8 +15,8 @@
 SLOT="0"
 IUSE=""
 
-DEPEND=">=dev-lang/go-1.4
-       dev-go/go-oauth2"
+DEPEND=">=dev-lang/go-1.4:=
+       dev-go/go-oauth2:="
 RDEPEND=""
 
 SRC_URI=""



1.5                  app-admin/vault/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/ChangeLog?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/ChangeLog?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/ChangeLog?r1=1.4&r2=1.5

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/vault/ChangeLog,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- ChangeLog   9 Jun 2015 07:09:29 -0000       1.4
+++ ChangeLog   8 Jul 2015 19:15:20 -0000       1.5
@@ -1,6 +1,12 @@
 # ChangeLog for app-admin/vault
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/vault/ChangeLog,v 1.4 2015/06/09 
07:09:29 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/vault/ChangeLog,v 1.5 2015/07/08 
19:15:20 williamh Exp $
+
+*vault-0.1.2-r1 (08 Jul 2015)
+
+  08 Jul 2015; William Hubbs <willi...@gentoo.org> +vault-0.1.2-r1.ebuild,
+  vault-9999.ebuild:
+  add the slot dependencies for go and go-oauth2
 
   09 Jun 2015; Zac Medico <zmed...@gentoo.org> vault-0.1.2.ebuild,
   vault-9999.ebuild:



1.1                  app-admin/vault/vault-0.1.2-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/vault-0.1.2-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/vault/vault-0.1.2-r1.ebuild?rev=1.1&content-type=text/plain

Index: vault-0.1.2-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-admin/vault/vault-0.1.2-r1.ebuild,v 1.1 
2015/07/08 19:15:20 williamh Exp $

EAPI=5

inherit fcaps systemd user

KEYWORDS="~amd64"
DESCRIPTION="A tool for managing secrets"
HOMEPAGE="https://vaultproject.io/";
GO_PN="github.com/hashicorp/${PN}"
LICENSE="MPL-2.0"
SLOT="0"
IUSE=""

DEPEND=">=dev-lang/go-1.4:=
        dev-go/go-oauth2:="
RDEPEND=""

SRC_URI="https://${GO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/mitchellh/gox/archive/v0.3.0.tar.gz -> gox-0.3.0.tar.gz
https://github.com/mitchellh/iochan/archive/b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz
 -> iochan-b584a329b193e206025682ae6c10cdbe03b0cd77.tar.gz"
STRIP_MASK="*.a"
S="${WORKDIR}/src/${GO_PN}"

FILECAPS=(
        -m 755 'cap_ipc_lock=+ei' usr/bin/${PN}
)

pkg_setup() {
        enewgroup ${PN}
        enewuser ${PN} -1 -1 -1 ${PN}
}

src_unpack() {
        local x

        default
        mkdir -p src/${GO_PN%/*} || die
        mv ${P} src/${GO_PN} || die

        # Create a writable GOROOT in order to avoid sandbox violations.
        export GOROOT="${WORKDIR}/goroot"
        cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
        rm -rf "${GOROOT}/src/${GO_PN}" || die

        export 
GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace

        while read -r -d '' x; do
                rm -rf "${GOROOT}/src/${x}" 
"${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die
        done < <(find 
"${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace/src" -maxdepth 3 
-mindepth 3 -type d -print0)

        mkdir -p "${GOROOT}/src/github.com/mitchellh" || die
        rm -rf "${GOROOT}/src/github.com/mitchellh/gox" || die
        mv gox-0.3.0 "${GOROOT}/src/github.com/mitchellh/gox" || die
        rm -rf "${GOROOT}/src/github.com/mitchellh/iochan" || die
        mv iochan-* "${GOROOT}/src/github.com/mitchellh/iochan" || die
}

src_prepare() {
        # Avoid the need to have a git checkout
        sed -e 's:^GIT.*::' \
                -e 's:-ldflags.*:\\:' \
                -i scripts/build.sh || die
}

src_compile() {
        go install -v -x github.com/mitchellh/gox || die
        PATH=${GOROOT}/bin:${PATH} emake dev
}

src_install() {
        local x

        newinitd "${FILESDIR}/${PN}.initd" "${PN}"
        newconfd "${FILESDIR}/${PN}.confd" "${PN}"
        systemd_dounit "${FILESDIR}/${PN}.service"

        keepdir /etc/${PN}.d
        insinto /etc/${PN}.d
        doins "${FILESDIR}/"*.json.example

        keepdir /var/log/${PN}
        fowners ${PN}:${PN} /var/log/${PN}

        dobin bin/${PN}
        find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
        find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type f -delete
        while read -r -d '' x; do
                x=${x#${WORKDIR}/src}
                [[ -d ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x} ||
                        -f ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x}.a ]] && 
continue
                rm -rf "${WORKDIR}"/src/${x}
        done < <(find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type d 
-print0)
        insopts -m0644 -p # preserve timestamps for bug 551486
        insinto /usr/lib/go/pkg/${KERNEL}_${ARCH}/${GO_PN%/*}
        doins -r "${WORKDIR}"/pkg/${KERNEL}_${ARCH}/${GO_PN}
        insinto /usr/lib/go/src/${GO_PN%/*}
        doins -r "${WORKDIR}"/src/${GO_PN}
}




Reply via email to