k_f         15/06/07 14:39:23

  Modified:             ChangeLog
  Added:                pinentry-0.9.4-r1.ebuild
  Log:
  Add a patch from upstream master to actually respect the user's choice of 
using an external password manager for the gnome3 pinentry
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x250B7AFED6379D85!)

Revision  Changes    Path
1.175                app-crypt/pinentry/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-crypt/pinentry/ChangeLog?rev=1.175&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-crypt/pinentry/ChangeLog?rev=1.175&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-crypt/pinentry/ChangeLog?r1=1.174&r2=1.175

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v
retrieving revision 1.174
retrieving revision 1.175
diff -u -r1.174 -r1.175
--- ChangeLog   7 Jun 2015 11:02:09 -0000       1.174
+++ ChangeLog   7 Jun 2015 14:39:23 -0000       1.175
@@ -1,6 +1,14 @@
 # ChangeLog for app-crypt/pinentry
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.174 
2015/06/07 11:02:09 k_f Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.175 
2015/06/07 14:39:23 k_f Exp $
+
+*pinentry-0.9.4-r1 (07 Jun 2015)
+
+  07 Jun 2015; Kristian Fiskerstrand <k...@gentoo.org>
+  +files/pinentry-0.9.4-actually_respect_users_pm.patch,
+  +pinentry-0.9.4-r1.ebuild:
+  Add a patch from upstream master to actually respect the user's choice of
+  using an external password manager for the gnome3 pinentry
 
 *pinentry-0.9.4 (07 Jun 2015)
 



1.1                  app-crypt/pinentry/pinentry-0.9.4-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-crypt/pinentry/pinentry-0.9.4-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-crypt/pinentry/pinentry-0.9.4-r1.ebuild?rev=1.1&content-type=text/plain

Index: pinentry-0.9.4-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.9.4-r1.ebuild,v 1.1 
2015/06/07 14:39:23 k_f Exp $

EAPI=5

inherit qmake-utils autotools multilib eutils flag-o-matic toolchain-funcs

DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize 
the Assuan protocol"
HOMEPAGE="http://gnupg.org/aegypten2/index.html";
SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh 
~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd 
~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos 
~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="clipboard gtk ncurses qt4 caps gnome-keyring static"

RDEPEND="
        app-eselect/eselect-pinentry
        caps? ( sys-libs/libcap )
        gtk? ( x11-libs/gtk+:2 )
        ncurses? ( sys-libs/ncurses )
        qt4? ( >=dev-qt/qtgui-4.4.1:4 )
        static? ( >=sys-libs/ncurses-5.7-r5[static-libs,-gpm] )
"
DEPEND="${RDEPEND}
        sys-devel/gettext
        gtk? ( virtual/pkgconfig )
        qt4? ( virtual/pkgconfig )
        gnome-keyring? ( app-crypt/libsecret )
"
REQUIRED_USE="
        || ( ncurses gtk qt4 )
        gtk? ( !static )
        qt4? ( !static )
        static? ( ncurses )
"

DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )

src_prepare() {
        epatch "${FILESDIR}/${PN}-0.8.2-ncurses.patch"
        epatch "${FILESDIR}/${P}-actually_respect_users_pm.patch"
}

src_configure() {
        use static && append-ldflags -static
        [[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11

        # Issues finding qt on multilib systems
        export QTLIB="${QTDIR}/$(get_libdir)"

        econf \
                --enable-pinentry-tty \
                $(use_enable gtk pinentry-gtk2) \
                $(use_enable ncurses pinentry-curses) \
                $(use_enable ncurses fallback-curses) \
                $(use_enable qt4 pinentry-qt4) \
                $(use qt4 && use_enable clipboard pinentry-qt4-clipboard) \
                $(use_with caps libcap) \
                $(use_enable gnome-keyring libsecret) \
                $(use_enable gnome-keyring pinentry-gnome3) \
                MOC="$(qt4_get_bindir)"/moc
}

src_install() {
        default
        rm -f "${ED}"/usr/bin/pinentry || die
}

pkg_postinst() {
        if ! has_version 'app-crypt/pinentry' || has_version 
'<app-crypt/pinentry-0.7.3'; then
                elog "We no longer install pinentry-curses and pinentry-qt SUID 
root by default."
                elog "Linux kernels >=2.6.9 support memory locking for 
unprivileged processes."
                elog "The soft resource limit for memory locking specifies the 
limit an"
                elog "unprivileged process may lock into memory. You can also 
use POSIX"
                elog "capabilities to allow pinentry to lock memory. To do so 
activate the caps"
                elog "USE flag and add the CAP_IPC_LOCK capability to the 
permitted set of"
                elog "your users."
        fi
        eselect pinentry update ifunset
}

pkg_postrm() {
        eselect pinentry update ifunset
}




Reply via email to