ulm         14/05/05 07:06:01

  Modified:             ChangeLog
  Added:                emacs-22.3-r12.ebuild emacs-23.4-r8.ebuild
                        emacs-24.3-r4.ebuild
  Removed:              emacs-23.4-r7.ebuild emacs-22.3-r11.ebuild
                        emacs-24.3-r3.ebuild
  Log:
  Access shared game score files in /var/games/emacs, compliant with the FHS.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
9433907D693FB5B8!)

Revision  Changes    Path
1.614                app-editors/emacs/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/ChangeLog?rev=1.614&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/ChangeLog?rev=1.614&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/ChangeLog?r1=1.613&r2=1.614

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v
retrieving revision 1.613
retrieving revision 1.614
diff -u -r1.613 -r1.614
--- ChangeLog   23 Apr 2014 11:38:37 -0000      1.613
+++ ChangeLog   5 May 2014 07:06:01 -0000       1.614
@@ -1,6 +1,15 @@
 # ChangeLog for app-editors/emacs
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.613 
2014/04/23 11:38:37 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.614 
2014/05/05 07:06:01 ulm Exp $
+
+*emacs-24.3-r4 (05 May 2014)
+*emacs-23.4-r8 (05 May 2014)
+*emacs-22.3-r12 (05 May 2014)
+
+  05 May 2014; Ulrich Müller <u...@gentoo.org> -emacs-22.3-r11.ebuild,
+  +emacs-22.3-r12.ebuild, -emacs-23.4-r7.ebuild, +emacs-23.4-r8.ebuild,
+  -emacs-24.3-r3.ebuild, +emacs-24.3-r4.ebuild:
+  Access shared game score files in /var/games/emacs, compliant with the FHS.
 
   23 Apr 2014; Ulrich Müller <u...@gentoo.org> -emacs-18.59-r8.ebuild:
   Remove old.



1.1                  app-editors/emacs/emacs-22.3-r12.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/emacs-22.3-r12.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/emacs-22.3-r12.ebuild?rev=1.1&content-type=text/plain

Index: emacs-22.3-r12.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.3-r12.ebuild,v 
1.1 2014/05/05 07:06:01 ulm Exp $

EAPI=5
WANT_AUTOMAKE="none"

inherit autotools elisp-common eutils flag-o-matic

DESCRIPTION="The extensible, customizable, self-documenting real-time display 
editor"
HOMEPAGE="http://www.gnu.org/software/emacs/";
SRC_URI="mirror://gnu/emacs/${P}.tar.gz
        mirror://gentoo/${P}-patches-8.tar.bz2"

LICENSE="GPL-3+ FDL-1.2+ BSD HPND MIT"
SLOT="22"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 
~x86-fbsd"
IUSE="alsa games gif gtk gzip-el hesiod jpeg kerberos motif png sound source 
tiff toolkit-scroll-bars X Xaw3d +xpm"

RDEPEND="sys-libs/ncurses
        >=app-admin/eselect-emacs-1.16
        >=app-emacs/emacs-common-gentoo-1.4-r1[games?,X?]
        net-libs/liblockfile
        hesiod? ( net-dns/hesiod )
        kerberos? ( virtual/krb5 )
        alsa? ( media-libs/alsa-lib )
        X? (
                x11-libs/libXmu
                x11-libs/libXt
                x11-misc/xbitmaps
                gif? ( media-libs/giflib )
                jpeg? ( virtual/jpeg:0= )
                png? ( >=media-libs/libpng-1.4:0= )
                tiff? ( media-libs/tiff )
                xpm? ( x11-libs/libXpm )
                gtk? ( x11-libs/gtk+:2 )
                !gtk? (
                        Xaw3d? ( x11-libs/libXaw3d )
                        !Xaw3d? ( motif? ( >=x11-libs/motif-2.3:0 ) )
                )
        )"

DEPEND="${RDEPEND}
        alsa? ( virtual/pkgconfig )
        X? ( gtk? ( virtual/pkgconfig ) )
        gzip-el? ( app-arch/gzip )"

# FULL_VERSION keeps the full version number, which is needed in order to
# determine some path information correctly for copy/move operations later on
FULL_VERSION="${PV}"
EMACS_SUFFIX="emacs-${SLOT}"
SITEFILE="20${PN}-${SLOT}-gentoo.el"

src_prepare() {
        EPATCH_SUFFIX=patch epatch

        sed -i \
                -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` 
-print-file-name=crtbegin.o):g" \
                -e "s:/usr/lib/crtend.o:$(`tc-getCC` 
-print-file-name=crtend.o):g" \
                "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"

        sed -i -e "/^\\.so/s/etags/&-${EMACS_SUFFIX}/" etc/ctags.1 \
                || die "unable to sed ctags.1"

        if ! use alsa; then
                # ALSA is detected even if not requested by its USE flag.
                # Suppress it by supplying pkg-config with a wrong library name.
                sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
                        || die "unable to sed configure.in"
        fi
        if ! use gzip-el; then
                # Emacs' build system automatically detects the gzip binary and
                # compresses el files. We don't want that so confuse it with a
                # wrong binary name
                sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
                        || die "unable to sed configure.in"
        fi

        eautoreconf
}

src_configure() {
        strip-flags
        filter-flags -fstack-protector -fstack-protector-all    #285778
        replace-flags "-O[3-9]" -O2
        sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die

        local myconf

        if use alsa && ! use sound; then
                einfo "Although sound USE flag is disabled you chose to have 
alsa,"
                einfo "so sound is switched on anyway."
                myconf="${myconf} --with-sound"
        else
                myconf="${myconf} $(use_with sound)"
        fi

        if use X; then
                myconf="${myconf} --with-x"
                myconf="${myconf} $(use_with toolkit-scroll-bars)"
                myconf="${myconf} $(use_with gif) $(use_with jpeg)"
                myconf="${myconf} $(use_with png) $(use_with tiff)"
                myconf="${myconf} $(use_with xpm)"

                # GTK+ is the default toolkit if USE=gtk is chosen with other
                # possibilities. Emacs upstream thinks this should be standard
                # policy on all distributions
                if use gtk; then
                        einfo "Configuring to build with GIMP Toolkit (GTK+)"
                        myconf="${myconf} --with-x-toolkit=gtk"
                elif use Xaw3d; then
                        einfo "Configuring to build with Xaw3d (Athena/Lucid) 
toolkit"
                        myconf="${myconf} --with-x-toolkit=athena"
                        myconf="${myconf} --without-gtk"
                elif use motif; then
                        einfo "Configuring to build with Motif toolkit"
                        myconf="${myconf} --with-x-toolkit=motif"
                        myconf="${myconf} --without-gtk"
                else
                        einfo "Configuring to build with no toolkit"
                        myconf="${myconf} --with-x-toolkit=no"
                        myconf="${myconf} --without-gtk"
                fi

                local f tk=
                for f in gtk Xaw3d motif; do
                        use ${f} || continue
                        [ "${tk}" ] \
                                && ewarn "USE flag \"${f}\" ignored (superseded 
by \"${tk}\")"
                        tk="${tk}${tk:+ }${f}"
                done
        else
                myconf="${myconf} --without-x"
        fi

        econf \
                --program-suffix=-${EMACS_SUFFIX} \
                --infodir=/usr/share/info/${EMACS_SUFFIX} \
                --localstatedir=/var \
                --enable-locallisppath="/etc/emacs:${SITELISP}" \
                --without-carbon \
                --with-gameuser="${GAMES_USER_DED:-games}" \
                $(use_with hesiod) \
                $(use_with kerberos) $(use_with kerberos kerberos5) \
                ${myconf}
}

src_compile() {
        export SANDBOX_ON=0                     # for the unbelievers, see Bug 
#131505
        emake CC="$(tc-getCC)"
}

src_install () {
        emake DESTDIR="${D}" install

        rm "${D}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
                || die "removing duplicate emacs executable failed"
        mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
                || die "moving emacs executable failed"

        # move man pages to the correct place
        local m
        mv "${D}"/usr/share/man/man1/{emacs,${EMACS_SUFFIX}}.1 \
                || die "moving emacs man page failed"
        for m in ctags emacsclient etags; do
                mv "${D}"/usr/share/man/man1/${m}{,-${EMACS_SUFFIX}}.1 \
                        || die "moving ${m} man page failed"
        done

        # move info dir to avoid collisions with the dir file generated by 
portage
        mv "${D}"/usr/share/info/${EMACS_SUFFIX}/dir{,.orig} \
                || die "moving info dir failed"
        touch "${D}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
        docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig

        # avoid collision between slots, see bug #169033 e.g.
        rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
        rm -rf "${D}"/var

        # remove unused <version>/site-lisp dir
        rm -rf "${D}"/usr/share/emacs/${FULL_VERSION}/site-lisp

        local c=";;"
        if use source; then
                insinto /usr/share/emacs/${FULL_VERSION}/src
                # This is not meant to install all the source -- just the
                # C source you might find via find-function
                doins src/*.[ch]
                c=""
        fi

        sed 's/^X//' >"${T}/${SITEFILE}" <<-EOF
        X
        ;;; ${PN}-${SLOT} site-lisp configuration
        X
        (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
        X  ${c}(setq find-function-C-source-directory
        X  ${c}      "/usr/share/emacs/${FULL_VERSION}/src")
        X  (let ((path (getenv "INFOPATH"))
        X       (dir "/usr/share/info/${EMACS_SUFFIX}")
        X       (re "\\\\\`/usr/share/info\\\\>"))
        X    (and path
        X        ;; move Emacs Info dir before anything else in /usr/share/info
        X        (let* ((p (cons nil (split-string path ":" t))) (q p))
        X          (while (and (cdr q) (not (string-match re (cadr q))))
        X            (setq q (cdr q)))
        X          (setcdr q (cons dir (delete dir (cdr q))))
        X          (setq Info-directory-list (prune-directory-list (cdr p)))))))
        EOF
        elisp-site-file-install "${T}/${SITEFILE}" || die

        dodoc AUTHORS BUGS CONTRIBUTE README
}

pkg_preinst() {
        # move Info dir file to correct name
        local infodir=/usr/share/info/${EMACS_SUFFIX} f
        if [ -f "${D}"${infodir}/dir.orig ]; then
                mv "${D}"${infodir}/dir{.orig,} || die "moving info dir failed"
        elif [[ -d "${D}"${infodir} ]]; then
                # this should not happen in EAPI 4
                ewarn "Regenerating Info directory index in ${infodir} ..."
                rm -f "${D}"${infodir}/dir{,.*}
                for f in "${D}"${infodir}/*; do
                        if [[ ${f##*/} != *-[0-9]* && -e ${f} ]]; then
                                install-info --info-dir="${D}"${infodir} "${f}" 
\
                                        || die "install-info failed"
                        fi
                done
        fi
}

pkg_postinst() {
        elisp-site-regen
        eselect emacs update ifunset

        if use X; then
                elog "You need to install some fonts for Emacs."
                elog "Installing media-fonts/font-adobe-{75,100}dpi on the X 
server's"
                elog "machine would satisfy basic Emacs requirements under X11."
                elog
        fi

        elog "You can set the version to be started by /usr/bin/emacs through"
        elog "the Emacs eselect module, which also redirects man and info 
pages."
        elog "Therefore, several Emacs versions can be installed at the same 
time."
        elog "\"man emacs.eselect\" for details."
}

pkg_postrm() {
        elisp-site-regen
        eselect emacs update ifunset
}



1.1                  app-editors/emacs/emacs-23.4-r8.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/emacs-23.4-r8.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/emacs-23.4-r8.ebuild?rev=1.1&content-type=text/plain

Index: emacs-23.4-r8.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.4-r8.ebuild,v 1.1 
2014/05/05 07:06:01 ulm Exp $

EAPI=5
WANT_AUTOMAKE="none"

inherit autotools elisp-common eutils flag-o-matic multilib readme.gentoo

DESCRIPTION="The extensible, customizable, self-documenting real-time display 
editor"
HOMEPAGE="http://www.gnu.org/software/emacs/";
SRC_URI="mirror://gnu/emacs/${P}.tar.bz2
        http://dev.gentoo.org/~ulm/emacs/${P}-patches-10.tar.xz";

LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="23"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc 
~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos 
~x86-macos"
IUSE="alsa aqua athena dbus games gconf gif gpm gtk gzip-el hesiod jpeg 
kerberos livecd m17n-lib motif pax_kernel png sound source svg tiff 
toolkit-scroll-bars X Xaw3d xft +xpm"
REQUIRED_USE="?? ( aqua X )"

RDEPEND="sys-libs/ncurses
        >=app-admin/eselect-emacs-1.16
        >=app-emacs/emacs-common-gentoo-1.4-r1[games?,X?]
        net-libs/liblockfile
        hesiod? ( net-dns/hesiod )
        kerberos? ( virtual/krb5 )
        alsa? ( media-libs/alsa-lib )
        gpm? ( sys-libs/gpm )
        dbus? ( sys-apps/dbus )
        X? (
                x11-libs/libXmu
                x11-libs/libXt
                x11-misc/xbitmaps
                gconf? ( >=gnome-base/gconf-2.26.2 )
                gif? ( media-libs/giflib )
                jpeg? ( virtual/jpeg:0= )
                png? ( >=media-libs/libpng-1.4:0= )
                svg? ( >=gnome-base/librsvg-2.0 )
                tiff? ( media-libs/tiff )
                xpm? ( x11-libs/libXpm )
                xft? (
                        media-libs/fontconfig
                        media-libs/freetype
                        x11-libs/libXft
                        m17n-lib? (
                                >=dev-libs/libotf-0.9.4
                                >=dev-libs/m17n-lib-1.5.1
                        )
                )
                gtk? ( x11-libs/gtk+:2 )
                !gtk? (
                        motif? ( >=x11-libs/motif-2.3:0 )
                        !motif? (
                                Xaw3d? ( x11-libs/libXaw3d )
                                !Xaw3d? ( athena? ( x11-libs/libXaw ) )
                        )
                )
        )"

DEPEND="${RDEPEND}
        alsa? ( virtual/pkgconfig )
        dbus? ( virtual/pkgconfig )
        X? ( virtual/pkgconfig )
        gzip-el? ( app-arch/gzip )
        pax_kernel? (
                sys-apps/attr
                sys-apps/paxctl
        )"

RDEPEND="${RDEPEND}
        !<app-editors/emacs-vcs-${PV}"

EMACS_SUFFIX="${PN/emacs/emacs-${SLOT}}"
SITEFILE="20${PN}-${SLOT}-gentoo.el"
# FULL_VERSION keeps the full version number, which is needed in
# order to determine some path information correctly for copy/move
# operations later on
FULL_VERSION="${PV%%_*}"
S="${WORKDIR}/emacs-${FULL_VERSION}"

src_prepare() {
        EPATCH_SUFFIX=patch epatch
        epatch_user

        sed -i -e "/^\\.so/s/etags/&-${EMACS_SUFFIX}/" doc/man/ctags.1 \
                || die "unable to sed ctags.1"

        if ! use alsa; then
                # ALSA is detected even if not requested by its USE flag.
                # Suppress it by supplying pkg-config with a wrong library name.
                sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
                        || die "unable to sed configure.in"
        fi
        if ! use gzip-el; then
                # Emacs' build system automatically detects the gzip binary and
                # compresses el files. We don't want that so confuse it with a
                # wrong binary name
                sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
                        || die "unable to sed configure.in"
        fi

        eautoreconf
}

src_configure() {
        strip-flags
        filter-flags -fstrict-aliasing
        append-flags $(test-flags -fno-strict-aliasing)

        if use sh; then
                replace-flags "-O[1-9]" -O0             #262359
        elif use ia64; then
                replace-flags "-O[2-9]" -O1             #325373
        else
                replace-flags "-O[3-9]" -O2
        fi

        local myconf

        if use alsa && ! use sound; then
                einfo "Although sound USE flag is disabled you chose to have 
alsa,"
                einfo "so sound is switched on anyway."
                myconf+=" --with-sound"
        else
                myconf+=" $(use_with sound)"
        fi

        if use X; then
                myconf+=" --with-x --without-ns"
                myconf+=" $(use_with gconf)"
                myconf+=" $(use_with toolkit-scroll-bars)"
                myconf+=" $(use_with gif)"
                myconf+=" $(use_with jpeg)"
                myconf+=" $(use_with png)"
                myconf+=" $(use_with svg rsvg)"
                myconf+=" $(use_with tiff)"
                myconf+=" $(use_with xpm)"

                if use xft; then
                        myconf+=" --with-xft"
                        myconf+=" $(use_with m17n-lib libotf)"
                        myconf+=" $(use_with m17n-lib m17n-flt)"
                else
                        myconf+=" --without-xft"
                        myconf+=" --without-libotf --without-m17n-flt"
                        use m17n-lib && ewarn \
                                "USE flag \"m17n-lib\" has no effect if \"xft\" 
is not set."
                fi

                # GTK+ is the default toolkit if USE=gtk is chosen with other
                # possibilities. Emacs upstream thinks this should be standard
                # policy on all distributions
                local f
                if use gtk; then
                        einfo "Configuring to build with GIMP Toolkit (GTK+)"
                        myconf+=" --with-x-toolkit=gtk"
                        for f in motif Xaw3d athena; do
                                use ${f} && ewarn \
                                        "USE flag \"${f}\" has no effect if 
\"gtk\" is set."
                        done
                elif use motif; then
                        einfo "Configuring to build with Motif toolkit"
                        myconf+=" --with-x-toolkit=motif"
                        for f in Xaw3d athena; do
                                use ${f} && ewarn \
                                        "USE flag \"${f}\" has no effect if 
\"motif\" is set."
                        done
                elif use athena || use Xaw3d; then
                        einfo "Configuring to build with Athena/Lucid toolkit"
                        myconf+=" --with-x-toolkit=lucid $(use_with Xaw3d 
xaw3d)"
                else
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"
                myconf+=" --without-x"
        else
                myconf+=" --without-x --without-ns"
        fi

        # Save version information in the Emacs binary. It will be available
        # in variable "system-configuration-options".
        myconf+=" GENTOO_PACKAGE=${CATEGORY}/${PF}"

        # According to configure, this option is only used for GNU/Linux
        # (x86_64 and s390). For Gentoo Prefix we have to explicitly spell
        # out the location because $(get_libdir) does not necessarily return
        # something that matches the host OS's libdir naming (e.g. RHEL).
        local crtdir=$($(tc-getCC) -print-file-name=crt1.o)
        crtdir=${crtdir%/*}

        econf \
                --program-suffix="-${EMACS_SUFFIX}" \
                --infodir="${EPREFIX}"/usr/share/info/${EMACS_SUFFIX} \
                --localstatedir="${EPREFIX}"/var \
                
--enable-locallisppath="${EPREFIX}/etc/emacs:${EPREFIX}${SITELISP}" \
                --with-crt-dir="${crtdir}" \
                --with-gameuser="${GAMES_USER_DED:-games}" \
                $(use_with hesiod) \
                $(use_with kerberos) $(use_with kerberos kerberos5) \
                $(use_with gpm) \
                $(use_with dbus) \
                ${myconf}
}

src_compile() {
        export SANDBOX_ON=0                     # for the unbelievers, see Bug 
#131505
        emake CC="$(tc-getCC)" \
                AR="$(tc-getAR) cq" \
                RANLIB="$(tc-getRANLIB)"
}

src_install () {
        emake DESTDIR="${D}" install

        rm "${ED}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
                || die "removing duplicate emacs executable failed"
        mv "${ED}"/usr/bin/emacs-${EMACS_SUFFIX} 
"${ED}"/usr/bin/${EMACS_SUFFIX} \
                || die "moving emacs executable failed"

        # move man pages to the correct place
        local m
        mv "${ED}"/usr/share/man/man1/{emacs,${EMACS_SUFFIX}}.1 \
                || die "moving emacs man page failed"
        for m in b2m ctags ebrowse emacsclient etags grep-changelog 
rcs-checkin; do
                mv "${ED}"/usr/share/man/man1/${m}{,-${EMACS_SUFFIX}}.1 \
                        || die "moving ${m} man page failed"
        done

        # move info dir to avoid collisions with the dir file generated by 
portage
        mv "${ED}"/usr/share/info/${EMACS_SUFFIX}/dir{,.orig} \
                || die "moving info dir failed"
        touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
        docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig

        # avoid collision between slots, see bug #169033 e.g.
        rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
        rm -rf "${ED}"/usr/share/{applications,icons}
        rm -rf "${ED}"/var

        # remove unused <version>/site-lisp dir
        rm -rf "${ED}"/usr/share/emacs/${FULL_VERSION}/site-lisp

        local cdir
        if use source; then
                cdir="/usr/share/emacs/${FULL_VERSION}/src"
                insinto "${cdir}"
                # This is not meant to install all the source -- just the
                # C source you might find via find-function
                doins src/*.{c,h,m}
                doins -r src/{m,s}
                rm "${ED}"/usr/share/emacs/${FULL_VERSION}/src/Makefile.c
                rm "${ED}"/usr/share/emacs/${FULL_VERSION}/src/{m,s}/README
        elif has installsources ${FEATURES}; then
                cdir="/usr/src/debug/${CATEGORY}/${PF}/${S#"${WORKDIR}/"}/src"
        fi

        sed -e "${cdir:+#}/^Y/d" -e "s/^[XY]//" >"${T}/${SITEFILE}" <<-EOF
        X
        ;;; ${PN}-${SLOT} site-lisp configuration
        X
        (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
        Y  (setq find-function-C-source-directory
        Y       "${EPREFIX}${cdir}")
        X  (let ((path (getenv "INFOPATH"))
        X       (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
        X       (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
        X    (and path
        X        ;; move Emacs Info dir before anything else in /usr/share/info
        X        (let* ((p (cons nil (split-string path ":" t))) (q p))
        X          (while (and (cdr q) (not (string-match re (cadr q))))
        X            (setq q (cdr q)))
        X          (setcdr q (cons dir (delete dir (cdr q))))
        X          (setq Info-directory-list (prune-directory-list (cdr p)))))))
        EOF
        elisp-site-file-install "${T}/${SITEFILE}" || die

        dodoc README BUGS

        if use aqua; then
                dodir /Applications/Gentoo
                rm -rf 
"${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app
                mv nextstep/Emacs.app \
                        
"${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app || die
        fi

        DOC_CONTENTS="You can set the version to be started by /usr/bin/emacs
                through the Emacs eselect module, which also redirects man and 
info
                pages. Therefore, several Emacs versions can be installed at the
                same time. \"man emacs.eselect\" for details.
                \\n\\nIf you upgrade from a previous major version of Emacs, 
then
                it is strongly recommended that you use app-admin/emacs-updater
                to rebuild all byte-compiled elisp files of the installed Emacs
                packages."
        use X && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
                Installing media-fonts/font-adobe-{75,100}dpi on the X server's
                machine would satisfy basic Emacs requirements under X11.
                See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
                for how to enable anti-aliased fonts."
        use aqua && DOC_CONTENTS+="\\n\\nEmacs${EMACS_SUFFIX#emacs}.app is in
                \"${EPREFIX}/Applications/Gentoo\". You may want to copy or 
symlink
                it into /Applications by yourself."
        readme.gentoo_create_doc
}

pkg_preinst() {
        # move Info dir file to correct name
        local infodir=/usr/share/info/${EMACS_SUFFIX} f
        if [[ -f ${ED}${infodir}/dir.orig ]]; then
                mv "${ED}"${infodir}/dir{.orig,} || die "moving info dir failed"
        elif [[ -d "${ED}"${infodir} ]]; then
                # this should not happen in EAPI 4
                ewarn "Regenerating Info directory index in ${infodir} ..."
                rm -f "${ED}"${infodir}/dir{,.*}
                for f in "${ED}"${infodir}/*; do
                        if [[ ${f##*/} != *-[0-9]* && -e ${f} ]]; then
                                install-info --info-dir="${ED}"${infodir} 
"${f}" \
                                        || die "install-info failed"
                        fi
                done
        fi
}

pkg_postinst() {
        elisp-site-regen
        readme.gentoo_print_elog

        if use livecd; then
                # force an update of the emacs symlink for the livecd/dvd,
                # because some microemacs packages set it with USE=livecd
                eselect emacs update
        elif [[ $(readlink "${EROOT}"/usr/bin/emacs) = ${EMACS_SUFFIX} ]]; then
                # refresh symlinks in case any installed files have changed
                eselect emacs set ${EMACS_SUFFIX}
        else
                eselect emacs update ifunset
        fi
}

pkg_postrm() {
        elisp-site-regen
        eselect emacs update ifunset
}



1.1                  app-editors/emacs/emacs-24.3-r4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/emacs-24.3-r4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-editors/emacs/emacs-24.3-r4.ebuild?rev=1.1&content-type=text/plain

Index: emacs-24.3-r4.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-24.3-r4.ebuild,v 1.1 
2014/05/05 07:06:01 ulm Exp $

EAPI=5

inherit autotools elisp-common eutils flag-o-matic multilib readme.gentoo

DESCRIPTION="The extensible, customizable, self-documenting real-time display 
editor"
HOMEPAGE="http://www.gnu.org/software/emacs/";
SRC_URI="mirror://gnu/emacs/${P}.tar.xz
        http://dev.gentoo.org/~ulm/emacs/${P}-patches-5.tar.xz";

LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="24"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc 
~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos"
IUSE="alsa aqua athena dbus games gconf gif gnutls gpm gsettings gtk +gtk3 
gzip-el hesiod imagemagick jpeg kerberos libxml2 livecd m17n-lib motif 
pax_kernel png selinux sound source svg tiff toolkit-scroll-bars wide-int X 
Xaw3d xft +xpm"
REQUIRED_USE="?? ( aqua X )"

RDEPEND="sys-libs/ncurses
        >=app-admin/eselect-emacs-1.16
        >=app-emacs/emacs-common-gentoo-1.4-r1[games?,X?]
        net-libs/liblockfile
        hesiod? ( net-dns/hesiod )
        kerberos? ( virtual/krb5 )
        alsa? ( media-libs/alsa-lib )
        gpm? ( sys-libs/gpm )
        dbus? ( sys-apps/dbus )
        gnutls? ( net-libs/gnutls )
        libxml2? ( >=dev-libs/libxml2-2.2.0 )
        selinux? ( sys-libs/libselinux )
        X? (
                x11-libs/libXmu
                x11-libs/libXt
                x11-misc/xbitmaps
                gconf? ( >=gnome-base/gconf-2.26.2 )
                gsettings? ( >=dev-libs/glib-2.28.6 )
                gif? ( media-libs/giflib )
                jpeg? ( virtual/jpeg:0= )
                png? ( >=media-libs/libpng-1.4:0= )
                svg? ( >=gnome-base/librsvg-2.0 )
                tiff? ( media-libs/tiff )
                xpm? ( x11-libs/libXpm )
                imagemagick? ( >=media-gfx/imagemagick-6.6.2 )
                xft? (
                        media-libs/fontconfig
                        media-libs/freetype
                        x11-libs/libXft
                        m17n-lib? (
                                >=dev-libs/libotf-0.9.4
                                >=dev-libs/m17n-lib-1.5.1
                        )
                )
                gtk? (
                        gtk3? ( x11-libs/gtk+:3 )
                        !gtk3? ( x11-libs/gtk+:2 )
                )
                !gtk? (
                        motif? ( >=x11-libs/motif-2.3:0 )
                        !motif? (
                                Xaw3d? ( x11-libs/libXaw3d )
                                !Xaw3d? ( athena? ( x11-libs/libXaw ) )
                        )
                )
        )"

DEPEND="${RDEPEND}
        app-arch/xz-utils
        alsa? ( virtual/pkgconfig )
        dbus? ( virtual/pkgconfig )
        gnutls? ( virtual/pkgconfig )
        libxml2? ( virtual/pkgconfig )
        X? ( virtual/pkgconfig )
        gzip-el? ( app-arch/gzip )
        pax_kernel? (
                sys-apps/attr
                sys-apps/paxctl
        )"

RDEPEND="${RDEPEND}
        !<app-editors/emacs-vcs-${PV}"

EMACS_SUFFIX="${PN/emacs/emacs-${SLOT}}"
SITEFILE="20${PN}-${SLOT}-gentoo.el"
# FULL_VERSION keeps the full version number, which is needed in
# order to determine some path information correctly for copy/move
# operations later on
FULL_VERSION="${PV%%_*}"
S="${WORKDIR}/emacs-${FULL_VERSION}"

src_prepare() {
        EPATCH_SUFFIX=patch epatch
        epatch_user

        sed -i -e "/^\\.so/s/etags/&-${EMACS_SUFFIX}/" doc/man/ctags.1 \
                || die "unable to sed ctags.1"

        if ! use alsa; then
                # ALSA is detected even if not requested by its USE flag.
                # Suppress it by supplying pkg-config with a wrong library name.
                sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.ac \
                        || die "unable to sed configure.ac"
        fi
        if ! use gzip-el; then
                # Emacs' build system automatically detects the gzip binary and
                # compresses el files. We don't want that so confuse it with a
                # wrong binary name
                sed -i -e "/AC_PATH_PROG/s/gzip/PrEvEnTcOmPrEsSiOn/" 
configure.ac \
                        || die "unable to sed configure.ac"
        fi

        AT_M4DIR=m4 eautoreconf
}

src_configure() {
        strip-flags

        if use sh; then
                replace-flags "-O[1-9]" -O0             #262359
        elif use ia64; then
                replace-flags "-O[2-9]" -O1             #325373
        else
                replace-flags "-O[3-9]" -O2
        fi

        local myconf

        if use alsa && ! use sound; then
                einfo "Although sound USE flag is disabled you chose to have 
alsa,"
                einfo "so sound is switched on anyway."
                myconf+=" --with-sound"
        else
                myconf+=" $(use_with sound)"
        fi

        if use X; then
                myconf+=" --with-x --without-ns"
                myconf+=" $(use_with gconf)"
                myconf+=" $(use_with gsettings)"
                myconf+=" $(use_with toolkit-scroll-bars)"
                myconf+=" $(use_with gif)"
                myconf+=" $(use_with jpeg)"
                myconf+=" $(use_with png)"
                myconf+=" $(use_with svg rsvg)"
                myconf+=" $(use_with tiff)"
                myconf+=" $(use_with xpm)"
                myconf+=" $(use_with imagemagick)"

                if use xft; then
                        myconf+=" --with-xft"
                        myconf+=" $(use_with m17n-lib libotf)"
                        myconf+=" $(use_with m17n-lib m17n-flt)"
                else
                        myconf+=" --without-xft"
                        myconf+=" --without-libotf --without-m17n-flt"
                        use m17n-lib && ewarn \
                                "USE flag \"m17n-lib\" has no effect if \"xft\" 
is not set."
                fi

                local f
                if use gtk; then
                        einfo "Configuring to build with GIMP Toolkit (GTK+)"
                        myconf+=" --with-x-toolkit=$(usex gtk3 gtk3 gtk2)"
                        for f in motif Xaw3d athena; do
                                use ${f} && ewarn \
                                        "USE flag \"${f}\" has no effect if 
\"gtk\" is set."
                        done
                elif use motif; then
                        einfo "Configuring to build with Motif toolkit"
                        myconf+=" --with-x-toolkit=motif"
                        for f in Xaw3d athena; do
                                use ${f} && ewarn \
                                        "USE flag \"${f}\" has no effect if 
\"motif\" is set."
                        done
                elif use athena || use Xaw3d; then
                        einfo "Configuring to build with Athena/Lucid toolkit"
                        myconf+=" --with-x-toolkit=lucid $(use_with Xaw3d 
xaw3d)"
                else
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"
                myconf+=" --without-x"
        else
                myconf+=" --without-x --without-ns"
        fi

        # Save version information in the Emacs binary. It will be available
        # in variable "system-configuration-options".
        myconf+=" GENTOO_PACKAGE=${CATEGORY}/${PF}"

        # According to configure, this option is only used for GNU/Linux
        # (x86_64 and s390). For Gentoo Prefix we have to explicitly spell
        # out the location because $(get_libdir) does not necessarily return
        # something that matches the host OS's libdir naming (e.g. RHEL).
        local crtdir=$($(tc-getCC) -print-file-name=crt1.o)
        crtdir=${crtdir%/*}

        econf \
                --program-suffix="-${EMACS_SUFFIX}" \
                --infodir="${EPREFIX}"/usr/share/info/${EMACS_SUFFIX} \
                --localstatedir="${EPREFIX}"/var \
                
--enable-locallisppath="${EPREFIX}/etc/emacs:${EPREFIX}${SITELISP}" \
                --with-crt-dir="${crtdir}" \
                --with-gameuser="${GAMES_USER_DED:-games}" \
                --without-compress-info \
                $(use_with hesiod) \
                $(use_with kerberos) $(use_with kerberos kerberos5) \
                $(use_with gpm) \
                $(use_with dbus) \
                $(use_with gnutls) \
                $(use_with libxml2 xml2) \
                $(use_with selinux) \
                $(use_with wide-int) \
                ${myconf}
}

src_compile() {
        export SANDBOX_ON=0                     # for the unbelievers, see Bug 
#131505
        emake
}

src_install () {
        emake DESTDIR="${D}" NO_BIN_LINK=t install

        mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} \
                || die "moving emacs executable failed"
        mv "${ED}"/usr/share/man/man1/{emacs-,}${EMACS_SUFFIX}.1 \
                || die "moving emacs man page failed"

        # move info dir to avoid collisions with the dir file generated by 
portage
        mv "${ED}"/usr/share/info/${EMACS_SUFFIX}/dir{,.orig} \
                || die "moving info dir failed"
        touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
        docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig

        # avoid collision between slots, see bug #169033 e.g.
        rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
        rm -rf "${ED}"/usr/share/{applications,icons}
        rm -rf "${ED}"/var

        # remove unused <version>/site-lisp dir
        rm -rf "${ED}"/usr/share/emacs/${FULL_VERSION}/site-lisp

        local cdir
        if use source; then
                cdir="/usr/share/emacs/${FULL_VERSION}/src"
                insinto "${cdir}"
                # This is not meant to install all the source -- just the
                # C source you might find via find-function
                doins src/*.{c,h,m}
        elif has installsources ${FEATURES}; then
                cdir="/usr/src/debug/${CATEGORY}/${PF}/${S#"${WORKDIR}/"}/src"
        fi

        sed -e "${cdir:+#}/^Y/d" -e "s/^[XY]//" >"${T}/${SITEFILE}" <<-EOF
        X
        ;;; ${PN}-${SLOT} site-lisp configuration
        X
        (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
        Y  (setq find-function-C-source-directory
        Y       "${EPREFIX}${cdir}")
        X  (let ((path (getenv "INFOPATH"))
        X       (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
        X       (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
        X    (and path
        X        ;; move Emacs Info dir before anything else in /usr/share/info
        X        (let* ((p (cons nil (split-string path ":" t))) (q p))
        X          (while (and (cdr q) (not (string-match re (cadr q))))
        X            (setq q (cdr q)))
        X          (setcdr q (cons dir (delete dir (cdr q))))
        X          (setq Info-directory-list (prune-directory-list (cdr p)))))))
        EOF
        elisp-site-file-install "${T}/${SITEFILE}" || die

        dodoc README BUGS

        if use aqua; then
                dodir /Applications/Gentoo
                rm -rf 
"${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app
                mv nextstep/Emacs.app \
                        
"${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app || die
        fi

        DOC_CONTENTS="You can set the version to be started by /usr/bin/emacs
                through the Emacs eselect module, which also redirects man and 
info
                pages. Therefore, several Emacs versions can be installed at the
                same time. \"man emacs.eselect\" for details.
                \\n\\nIf you upgrade from Emacs version 24.2 or earlier, then 
it is
                strongly recommended that you use app-admin/emacs-updater to 
rebuild
                all byte-compiled elisp files of the installed Emacs packages."
        use X && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
                Installing media-fonts/font-adobe-{75,100}dpi on the X server's
                machine would satisfy basic Emacs requirements under X11.
                See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
                for how to enable anti-aliased fonts."
        use aqua && DOC_CONTENTS+="\\n\\nEmacs${EMACS_SUFFIX#emacs}.app is in
                \"${EPREFIX}/Applications/Gentoo\". You may want to copy or 
symlink
                it into /Applications by yourself."
        readme.gentoo_create_doc
}

pkg_preinst() {
        # move Info dir file to correct name
        local infodir=/usr/share/info/${EMACS_SUFFIX} f
        if [[ -f ${ED}${infodir}/dir.orig ]]; then
                mv "${ED}"${infodir}/dir{.orig,} || die "moving info dir failed"
        elif [[ -d "${ED}"${infodir} ]]; then
                # this should not happen in EAPI 4
                ewarn "Regenerating Info directory index in ${infodir} ..."
                rm -f "${ED}"${infodir}/dir{,.*}
                for f in "${ED}"${infodir}/*; do
                        if [[ ${f##*/} != *-[0-9]* && -e ${f} ]]; then
                                install-info --info-dir="${ED}"${infodir} 
"${f}" \
                                        || die "install-info failed"
                        fi
                done
        fi
}

pkg_postinst() {
        elisp-site-regen

        local pvr
        for pvr in ${REPLACING_VERSIONS}; do
                [[ ${pvr%%[-_]*} = 24.[12] ]] && FORCE_PRINT_ELOG=1
        done
        readme.gentoo_print_elog

        if use livecd; then
                # force an update of the emacs symlink for the livecd/dvd,
                # because some microemacs packages set it with USE=livecd
                eselect emacs update
        elif [[ $(readlink "${EROOT}"/usr/bin/emacs) = ${EMACS_SUFFIX} ]]; then
                # refresh symlinks in case any installed files have changed
                eselect emacs set ${EMACS_SUFFIX}
        else
                eselect emacs update ifunset
        fi
}

pkg_postrm() {
        elisp-site-regen
        eselect emacs update ifunset
}




Reply via email to