titanofold    14/11/16 14:55:06

  Added:                metadata.xml ChangeLog pgrouting-2.0.0.ebuild
                        Manifest
  Log:
  New ebuild written by Benjamin Börngen-Schmidt with some tweaks by me. Fixes
  bug 527058.
  
  (Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 
D1BBFDA0)

Revision  Changes    Path
1.1                  dev-db/pgrouting/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
  <herd>postgresql</herd>
  <use>
    <flag name='html'>Install HTML formatted documentation</flag>
    <flag name='drivingdistance'>Enable to calculate driving distance</flag>
  </use>
</pkgmetadata>



1.1                  dev-db/pgrouting/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for dev-db/pgrouting
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/pgrouting/ChangeLog,v 1.1 2014/11/16 
14:55:06 titanofold Exp $

*pgrouting-2.0.0 (16 Nov 2014)

  16 Nov 2014; Aaron W. Swenson <titanof...@gentoo.org>
  +pgrouting-2.0.0.ebuild, +files/no-contrib-when-use-extension.patch,
  +metadata.xml:
  New ebuild written by Benjamin Börngen-Schmidt with some tweaks by me. Fixes
  bug 527058.




1.1                  dev-db/pgrouting/pgrouting-2.0.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/pgrouting-2.0.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/pgrouting-2.0.0.ebuild?rev=1.1&content-type=text/plain

Index: pgrouting-2.0.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/pgrouting/pgrouting-2.0.0.ebuild,v 
1.1 2014/11/16 14:55:06 titanofold Exp $

EAPI="5"
POSTGRES_COMPAT=( 9.{0,1,2,3,4} )

inherit eutils cmake-utils

DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing 
functionality."
HOMEPAGE="http://pgrouting.org/index.html";
LICENSE="GPL-2 MIT Boost-1.0"

SLOT="0"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pgRouting/pgrouting/archive/v${PV}.tar.gz -> 
${PN}-${PV}.tar.gz"
IUSE="+drivingdistance doc pdf html"

REQUIRED_USE="html? ( doc ) pdf? ( doc )"

RDEPEND="
        || (
                virtual/postgresql:9.4[server]
                virtual/postgresql:9.3[server]
                virtual/postgresql:9.2[server]
                virtual/postgresql:9.1[server]
                virtual/postgresql:9.0[server]
        )
        >=dev-db/postgis-2.0
        dev-libs/boost
        drivingdistance? ( sci-mathematics/cgal )
"

DEPEND="
        doc? ( >=dev-python/sphinx-1.1 )
        pdf? ( >=dev-python/sphinx-1.1[latex] )
"

# Needs a running psql instance, doesn't work out of the box
RESTRICT="test"
CMAKE_MIN_VERSION="2.8.8"

postgres_check_slot() {
        if ! declare -p POSTGRES_COMPAT &>/dev/null; then
                die 'POSTGRES_COMPAT not declared.'
        fi

# Don't die because we can't run postgresql-config during pretend.
[[ "$EBUILD_PHASE" = "pretend" \
        && -z "$(which postgresql-config 2> /dev/null)" ]] && return 0

        local res=$(echo ${POSTGRES_COMPAT[@]} \
                | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)

        if [[ "$res" -eq "0" ]] ; then
                        eerror "PostgreSQL slot must be set to one of: "
                        eerror "    ${POSTGRES_COMPAT[@]}"
                        return 1
        fi

        return 0
}

pkg_pretend() {
        postgres_check_slot || die
}

pkg_setup() {
        postgres_check_slot || die
}

src_prepare() {
        epatch "${FILESDIR}/no-contrib-when-use-extension.patch"
}

src_configure() {
        local mycmakeargs=(
                $(cmake-utils_use_with drivingdistance DD)
                $(cmake-utils_use_with doc DOC)
                $(cmake-utils_use_build doc MAN)
                $(cmake-utils_use_build html HTML)
                $(cmake-utils_use_build pdf LATEX)
        )

        cmake-utils_src_configure
}

src_compile() {
        local make_opts
        use doc && make_opts="all doc"
        cmake-utils_src_make ${make_opts}
}

src_install() {
        use doc && doman "${BUILD_DIR}"/doc/man/en/pgrouting.7
        use html && dohtml -r "${BUILD_DIR}"/doc/html/*
        use pdf && dodoc "${BUILD_DIR}"/doc/latex/en/*.pdf

        dodoc README* VERSION

        cmake-utils_src_install
}



1.1                  dev-db/pgrouting/Manifest

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/Manifest?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgrouting/Manifest?rev=1.1&content-type=text/plain

Index: Manifest
===================================================================
AUX no-contrib-when-use-extension.patch 3077 SHA256 
7d467aeb6f7701c4aff0e2034d28d7314152f7c654da547593260542533b7867 SHA512 
be0e5ad3fe44c8138e44ee61744fb57e9d759cc066619bc0e2d1758d26ef075b88cb52ccea6b6f2e2b5af7e0d5db982a0da0762c54dabccf9f71116ffbad87f4
 WHIRLPOOL 
5693233ba778f4ed0284649b749ed422fc9832b047f31aa644b7f9d24218e59e513474897a5c4745e6b9f96b118ffea5402bf305377d60f3c68b1e1fa053a196
DIST pgrouting-2.0.0.tar.gz 3765933 SHA256 
606309e8ece04abec062522374b48179c16bddb30dd4c5080b89a4298e8d163b SHA512 
4a74cc1ce1bbbb8d95ae2aabc712e30c97e0418b1e4f28a255ecd9e57577bd7081a52e6e64a63cb06c9ca659271273b37bdbefb94d49e69b9c2ce45e96911884
 WHIRLPOOL 
ce7492fe1512f7829bd887a7acaadc6c276719fc7e00ceb68a702a2476a9464c83bf929ef78381c8d36a6575dee21587c204f798511e1430731064c2c48a0815
EBUILD pgrouting-2.0.0.ebuild 2327 SHA256 
f35ac6331a76fbd11afa56af26c7083f59e2572b1c63f022756b2329c9efba82 SHA512 
90a4a34b5528659c5aed94199f7c32c4949e31b2749601c6998475424b8bcee1db8acba06b900bf7c385e48cfcd785b98fce79133b435f362a452b34bd0720df
 WHIRLPOOL 
80f66022e7577fe294c72fe5dd7821500ac0aa46218c9ff4382c563be15095d725cfbc723895a57f856d8cd387711bdc00a41452b768eb1be3859cf145bde882
MISC ChangeLog 388 SHA256 
f4c44f07479ff42314f1daf62ad6527b034a50d2bbe59d7571a62ef254079aab SHA512 
d26c3cb3101604e4f89c78f9d18447b5bb727549b7aa3ba97096d9193d7a6e4afd4721bea2b458a1cc83547d756f2b6a93f0e88621150e4210c6143e0e3c61dd
 WHIRLPOOL 
730c52ca07154b2aead37c69fbf01bccbedb22e23eab5342c52ae43626f363ee34efbb7286d12c42d18c0ed08a1f1b9c7a100ce00fd02eb68726b6f64ecc90f0
MISC metadata.xml 325 SHA256 
a1a9a71fe05d3866da7dd05b0fbddacf1cfdbb73b8e876f5c3db3f0b47c482d7 SHA512 
0b419bb16f39e645ec0c6d56f98d2b01a16d7b43220528139d2b0dca132032403ea34e56d5dc149615a46d16dc52dda0e1ccc9b76ae82437e3245e8b78de3a71
 WHIRLPOOL 
b9c0bc4b8550f149a3d783467f900f9c120a87c7c4538359c851eb188242a2cdc3151198891b173d4596aa7d31e8d96dcc270f8c634cb67a7f90cfaa8ad5ad4d




Reply via email to