jmbsvicetto    14/05/26 10:28:12

  Modified:             ChangeLog
  Added:                phpmyadmin-4.1.14.ebuild phpmyadmin-4.2.2.ebuild
  Log:
  Add 4.1.14 and 4.2.2 releases.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BB0E6E98)

Revision  Changes    Path
1.510                dev-db/phpmyadmin/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/ChangeLog?rev=1.510&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/ChangeLog?rev=1.510&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/ChangeLog?r1=1.509&r2=1.510

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v
retrieving revision 1.509
retrieving revision 1.510
diff -u -r1.509 -r1.510
--- ChangeLog   24 Mar 2014 14:29:02 -0000      1.509
+++ ChangeLog   26 May 2014 10:28:12 -0000      1.510
@@ -1,6 +1,13 @@
 # ChangeLog for dev-db/phpmyadmin
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.509 
2014/03/24 14:29:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.510 
2014/05/26 10:28:12 jmbsvicetto Exp $
+
+*phpmyadmin-4.2.2 (26 May 2014)
+*phpmyadmin-4.1.14 (26 May 2014)
+
+  26 May 2014; Jorge Manuel B. S. Vicetto <jmbsvice...@gentoo.org>
+  +phpmyadmin-4.1.14.ebuild, +phpmyadmin-4.2.2.ebuild:
+  Add 4.1.14 and 4.2.2 releases.
 
   24 Mar 2014; Agostino Sarubbo <a...@gentoo.org> phpmyadmin-4.1.7.ebuild:
   Stable for ppc64, wrt bug #502002



1.1                  dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild?rev=1.1&content-type=text/plain

Index: phpmyadmin-4.1.14.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild,v 
1.1 2014/05/26 10:28:12 jmbsvicetto Exp $

EAPI="4"

inherit eutils webapp depend.php

MY_PV=${PV/_/-}
MY_P="phpMyAdmin-${MY_PV}-all-languages"

DESCRIPTION="Web-based administration for MySQL database in PHP"
HOMEPAGE="http://www.phpmyadmin.net/";
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~ppc-macos ~x64-macos ~x86-macos"
IUSE="setup"

RDEPEND="
        dev-lang/php[crypt,ctype,filter,json,session,unicode]
        || (
                dev-lang/php[mysqli]
                dev-lang/php[mysql]
        )
"

need_httpd_cgi
need_php_httpd

S="${WORKDIR}"/${MY_P}

pkg_setup() {
        webapp_pkg_setup
}

src_install() {
        webapp_src_preinst

        dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
        rm -f LICENSE README* RELEASE-DATE-${MY_PV}

        if ! use setup; then
                rm -rf setup || die "Cannot remove setup utility"
                elog "The phpMyAdmin setup utility has been removed."
                elog "It is a regular target of various exploits. If you need 
it, set USE=setup."
        else
                elog "You should consider disabling the setup USE flag"
                elog "to exclude the setup utility if you don't use it."
                elog "It regularly is the target of various exploits."
        fi

        insinto "${MY_HTDOCSDIR#${EPREFIX}}"
        doins -r .

        webapp_configfile 
"${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
        webapp_serverowned 
"${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php

        webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
        webapp_src_install
}



1.1                  dev-db/phpmyadmin/phpmyadmin-4.2.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.2.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.2.2.ebuild?rev=1.1&content-type=text/plain

Index: phpmyadmin-4.2.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.2.2.ebuild,v 
1.1 2014/05/26 10:28:12 jmbsvicetto Exp $

EAPI="4"

inherit eutils webapp depend.php

MY_PV=${PV/_/-}
MY_P="phpMyAdmin-${MY_PV}-all-languages"

DESCRIPTION="Web-based administration for MySQL database in PHP"
HOMEPAGE="http://www.phpmyadmin.net/";
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~ppc-macos ~x64-macos ~x86-macos"
IUSE="setup"

RDEPEND="
        dev-lang/php[crypt,ctype,filter,json,session,unicode]
        || (
                dev-lang/php[mysqli]
                dev-lang/php[mysql]
        )
"

need_httpd_cgi
need_php_httpd

S="${WORKDIR}"/${MY_P}

pkg_setup() {
        webapp_pkg_setup
}

src_install() {
        webapp_src_preinst

        dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
        rm -f LICENSE README* RELEASE-DATE-${MY_PV}

        if ! use setup; then
                rm -rf setup || die "Cannot remove setup utility"
                elog "The phpMyAdmin setup utility has been removed."
                elog "It is a regular target of various exploits. If you need 
it, set USE=setup."
        else
                elog "You should consider disabling the setup USE flag"
                elog "to exclude the setup utility if you don't use it."
                elog "It regularly is the target of various exploits."
        fi

        insinto "${MY_HTDOCSDIR#${EPREFIX}}"
        doins -r .

        webapp_configfile 
"${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
        webapp_serverowned 
"${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php

        webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
        webapp_src_install
}




Reply via email to