ercpe       14/07/15 07:50:55

  Modified:             netty-common-4.0.19.ebuild ChangeLog
  Added:                netty-common-4.0.21.ebuild
  Log:
  Version bump (bug #515854), dropped code for the failing tests, cleaned 
things up (in 4.0.19 too)
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
77C501ED)

Revision  Changes    Path
1.2                  dev-java/netty-common/netty-common-4.0.19.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/netty-common-4.0.19.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/netty-common-4.0.19.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/netty-common-4.0.19.ebuild?r1=1.1&r2=1.2

Index: netty-common-4.0.19.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/dev-java/netty-common/netty-common-4.0.19.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- netty-common-4.0.19.ebuild  19 May 2014 12:35:12 -0000      1.1
+++ netty-common-4.0.19.ebuild  15 Jul 2014 07:50:55 -0000      1.2
@@ -1,10 +1,10 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/dev-java/netty-common/netty-common-4.0.19.ebuild,v 1.1 
2014/05/19 12:35:12 tomwij Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/dev-java/netty-common/netty-common-4.0.19.ebuild,v 1.2 
2014/07/15 07:50:55 ercpe Exp $
 
 EAPI="5"
 
-JAVA_PKG_IUSE="doc source test"
+JAVA_PKG_IUSE="doc source"
 
 inherit java-pkg-2 java-ant-2
 
@@ -16,26 +16,22 @@
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
 
-RDEPEND=">=virtual/jre-1.6"
-
-DEPEND=">=virtual/jdk-1.6
-       dev-java/commons-logging:0
+CDEPEND="dev-java/commons-logging:0
        dev-java/javassist:3
        dev-java/log4j:0
-       dev-java/slf4j-api:0
-       test? (
-               dev-java/ant-core:0
-               dev-java/easymock:3.2
-               dev-java/junit:4
-       )"
+       dev-java/slf4j-api:0"
+RDEPEND=">=virtual/jre-1.6
+               ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+               ${CDEPEND}"
 
 S="${WORKDIR}/${MY_PN}-${MY_P}.Final/${PN/${MY_PN}-}"
 
 EANT_BUILD_TARGET="package"
 JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_TEST_EXTRA_ARGS+=" -Djunit.present=true"
+EANT_GENTOO_CLASSPATH="commons-logging,log4j,javassist-3,slf4j-api"
 
 # Tests fail as they might need logging to be properly set up and/or 
compatible.
 #
@@ -44,23 +40,12 @@
 RESTRICT="test"
 
 java_prepare() {
-       EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjars --build-only 
commons-logging,log4j,javassist-3,slf4j-api)"
-
        cp "${FILESDIR}"/${P}-build.xml build.xml || die
-
-       # Remove the odd memory restriction in the generated build files.
-       sed -i 's/memoryMaximumSize="256m"//' build.xml || die
-}
-
-src_test() {
-       EANT_EXTRA_ARGS="${EANT_EXTRA_ARGS}:$(java-pkg_getjars --build-only 
ant-core,easymock-3.2,junit-4)"
-
-       ANT_TASKS="ant-junit" java-pkg-2_src_test
 }
 
 src_install() {
        java-pkg_newjar target/${MY_PN}-*.jar ${PN}.jar
 
        use doc && java-pkg_dojavadoc target/site/apidocs
-       use source && java-pkg_dosrc src/main/java
+       use source && java-pkg_dosrc src/main/java/*
 }



1.2                  dev-java/netty-common/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/ChangeLog?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/ChangeLog?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/ChangeLog?r1=1.1&r2=1.2

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-java/netty-common/ChangeLog,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- ChangeLog   19 May 2014 12:35:12 -0000      1.1
+++ ChangeLog   15 Jul 2014 07:50:55 -0000      1.2
@@ -1,6 +1,14 @@
 # ChangeLog for dev-java/netty-common
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/netty-common/ChangeLog,v 1.1 
2014/05/19 12:35:12 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netty-common/ChangeLog,v 1.2 
2014/07/15 07:50:55 ercpe Exp $
+
+*netty-common-4.0.21 (15 Jul 2014)
+
+  15 Jul 2014; Johann Schmitz <er...@gentoo.org>
+  +files/netty-common-4.0.21-build.xml, +netty-common-4.0.21.ebuild,
+  files/netty-common-4.0.19-build.xml, netty-common-4.0.19.ebuild:
+  Version bump (bug #515854), dropped code for the failing tests, cleaned 
things
+  up (in 4.0.19 too)
 
 *netty-common-4.0.19 (19 May 2014)
 



1.1                  dev-java/netty-common/netty-common-4.0.21.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/netty-common-4.0.21.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/netty-common/netty-common-4.0.21.ebuild?rev=1.1&content-type=text/plain

Index: netty-common-4.0.21.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-java/netty-common/netty-common-4.0.21.ebuild,v 1.1 
2014/07/15 07:50:55 ercpe Exp $

EAPI="5"

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-ant-2

MY_PN="netty"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Async event-driven framework for rapid development of high 
performance network applications"
HOMEPAGE="http://netty.io/";
SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_P}.Final.tar.gz";

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

CDEPEND="dev-java/commons-logging:0
        dev-java/javassist:3
        dev-java/log4j:0
        dev-java/slf4j-api:0"
RDEPEND=">=virtual/jre-1.6
                ${CDEPEND}"
DEPEND=">=virtual/jdk-1.6
                ${CDEPEND}"

S="${WORKDIR}/${MY_PN}-${MY_P}.Final/${PN/${MY_PN}-}"

EANT_BUILD_TARGET="package"
JAVA_ANT_REWRITE_CLASSPATH="true"
EANT_GENTOO_CLASSPATH="commons-logging,log4j,javassist-3,slf4j-api"

# Tests fail as they might need logging to be properly set up and/or compatible.
#
# junit.framework.AssertionFailedError: expected:<[foo]> but was:<[NOP]>
# at io.netty.util.internal.logging.Slf4JLoggerFactoryTest.testCreation
RESTRICT="test"

java_prepare() {
        #EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjars --build-only 
commons-logging,log4j,javassist-3,slf4j-api)"
        cp "${FILESDIR}"/${P}-build.xml build.xml || die
}

src_install() {
        java-pkg_newjar target/${MY_PN}-*.jar ${PN}.jar

        use doc && java-pkg_dojavadoc target/site/apidocs
        use source && java-pkg_dosrc src/main/java/*
}




Reply via email to