eva         14/09/27 21:29:11

  Added:                metadata.xml appstream-glib-0.3.0.ebuild ChangeLog
                        Manifest
  Log:
  Initial commit, required by newer appdata-tools.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
C6085806)

Revision  Changes    Path
1.1                  dev-libs/appstream-glib/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
<herd>gnome</herd>
</pkgmetadata>



1.1                  dev-libs/appstream-glib/appstream-glib-0.3.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/appstream-glib-0.3.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/appstream-glib-0.3.0.ebuild?rev=1.1&content-type=text/plain

Index: appstream-glib-0.3.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-libs/appstream-glib/appstream-glib-0.3.0.ebuild,v 
1.1 2014/09/27 21:29:11 eva Exp $

EAPI=5

inherit autotools eutils bash-completion-r1

MY_P="${PN/-/_}_${PV//./_}"

DESCRIPTION="Provides GObjects and helper methods to read and write AppStream 
metadata"
HOMEPAGE="https://github.com/hughsie/appstream-glib";
SRC_URI="https://github.com/hughsie/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0/7"
KEYWORDS="~amd64"
IUSE="+introspection nls"

# FIXME: yaml is optional but not properly handled in autofoo
RDEPEND="
        app-arch/libarchive
        dev-db/sqlite:3
        >=dev-libs/glib-2.16.1:2
        media-libs/fontconfig
        >=media-libs/freetype-2.4:2
        >=net-libs/libsoup-2.24:2.4
        >=x11-libs/gdk-pixbuf-2.14:2
        x11-libs/gtk+:3
        x11-libs/pango
        dev-libs/libyaml
        introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
"
DEPEND="${RDEPEND}
        app-text/docbook-xml-dtd:4.3
        dev-libs/libxslt
        >=dev-util/gtk-doc-am-1.9
        >=dev-util/intltool-0.40
        >=sys-devel/gettext-0.17
"

S="${WORKDIR}/${PN}-${MY_P}"

src_prepare() {
        eautoreconf
}

src_configure() {
        econf \
                --disable-rpm \
                --disable-static \
                --enable-dep11 \
                --enable-man \
                $(use_enable nls) \
                $(use_enable introspection) \
                --with-bashcompletiondir="$(get_bashcompdir)"
}

src_install() {
        emake install DESTDIR="${D}"

        prune_libtool_files
}



1.1                  dev-libs/appstream-glib/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for dev-libs/appstream-glib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/appstream-glib/ChangeLog,v 1.1 
2014/09/27 21:29:11 eva Exp $

*appstream-glib-0.3.0 (27 Sep 2014)

  27 Sep 2014; Gilles Dartiguelongue <e...@gentoo.org>
  +appstream-glib-0.3.0.ebuild, +metadata.xml:
  Initial commit, required by newer appdata-tools.




1.1                  dev-libs/appstream-glib/Manifest

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/Manifest?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/appstream-glib/Manifest?rev=1.1&content-type=text/plain

Index: Manifest
===================================================================
DIST appstream-glib-0.3.0.tar.gz 1837336 SHA256 
0bc7043d97974a70ddd9e383ff74c7aa2da6d663783e43250668c2228a7a1616 SHA512 
55617248a7331fd2c51da6325eb3a704bf0da0f9e99f0c2c1b020988f4f5def72e1cceda801d5d4798fe1ac829defa88c01d9abb2dd68ebd880139ef41e3d204
 WHIRLPOOL 
eed8ba5a24986a8e5ae25be759eead71780ff8f7abe874370dbcfb805070b01b90fef6cae623e03e48d7b322917c65eee595acca64bfa99274e1f3aff8b6f710
EBUILD appstream-glib-0.3.0.ebuild 1348 SHA256 
ea3005019f4761f7c9565420449534b5df68af1c9ef06a3f6d672607a8ea73f4 SHA512 
6bd8a9687bf1d8471468542d8f16a0937289507921df1fde8d74bbb791df2def1ebf4345ebe691a97ba612842e6141b6485c911b52ee6dc9ae00f87402958836
 WHIRLPOOL 
6873984bd52c5a6a0520087d40e0e70c68a67014cdcc36724e6ff7df23b0602b6590a1b1178b8a1c49eec8c0804690465de966e1a046a29d91a766c645cc1286
MISC ChangeLog 314 SHA256 
dd1ce1fc79ca9b56cff9e647ae64f6656d02c4a4eac1297dac8e3ff845f8bf71 SHA512 
d57efbed6744bc3c073a1fbf54672a536c39dcbe9daeedafbf962b026bea2f5402308d4c1760598bc16ff21cf647d09f4e26fd0bf2836a9ccf2350928e0ed750
 WHIRLPOOL 
194459d5b1f4a305a18dc98708f9c59479903411a8079e57d336f8042bf712f6f1f192e98cb4556f77b16f0ab29125e8934d7b720dc6960242f79c87e52d98c2
MISC metadata.xml 158 SHA256 
3a7dbca0fdc557de69783e0663e2d76ddab129ea8a19b2d0ef6d3e5d1b947ce1 SHA512 
7fbfbd2b3ed1b81867d55648509f778fdbe2091af53727b3426a3c7f453ae7e1663a99fdd2101508b8d6c85b3158459c93551b77a6a394f02d7e11cbc8a5ecf4
 WHIRLPOOL 
4bcd5662974877d42ebc4361b6eb412bfeea2af7144b436ce7ed152327d554afc321c376625ba0bb85a704b70d86e3c4882dff3573047acddd8ffccf655d4f7e




Reply via email to