kensington    14/12/26 11:05:56

  Modified:             ChangeLog
  Added:                grantlee-5.0.0.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
0x06B1F38DCA45A1EC!)

Revision  Changes    Path
1.28                 dev-libs/grantlee/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/grantlee/ChangeLog?rev=1.28&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/grantlee/ChangeLog?rev=1.28&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/grantlee/ChangeLog?r1=1.27&r2=1.28

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v
retrieving revision 1.27
retrieving revision 1.28
diff -u -r1.27 -r1.28
--- ChangeLog   5 Feb 2014 17:16:43 -0000       1.27
+++ ChangeLog   26 Dec 2014 11:05:56 -0000      1.28
@@ -1,6 +1,12 @@
 # ChangeLog for dev-libs/grantlee
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.27 
2014/02/05 17:16:43 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.28 
2014/12/26 11:05:56 kensington Exp $
+
+*grantlee-5.0.0 (26 Dec 2014)
+
+  26 Dec 2014; Michael Palimaka <kensing...@gentoo.org>
+  +files/grantlee-slot.patch, +grantlee-5.0.0.ebuild:
+  Version bump.
 
 *grantlee-0.4.0 (05 Feb 2014)
 



1.1                  dev-libs/grantlee/grantlee-5.0.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/grantlee/grantlee-5.0.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/grantlee/grantlee-5.0.0.ebuild?rev=1.1&content-type=text/plain

Index: grantlee-5.0.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-5.0.0.ebuild,v 
1.1 2014/12/26 11:05:56 kensington Exp $

EAPI=5

VIRTUALX_REQUIRED="test"
inherit cmake-utils virtualx

DESCRIPTION="C++ string template engine based on the Django template system"
HOMEPAGE="http://www.gitorious.org/grantlee/pages/Home";
SRC_URI="http://downloads.grantlee.org/${P}.tar.gz";

LICENSE="LGPL-2.1"
SLOT="5"
KEYWORDS="~amd64"
IUSE="debug doc test"

RDEPEND="
        dev-qt/qtcore:5
        dev-qt/qtgui:5
        dev-qt/qtscript:5
"
DEPEND="${RDEPEND}
        doc? ( app-doc/doxygen[dot] )
        test? ( dev-qt/qttest:5 )
"

DOCS=( AUTHORS CHANGELOG README )

PATCHES=(
        "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
        "${FILESDIR}/${PN}-slot.patch"
)

src_configure() {
        local mycmakeargs=(
                -DBUILD_TESTS=$(usex test)
        )

        cmake-utils_src_configure
}

src_compile() {
        cmake-utils_src_compile

        use doc && cmake-utils_src_compile docs
}

src_test() {
        VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
}

src_install() {
        use doc && HTML_DOCS=("${BUILD_DIR}/apidox/")

        cmake-utils_src_install
}




Reply via email to