chainsaw    14/03/27 17:05:08

  Modified:             ChangeLog
  Added:                mongo-c-driver-0.8.1-r1.ebuild
  Log:
  Bump up the API version numbers in the header, as recent pmacct release 
candidates require this to build. Attempt to port to newer python eclass.
  
  (Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xB5058F9A)

Revision  Changes    Path
1.7                  dev-libs/mongo-c-driver/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog?rev=1.7&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog?rev=1.7&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog?r1=1.6&r2=1.7

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- ChangeLog   27 Mar 2014 15:05:14 -0000      1.6
+++ ChangeLog   27 Mar 2014 17:05:08 -0000      1.7
@@ -1,6 +1,13 @@
 # ChangeLog for dev-libs/mongo-c-driver
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog,v 1.6 
2014/03/27 15:05:14 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog,v 1.7 
2014/03/27 17:05:08 chainsaw Exp $
+
+*mongo-c-driver-0.8.1-r1 (27 Mar 2014)
+
+  27 Mar 2014; Tony Vroon <chain...@gentoo.org>
+  +mongo-c-driver-0.8.1-r1.ebuild, +files/0.8.1-api-version.diff:
+  Bump up the API version numbers in the header, as recent pmacct release
+  candidates require this to build. Attempt to port to newer python eclass.
 
 *mongo-c-driver-0.8.1 (27 Mar 2014)
 



1.1                  dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild?rev=1.1&content-type=text/plain

Index: mongo-c-driver-0.8.1-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/mongo-c-driver-0.8.1-r1.ebuild,v
 1.1 2014/03/27 17:05:08 chainsaw Exp $

EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )

inherit base multilib python-r1

DESCRIPTION="C Driver for MongoDB"
HOMEPAGE="http://www.mongodb.org/ https://github.com/mongodb/mongo-c-driver";
SRC_URI="https://github.com/mongodb/${PN}/tarball/v${PV/_/} -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="doc static-libs"

# tests fails to build
RESTRICT="test"

RDEPEND=""
DEPEND="doc? ( dev-python/sphinx )"
PATCHES=( "${FILESDIR}/${PV}-api-version.diff" )

src_unpack() {
        unpack ${A}
        mv *-${PN}-* "${S}"
}

src_compile() {
        emake
        use doc && make -C docs/source/sphinx html
}

src_install() {
        emake install \
                INSTALL_LIBRARY_PATH="${D}/usr/$(get_libdir)" \
                INSTALL_INCLUDE_PATH="${D}/usr/include"

        use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +

        use doc && dohtml -r docs/source/sphinx/build/html/*
}




Reply via email to