grozin      14/09/14 09:57:58

  Modified:             ChangeLog
  Added:                clozurecl-1.10.ebuild
  Removed:              clozurecl-1.8.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.12/cvs/Linux i686, signed Manifest commit with key 
0x3AFFCE974D34BD8C!)

Revision  Changes    Path
1.13                 dev-lisp/clozurecl/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lisp/clozurecl/ChangeLog?rev=1.13&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lisp/clozurecl/ChangeLog?rev=1.13&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lisp/clozurecl/ChangeLog?r1=1.12&r2=1.13

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v
retrieving revision 1.12
retrieving revision 1.13
diff -u -r1.12 -r1.13
--- ChangeLog   14 Oct 2013 10:48:32 -0000      1.12
+++ ChangeLog   14 Sep 2014 09:57:58 -0000      1.13
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lisp/clozurecl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.12 
2013/10/14 10:48:32 grozin Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.13 
2014/09/14 09:57:58 grozin Exp $
+
+*clozurecl-1.10 (14 Sep 2014)
+
+  14 Sep 2014; Andrey Grozin <gro...@gentoo.org> -clozurecl-1.8.ebuild,
+  +clozurecl-1.10.ebuild:
+  Version bump
 
 *clozurecl-1.9_p1-r1 (14 Oct 2013)
 



1.1                  dev-lisp/clozurecl/clozurecl-1.10.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.10.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.10.ebuild?rev=1.1&content-type=text/plain

Index: clozurecl-1.10.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.10.ebuild,v 
1.1 2014/09/14 09:57:58 grozin Exp $

EAPI=5
inherit eutils multilib toolchain-funcs

MY_PN=ccl
MY_P=${MY_PN}-${PV}

DESCRIPTION="ClozureCL is a Common Lisp implementation, derived from Digitool's 
MCL product"
HOMEPAGE="http://ccl.clozure.com/";
SRC_URI="x86?   ( 
ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )
                 amd64? ( 
ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )"
                 # ppc?   ( 
ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
                 # ppc64? ( 
ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"

LICENSE="LLGPL-2.1"
SLOT="0"
# KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

RDEPEND=">=dev-lisp/asdf-2.33-r3:="
DEPEND="${RDEPEND}
                !dev-lisp/openmcl"

S="${WORKDIR}"/${MY_PN}

ENVD="${T}"/50ccl

src_configure() {
        if use x86; then
                CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers; 
CCL_KERNEL=linuxx8632
        elif use amd64; then
                CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64; 
CCL_KERNEL=linuxx8664
        elif use ppc; then
                CCL_RUNTIME=ppccl; CCL_HEADERS=headers; CCL_KERNEL=linuxppc
        elif use ppc64; then
                CCL_RUNTIME=ppccl64; CCL_HEADERS=headers64; 
CCL_KERNEL=linuxppc64
        fi
}

src_prepare() {
        cp /usr/share/common-lisp/source/asdf/build/asdf.lisp tools/ || die
}

src_compile() {
        emake -C lisp-kernel/${CCL_KERNEL} clean
        emake -C lisp-kernel/${CCL_KERNEL} all CC="$(tc-getCC)"

        unset CCL_DEFAULT_DIRECTORY
        ./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e 
'(ccl:quit)' || die "Compilation failed"

        # remove non-owner write permissions on the full-image
        chmod go-w ${CCL_RUNTIME}{,.image}

        # remove .svn directories
        find "${S}" -type d -name .svn -exec rm -rf {} ';' &>/dev/null
}

src_install() {
        local install_dir=/usr/$(get_libdir)/${PN}

        exeinto ${install_dir}
        # install executable
        doexe ${CCL_RUNTIME}
        # install core image
        cp ${CCL_RUNTIME}.image "${D}"/${install_dir} || die
        # install optional libraries
        dodir ${install_dir}/tools
        cp tools/*fsl "${D}"/${install_dir}/tools || die

        # until we figure out which source files are necessary for runtime
        # optional features and which aren't, we install all sources
        find . -type f -name '*fsl' -delete
        rm -f lisp-kernel/${CCL_KERNEL}/*.o
        cp -a compiler level-0 level-1 lib library \
                lisp-kernel scripts tools xdump contrib \
                "${D}"/${install_dir} || die
        cp -a ${CCL_HEADERS} "${D}"/${install_dir} || die

        make_wrapper ccl "${install_dir}/${CCL_RUNTIME}"

        echo "CCL_DEFAULT_DIRECTORY=${install_dir}" > "${ENVD}"
        doenvd "${ENVD}"

        dodoc doc/release-notes.txt
        dohtml doc/ccl-documentation.html
        use doc && dohtml -r examples
}




Reply via email to