xarthisius    15/03/09 18:53:13

  Modified:             ChangeLog
  Added:                flake8-2.4.0.ebuild
  Removed:              flake8-2.0.ebuild flake8-2.1.0.ebuild
                        flake8-2.0-r1.ebuild
  Log:
  Version bump, drop old
  
  (Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 
0x5D21B852895192F9)

Revision  Changes    Path
1.28                 dev-python/flake8/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flake8/ChangeLog?rev=1.28&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flake8/ChangeLog?rev=1.28&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flake8/ChangeLog?r1=1.27&r2=1.28

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v
retrieving revision 1.27
retrieving revision 1.28
diff -u -r1.27 -r1.28
--- ChangeLog   9 Mar 2015 00:05:23 -0000       1.27
+++ ChangeLog   9 Mar 2015 18:53:13 -0000       1.28
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/flake8
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.27 
2015/03/09 00:05:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.28 
2015/03/09 18:53:13 xarthisius Exp $
+
+*flake8-2.4.0 (09 Mar 2015)
+
+  09 Mar 2015; Kacper Kowalik <xarthis...@gentoo.org> +flake8-2.4.0.ebuild,
+  -flake8-2.0-r1.ebuild, -flake8-2.0.ebuild, -flake8-2.1.0.ebuild:
+  Version bump, drop old
 
   09 Mar 2015; Pacho Ramos <pa...@gentoo.org> flake8-2.0-r1.ebuild:
   x86 stable, bug 540290



1.1                  dev-python/flake8/flake8-2.4.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flake8/flake8-2.4.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flake8/flake8-2.4.0.ebuild?rev=1.1&content-type=text/plain

Index: flake8-2.4.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.4.0.ebuild,v 1.1 
2015/03/09 18:53:13 xarthisius Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1

DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
HOMEPAGE="http://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8";
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux 
~x86-linux"
IUSE="test"
LICENSE="MIT"
SLOT="0"

# requires.txt inc. mccabe however that creates a circular dep
RDEPEND=">=dev-python/pyflakes-0.7.3[${PYTHON_USEDEP}]
        >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]"
PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${PDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
                dev-python/mock[${PYTHON_USEDEP}] )"

python_prepare_all() {
        # This tests requires / assumes this version is already installed.
        sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py 
|| die
        distutils-r1_python_prepare_all
}

python_test() {
        esetup.py test
}




Reply via email to