idella4     15/01/17 01:36:17

  Modified:             ChangeLog
  Added:                imapclient-0.12.ebuild
  Removed:              imapclient-0.11.ebuild imapclient-0.10.2.ebuild
  Log:
  bump; add patch for tests to import six from the system, rm disused patches 
and old
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.5                  dev-python/imapclient/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/imapclient/ChangeLog?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/imapclient/ChangeLog?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/imapclient/ChangeLog?r1=1.4&r2=1.5

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/imapclient/ChangeLog,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- ChangeLog   12 Dec 2014 11:52:02 -0000      1.4
+++ ChangeLog   17 Jan 2015 01:36:17 -0000      1.5
@@ -1,6 +1,15 @@
 # ChangeLog for dev-python/imapclient
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imapclient/ChangeLog,v 1.4 
2014/12/12 11:52:02 idella4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imapclient/ChangeLog,v 1.5 
2015/01/17 01:36:17 idella4 Exp $
+
+*imapclient-0.12 (17 Jan 2015)
+
+  17 Jan 2015; Ian Delaney <idel...@gentoo.org> +files/0.12-tests.patch,
+  +imapclient-0.12.ebuild, -files/imapclient-0.10.2-system-six.patch,
+  -files/imapclient-0.11-system-six.patch, -imapclient-0.10.2.ebuild,
+  -imapclient-0.11.ebuild:
+  bump; add patch for tests to import six from the system, rm disused patches
+  and old
 
   12 Dec 2014; Ian Delaney <idel...@gentoo.org> imapclient-0.11.ebuild:
   drop py3.2 add py3.4, tidy deps fix test phase, fixes Bug #530524 by pacho2



1.1                  dev-python/imapclient/imapclient-0.12.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/imapclient/imapclient-0.12.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/imapclient/imapclient-0.12.ebuild?rev=1.1&content-type=text/plain

Index: imapclient-0.12.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/imapclient/imapclient-0.12.ebuild,v 1.1 
2015/01/17 01:36:17 idella4 Exp $

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )

inherit distutils-r1

MY_PN="IMAPClient"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
HOMEPAGE="http://imapclient.freshfoo.com/";
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"

RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 
python2_7 pypy) )"

S=${WORKDIR}/${MY_P}

python_prepare_all() {
        # use system setuptools
        sed -i '/use_setuptools/d' setup.py || die

        # drop explicit mock version test dep
        sed -i "/tests_require/s:'mock==.\+':'mock':" setup.py || die

        # use system six library. patch proven less preferable to use of sed (< 
maintenance)
        # but a copy of the working hunks from prior version works fine for now.
        rm imapclient/six.py || die
        epatch "${FILESDIR}"/0.12-tests.patch
        sed -e 's:from .six:from six:g' \
                -e 's:from . import six:import six:g' \
                -i ${PN}/*.py || die

        distutils-r1_python_prepare_all
}

python_test() {
        "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
}

python_install() {
        distutils-r1_python_install
        # don't install examples and tests in module dir
        rm -r "${D}"$(python_get_sitedir)/imapclient/{examples,test} || die
}

python_install_all() {
#       local DOCS=( AUTHORS HACKING.rst NEWS.rst README.rst THANKS )
        use doc && local HTML_DOCS=( doc/html/. )
        distutils-r1_python_install_all
        use examples && dodoc -r ${PN}/examples
}




Reply via email to