blueness    14/07/30 17:00:12

  Modified:             ChangeLog
  Added:                pypax-0.8.6.ebuild
  Removed:              pypax-0.8.5.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xF52D4BBA)

Revision  Changes    Path
1.86                 dev-python/pypax/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pypax/ChangeLog?rev=1.86&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pypax/ChangeLog?rev=1.86&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pypax/ChangeLog?r1=1.85&r2=1.86

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v
retrieving revision 1.85
retrieving revision 1.86
diff -u -r1.85 -r1.86
--- ChangeLog   7 Jun 2014 14:33:54 -0000       1.85
+++ ChangeLog   30 Jul 2014 17:00:12 -0000      1.86
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/pypax
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v 1.85 
2014/06/07 14:33:54 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v 1.86 
2014/07/30 17:00:12 blueness Exp $
+
+*pypax-0.8.6 (30 Jul 2014)
+
+  30 Jul 2014; Anthony G. Basile <bluen...@gentoo.org> +pypax-0.8.6.ebuild,
+  -pypax-0.8.5.ebuild:
+  Version bump
 
 *pypax-0.8.5 (07 Jun 2014)
 



1.1                  dev-python/pypax/pypax-0.8.6.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pypax/pypax-0.8.6.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pypax/pypax-0.8.6.ebuild?rev=1.1&content-type=text/plain

Index: pypax-0.8.6.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/pypax-0.8.6.ebuild,v 1.1 
2014/07/30 17:00:12 blueness Exp $

EAPI="5"

PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )

inherit distutils-r1

DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/
        http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml";
SRC_URI="http://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz";

S="${WORKDIR}/elfix-${PV}/scripts"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="+ptpax +xtpax"

REQUIRED_USE="|| ( ptpax xtpax )"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        ptpax? ( dev-libs/elfutils )
        xtpax? ( sys-apps/attr )"

RDEPEND=""

src_compile() {
        unset PTPAX
        unset XTPAX
        use ptpax && export PTPAX="yes"
        use xtpax && export XTPAX="yes"
        distutils-r1_src_compile
}




Reply via email to