idella4     14/06/03 10:53:39

  Modified:             ChangeLog
  Added:                testify-0.3.3.ebuild
  Removed:              testify-0.2.9.ebuild testify-0.2.6.ebuild
                        testify-0.2.10.ebuild testify-0.2.8.ebuild
                        testify-0.2.7.ebuild
  Log:
  bump
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.13                 dev-python/testify/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/ChangeLog?rev=1.13&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/ChangeLog?rev=1.13&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/ChangeLog?r1=1.12&r2=1.13

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v
retrieving revision 1.12
retrieving revision 1.13
diff -u -r1.12 -r1.13
--- ChangeLog   26 May 2014 08:10:39 -0000      1.12
+++ ChangeLog   3 Jun 2014 10:53:39 -0000       1.13
@@ -1,6 +1,13 @@
 # ChangeLog for dev-python/testify
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.12 
2014/05/26 08:10:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.13 
2014/06/03 10:53:39 idella4 Exp $
+
+*testify-0.3.3 (03 Jun 2014)
+
+  03 Jun 2014; Ian Delaney <idel...@gentoo.org> +testify-0.3.3.ebuild,
+  -testify-0.2.10.ebuild, -testify-0.2.6.ebuild, -testify-0.2.7.ebuild,
+  -testify-0.2.8.ebuild, -testify-0.2.9.ebuild:
+  bump
 
 *testify-0.3.2 (26 May 2014)
 



1.1                  dev-python/testify/testify-0.3.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/testify-0.3.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/testify-0.3.3.ebuild?rev=1.1&content-type=text/plain

Index: testify-0.3.3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.3.ebuild,v 
1.1 2014/06/03 10:53:39 idella4 Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 pypy )
RESTRICT="test" # basically broken

inherit distutils-r1 vcs-snapshot

DESCRIPTION="A more pythonic replacement for the unittest module and nose"
HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/";
SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
        dev-python/sqlalchemy[${PYTHON_USEDEP}]
        www-servers/tornado[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${RDEPEND} )"

DOCS="README.md"

src_prepare_all() {
        # Rm rogue test, Bug #438032
        rm -f test/plugins//http_reporter_test.py
}

python_test() {
         "${PYTHON}" bin/${PN} test || die
}




Reply via email to