scarabeus    14/09/05 07:13:08

  Modified:             osc-0.146.0.ebuild ChangeLog
  Added:                osc-0.147.0.ebuild
  Removed:              osc-0.144.1.ebuild
  Log:
  Version bump to 0.147.0. Stabilse 0.146.0 on amd64 and x86. Drop oldest.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
8EEE3BE8)

Revision  Changes    Path
1.2                  dev-util/osc/osc-0.146.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/osc-0.146.0.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/osc-0.146.0.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/osc-0.146.0.ebuild?r1=1.1&r2=1.2

Index: osc-0.146.0.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/osc/osc-0.146.0.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- osc-0.146.0.ebuild  23 May 2014 13:08:07 -0000      1.1
+++ osc-0.146.0.ebuild  5 Sep 2014 07:13:08 -0000       1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/osc-0.146.0.ebuild,v 1.1 
2014/05/23 13:08:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/osc-0.146.0.ebuild,v 1.2 
2014/09/05 07:13:08 scarabeus Exp $
 
 EAPI=5
 
@@ -31,7 +31,7 @@
 
 # Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
 [[ "${PV}" == "9999" ]] || \
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 
 DEPEND="
        dev-python/urlgrabber[${PYTHON_USEDEP}]



1.34                 dev-util/osc/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/ChangeLog?rev=1.34&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/ChangeLog?rev=1.34&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/ChangeLog?r1=1.33&r2=1.34

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/osc/ChangeLog,v
retrieving revision 1.33
retrieving revision 1.34
diff -u -r1.33 -r1.34
--- ChangeLog   23 May 2014 13:08:07 -0000      1.33
+++ ChangeLog   5 Sep 2014 07:13:08 -0000       1.34
@@ -1,6 +1,12 @@
 # ChangeLog for dev-util/osc
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/ChangeLog,v 1.33 2014/05/23 
13:08:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/ChangeLog,v 1.34 2014/09/05 
07:13:08 scarabeus Exp $
+
+*osc-0.147.0 (05 Sep 2014)
+
+  05 Sep 2014; Tomáš Chvátal <scarab...@gentoo.org> +osc-0.147.0.ebuild,
+  -osc-0.144.1.ebuild, osc-0.146.0.ebuild:
+  Version bump to 0.147.0. Stabilse 0.146.0 on amd64 and x86. Drop oldest.
 
 *osc-0.146.0 (23 May 2014)
 



1.1                  dev-util/osc/osc-0.147.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/osc-0.147.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/osc/osc-0.147.0.ebuild?rev=1.1&content-type=text/plain

Index: osc-0.147.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/osc-0.147.0.ebuild,v 1.1 
2014/09/05 07:13:08 scarabeus Exp $

EAPI=5

EGIT_REPO_URI="git://github.com/openSUSE/osc.git"

PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="xml"

if [[ "${PV}" == "9999" ]]; then
        EXTRA_ECLASS="git-2"
else
        OBS_PROJECT="openSUSE:Tools"
        EXTRA_ECLASS="obs-download"
fi

DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1 ${EXTRA_ECLASS}
unset EXTRA_ECLASS

DESCRIPTION="Command line tool for Open Build Service"
HOMEPAGE="http://en.opensuse.org/openSUSE:OSC";

[[ "${PV}" == "9999" ]] || SRC_URI="${OBS_URI}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
IUSE=""

# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ "${PV}" == "9999" ]] || \
KEYWORDS="~amd64 ~x86"

DEPEND="
        dev-python/urlgrabber[${PYTHON_USEDEP}]
        app-arch/rpm[python,${PYTHON_USEDEP}]
        dev-python/m2crypto[${PYTHON_USEDEP}]
        ${PYTHON_DEPS}
"
PDEPEND="${DEPEND}
        app-admin/sudo
        dev-util/obs-service-meta
"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

src_prepare() {
        epatch "${FILESDIR}"/${PN}-0.139.2-out-of-tree-build.patch
        distutils-r1_src_prepare
}

src_install() {
        distutils-r1_src_install
        dosym osc-wrapper.py /usr/bin/osc
        keepdir /usr/lib/osc/source_validators
        cd "${ED}"/usr/
        find . -type f -exec sed -i 's|/usr/bin/build|/usr/bin/suse-build|g'    
 {} +
        find . -type f -exec sed -i 
's|/usr/lib/build|/usr/libexec/suse-build|g' {} +
        find . -type f -exec sed -i 's|/usr/lib/obs|/usr/libexec/obs|g'         
 {} +
        rm -f "${ED}"/usr/share/doc/${PN}*/TODO*
}




Reply via email to