mr_bones_    15/01/13 18:11:11

  Modified:             metadata.xml ChangeLog
  Added:                wesnoth-1.12.ebuild
  Log:
  version bump (bug #530642)
  
  (Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.7                  games-strategy/wesnoth/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/metadata.xml?rev=1.7&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/metadata.xml?rev=1.7&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/metadata.xml?r1=1.6&r2=1.7

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/metadata.xml,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- metadata.xml        20 May 2012 06:48:19 -0000      1.6
+++ metadata.xml        13 Jan 2015 18:11:11 -0000      1.7
@@ -4,5 +4,6 @@
   <herd>games</herd>
   <use>
     <flag name="server">Enable compilation of server</flag>
+       <flag name='fribidi'>Support for right-to-left languages</flag>
   </use>
 </pkgmetadata>



1.237                games-strategy/wesnoth/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/ChangeLog?rev=1.237&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/ChangeLog?rev=1.237&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/ChangeLog?r1=1.236&r2=1.237

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v
retrieving revision 1.236
retrieving revision 1.237
diff -u -r1.236 -r1.237
--- ChangeLog   31 Dec 2013 07:29:23 -0000      1.236
+++ ChangeLog   13 Jan 2015 18:11:11 -0000      1.237
@@ -1,6 +1,12 @@
 # ChangeLog for games-strategy/wesnoth
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.236 
2013/12/31 07:29:23 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.237 
2015/01/13 18:11:11 mr_bones_ Exp $
+
+*wesnoth-1.12 (13 Jan 2015)
+
+  13 Jan 2015; Michael Sterrett <mr_bon...@gentoo.org> +wesnoth-1.12.ebuild,
+  metadata.xml:
+  version bump (bug #530642)
 
   31 Dec 2013; Michael Sterrett <mr_bon...@gentoo.org>
   -files/wesnoth-1.10.4-boost.patch, -wesnoth-1.10.4.ebuild,



1.1                  games-strategy/wesnoth/wesnoth-1.12.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/wesnoth-1.12.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/wesnoth/wesnoth-1.12.ebuild?rev=1.1&content-type=text/plain

Index: wesnoth-1.12.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.12.ebuild,v 
1.1 2015/01/13 18:11:11 mr_bones_ Exp $

EAPI=5
inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games

DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org/";
SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="dbus dedicated doc fribidi nls server"

RDEPEND=">=media-libs/libsdl-1.2.7:0[joystick,video,X]
        media-libs/sdl-net
        !dedicated? (
                >=media-libs/sdl-ttf-2.0.8
                >=media-libs/sdl-mixer-1.2[vorbis]
                >=media-libs/sdl-image-1.2[jpeg,png]
                fribidi? ( dev-libs/fribidi )
                dbus? ( sys-apps/dbus )
                sys-libs/zlib
                x11-libs/pango
                dev-lang/lua
                media-libs/fontconfig
        )
        >=dev-libs/boost-1.48[nls,threads]
        virtual/libintl"
DEPEND="${RDEPEND}
        virtual/pkgconfig
        sys-devel/gettext"

S=${WORKDIR}/${P}.0

src_prepare() {
        if use dedicated || use server ; then
                sed \
                        -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
                        -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
                        -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
                        -e "s/GAMES_GROUP/${GAMES_GROUP}/" 
"${FILESDIR}"/wesnothd.rc \
                        > "${T}"/wesnothd || die
        fi
        if ! use doc ; then
                sed -i \
                        -e '/manual/d' \
                        doc/CMakeLists.txt || die
        fi
        # bug #472994
        mv icons/wesnoth-icon-Mac.png icons/wesnoth-icon.png || die
        mv icons/map-editor-icon-Mac.png icons/wesnoth_editor-icon.png || die

        # respect LINGUAS (bug #483316)
        if [[ ${LINGUAS+set} ]] ; then
                local langs
                for lang in $(cat po/LINGUAS)
                do
                        has $lang $LINGUAS && langs+="$lang "
                done
                echo "$langs" > po/LINGUAS || die
        fi
}

src_configure() {
        filter-flags -ftracer -fomit-frame-pointer
        if [[ $(gcc-major-version) -eq 3 ]] ; then
                filter-flags -fstack-protector
                append-flags -fno-stack-protector
        fi
        # Work around eclass
        append-flags -UNDEBUG
        if use dedicated || use server ; then
                mycmakeargs=(
                        "-DENABLE_CAMPAIGN_SERVER=TRUE"
                        "-DENABLE_SERVER=TRUE"
                        "-DSERVER_UID=${GAMES_USER_DED}"
                        "-DSERVER_GID=${GAMES_GROUP}"
                        "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
                        )
        else
                mycmakeargs=(
                        $(cmake-utils_use_enable fribidi FRIBIDI)
                        "-DENABLE_CAMPAIGN_SERVER=FALSE"
                        "-DENABLE_SERVER=FALSE"
                        )
        fi
        mycmakeargs+=(
                $(cmake-utils_use_enable !dedicated GAME)
                $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
                $(cmake-utils_use_enable nls NLS)
                $(cmake-utils_use_enable dbus NOTIFICATIONS)
                "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
                "-DENABLE_STRICT_COMPILATION=FALSE"
                "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
                "-DDATAROOTDIR=${GAMES_DATADIR}"
                "-DBINDIR=${GAMES_BINDIR}"
                "-DICONDIR=/usr/share/pixmaps"
                "-DDESKTOPDIR=/usr/share/applications"
                "-DLOCALEDIR=/usr/share/locale"
                "-DMANDIR=/usr/share/man"
                "-DDOCDIR=/usr/share/doc/${PF}"
                )
        cmake-utils_src_configure
}

src_compile() {
        cmake-utils_src_compile
}

src_install() {
        DOCS="README changelog players_changelog" cmake-utils_src_install
        if use dedicated || use server; then
                keepdir "${GAMES_STATEDIR}/run/wesnothd"
                doinitd "${T}"/wesnothd || die
        fi
        prepgamesdirs
}




Reply via email to