kensington    14/06/15 16:56:19

  Modified:             ChangeLog
  Added:                kde-l10n-4.13.2.ebuild
  Log:
  Version bump KDE SC 4.13.2
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0x06B1F38DCA45A1EC!)

Revision  Changes    Path
1.245                kde-base/kde-l10n/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/kde-base/kde-l10n/ChangeLog?rev=1.245&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/kde-base/kde-l10n/ChangeLog?rev=1.245&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/kde-base/kde-l10n/ChangeLog?r1=1.244&r2=1.245

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v
retrieving revision 1.244
retrieving revision 1.245
diff -u -r1.244 -r1.245
--- ChangeLog   13 May 2014 17:43:23 -0000      1.244
+++ ChangeLog   15 Jun 2014 16:56:19 -0000      1.245
@@ -1,6 +1,11 @@
 # ChangeLog for kde-base/kde-l10n
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.244 
2014/05/13 17:43:23 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.245 
2014/06/15 16:56:19 kensington Exp $
+
+*kde-l10n-4.13.2 (15 Jun 2014)
+
+  15 Jun 2014; Michael Palimaka <kensing...@gentoo.org> 
+kde-l10n-4.13.2.ebuild:
+  Version bump KDE SC 4.13.2
 
 *kde-l10n-4.13.1 (13 May 2014)
 



1.1                  kde-base/kde-l10n/kde-l10n-4.13.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.13.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.13.2.ebuild?rev=1.1&content-type=text/plain

Index: kde-l10n-4.13.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.13.2.ebuild,v 
1.1 2014/06/15 16:56:19 kensington Exp $

EAPI=5

KDE_HANDBOOK="optional"
inherit kde4-base

DESCRIPTION="KDE internationalization package"
HOMEPAGE="http://l10n.kde.org";

DEPEND="
        sys-devel/gettext
"
RDEPEND="!<kde-base/konq-plugins-4.6"

KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""

# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.xz::' 
-e 's:kde-l10n-::' |tr '\n' ' '
MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl he hi
hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru sk sl
sr sv tr ug uk vi wa zh_CN zh_TW"

URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
SRC_URI=""

for MY_LANG in ${MY_LANGS} ; do
        IUSE="${IUSE} linguas_${MY_LANG}"
        SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( 
${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
done

S="${WORKDIR}"

src_unpack() {
        local LNG DIR
        if [[ -z ${A} ]]; then
                elog
                elog "You either have the LINGUAS variable unset, or it only"
                elog "contains languages not supported by ${P}."
                elog "You won't have any additional language support."
                elog
                elog "${P} supports these language codes:"
                elog "${MY_LANGS}"
                elog
        fi

        [[ -n ${A} ]] && unpack ${A}
        cd "${S}"

        # add all linguas to cmake
        if [[ -n ${A} ]]; then
                for LNG in ${LINGUAS}; do
                        DIR="${PN}-${LNG}-${PV}"
                        if [[ -d "${DIR}" ]] ; then
                                echo "add_subdirectory( ${DIR} )" >> 
"${S}"/CMakeLists.txt
                        fi
                done
        fi
}

src_prepare() {
        find "${S}" -name CMakeLists.txt -type f \
                -exec sed -i -e 's:^ *add_subdirectory( *kdepim-runtime *):# no 
kdepim-runtime:g' {} +
        find "${S}" -name CMakeLists.txt -type f \
                -exec sed -i -e 's:^ *add_subdirectory( *kdepim *):# no 
kdepim:g' {} +

        # quick workaround for bug 493278
        find "${S}" -name "akonadi_knut_resource*" -delete

        kde4-base_src_prepare
}

src_configure() {
        mycmakeargs=(
                $(cmake-utils_use_build handbook docs)
        )
        [[ -n ${A} ]] && kde4-base_src_configure
}

src_compile() {
        [[ -n ${A} ]] && kde4-base_src_compile
}

src_test() {
        [[ -n ${A} ]] && kde4-base_src_test
}

src_install() {
        [[ -n ${A} ]] && kde4-base_src_install
}




Reply via email to