hasufell    14/09/05 20:32:16

  Modified:             ChangeLog
  Added:                geary-0.7.2.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  Changes    Path
1.20                 mail-client/geary/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mail-client/geary/ChangeLog?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mail-client/geary/ChangeLog?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mail-client/geary/ChangeLog?r1=1.19&r2=1.20

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/mail-client/geary/ChangeLog,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- ChangeLog   24 Aug 2014 16:26:43 -0000      1.19
+++ ChangeLog   5 Sep 2014 20:32:16 -0000       1.20
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/geary
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/geary/ChangeLog,v 1.19 
2014/08/24 16:26:43 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/geary/ChangeLog,v 1.20 
2014/09/05 20:32:16 hasufell Exp $
+
+*geary-0.7.2 (05 Sep 2014)
+
+  05 Sep 2014; Julian Ospald <hasuf...@gentoo.org> +geary-0.7.2.ebuild,
+  +files/geary-0.7.2-cflags.patch:
+  version bump
 
 *geary-0.7.1 (24 Aug 2014)
 



1.1                  mail-client/geary/geary-0.7.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mail-client/geary/geary-0.7.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mail-client/geary/geary-0.7.2.ebuild?rev=1.1&content-type=text/plain

Index: geary-0.7.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/mail-client/geary/geary-0.7.2.ebuild,v 1.1 
2014/09/05 20:32:16 hasufell Exp $

EAPI=5

VALA_MIN_API_VERSION=0.22

inherit eutils fdo-mime gnome2-utils vala cmake-utils

MY_P=${P/_pre/pr}
DESCRIPTION="A lightweight, easy-to-use, feature-rich email client"
HOMEPAGE="http://www.yorba.org/projects/geary/";
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/geary/${PV:0:3}/${MY_P}.tar.xz";

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"

DEPEND="
        app-crypt/gcr[introspection,vala]
        app-crypt/libsecret
        dev-db/sqlite:3
        dev-libs/glib:2
        >=dev-libs/libgee-0.8.5:0.8
        dev-libs/libxml2:2
        dev-libs/gmime:2.6
        media-libs/libcanberra
        >=net-libs/webkit-gtk-1.10.0:3[introspection]
        >=x11-libs/gtk+-3.10.0:3[introspection]
        x11-libs/libnotify"
RDEPEND="${DEPEND}
        gnome-base/gsettings-desktop-schemas
        nls? ( virtual/libintl )"
DEPEND="${DEPEND}
        app-text/gnome-doc-utils
        dev-util/desktop-file-utils
        nls? ( sys-devel/gettext )
        $(vala_depend)
        virtual/pkgconfig"

DOCS=( AUTHORS MAINTAINERS README NEWS THANKS )

S=${WORKDIR}/${MY_P}

src_prepare() {
        epatch "${FILESDIR}"/${PN}-0.7.2-cflags.patch \
                "${FILESDIR}"/${PN}-0.5.3-vapigen.patch \
                "${FILESDIR}"/${PN}-0.6.0-desktopfile.patch

        local i
        if use nls ; then
                if [[ -n "${LINGUAS+x}" ]] ; then
                        for i in $(cd po ; echo *.po) ; do
                                if ! has ${i%.po} ${LINGUAS} ; then
                                        sed -i -e "/^${i%.po}$/d" po/LINGUAS || 
die
                                fi
                        done
                fi
        else
                sed -i -e 's#add_subdirectory(po)##' CMakeLists.txt || die
        fi

        cmake-utils_src_prepare
        vala_src_prepare
}

src_configure() {
        local mycmakeargs=(
                -DDESKTOP_UPDATE=OFF
                -DGSETTINGS_COMPILE=OFF
                -DICON_UPDATE=OFF
                -DVALA_EXECUTABLE="${VALAC}"
                -DWITH_UNITY=OFF
                -DDESKTOP_VALIDATE=OFF
        )

        cmake-utils_src_configure
}

pkg_preinst() {
        gnome2_icon_savelist
        gnome2_schemas_savelist
}

pkg_postinst() {
        elog "For libnotify sounds you will need"
        elog "\"alsa\" or \"pulseaudio\" useflag of media-libs/libcanberra"
        elog "enabled."

        fdo-mime_desktop_database_update
        gnome2_icon_cache_update
        gnome2_schemas_update
}

pkg_postrm() {
        fdo-mime_desktop_database_update
        gnome2_icon_cache_update
        gnome2_schemas_update
}




Reply via email to