hasufell    14/04/18 13:37:22

  Modified:             ChangeLog
  Added:                giflib-4.2.3-r1.ebuild giflib-5.0.5-r1.ebuild
  Log:
  add multilib support wrt #496548, patch by Michael Mair-Keimberger
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  Changes    Path
1.73                 media-libs/giflib/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/giflib/ChangeLog?rev=1.73&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/giflib/ChangeLog?rev=1.73&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/giflib/ChangeLog?r1=1.72&r2=1.73

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-libs/giflib/ChangeLog,v
retrieving revision 1.72
retrieving revision 1.73
diff -u -r1.72 -r1.73
--- ChangeLog   10 Nov 2013 04:14:36 -0000      1.72
+++ ChangeLog   18 Apr 2014 13:37:22 -0000      1.73
@@ -1,6 +1,13 @@
 # ChangeLog for media-libs/giflib
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/ChangeLog,v 1.72 
2013/11/10 04:14:36 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/ChangeLog,v 1.73 
2014/04/18 13:37:22 hasufell Exp $
+
+*giflib-5.0.5-r1 (18 Apr 2014)
+*giflib-4.2.3-r1 (18 Apr 2014)
+
+  18 Apr 2014; Julian Ospald <hasuf...@gentoo.org> +giflib-4.2.3-r1.ebuild,
+  +giflib-5.0.5-r1.ebuild:
+  add multilib support wrt #496548, patch by Michael Mair-Keimberger
 
 *giflib-5.0.5 (10 Nov 2013)
 



1.1                  media-libs/giflib/giflib-4.2.3-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/giflib/giflib-4.2.3-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/giflib/giflib-4.2.3-r1.ebuild?rev=1.1&content-type=text/plain

Index: giflib-4.2.3-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-4.2.3-r1.ebuild,v 
1.1 2014/04/18 13:37:22 hasufell Exp $

EAPI=5

inherit autotools-multilib eutils

DESCRIPTION="Library to handle, display and manipulate GIF images"
HOMEPAGE="http://sourceforge.net/projects/giflib/";
SRC_URI="mirror://sourceforge/giflib/${P}.tar.bz2"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh 
~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux 
~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs X"

RDEPEND="X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
        abi_x86_32? (
                !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
                !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
        )"
DEPEND="${RDEPEND}"

src_prepare() {
        # don't generate html docs
        sed -i '/^SUBDIRS/s/doc//' Makefile.am || die

        epatch "${FILESDIR}"/${PN}-4.1.6-giffix-null-Extension-fix.patch
        sed -i \
                -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
                -e 's:${X_PRE_LIBS}::' \
                configure.ac || die #486542,#483258
        eautoreconf
}

src_configure() {
        local myeconfargs=(
                $(use_enable static-libs static)
                $(use_enable X x11)
                )
        autotools-multilib_src_configure
}

src_test() {
        autotools-multilib_src_test -C tests
}

src_install() {
        autotools-multilib_src_install

        # for static libs the .la file is required if built with +X
        use static-libs || prune_libtool_files --all

        doman doc/*.1
        dodoc doc/*.txt
}



1.1                  media-libs/giflib/giflib-5.0.5-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/giflib/giflib-5.0.5-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/giflib/giflib-5.0.5-r1.ebuild?rev=1.1&content-type=text/plain

Index: giflib-5.0.5-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-5.0.5-r1.ebuild,v 
1.1 2014/04/18 13:37:22 hasufell Exp $

EAPI=5

inherit eutils libtool autotools-multilib

DESCRIPTION="Library to handle, display and manipulate GIF images"
HOMEPAGE="http://sourceforge.net/projects/giflib/";
SRC_URI="mirror://sourceforge/giflib/${P}.tar.bz2"

LICENSE="MIT"
SLOT="0"
# Needs testing first.
#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh 
~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux 
~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"

RDEPEND="
        abi_x86_32? (
                !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
                !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
        )"
DEPEND="${RDEPEND}"

src_prepare() {
        elibtoolize
}

src_configure() {
        local myconfargs=(
                $(use_enable static-libs static)
                )
        # No need for xmlto as they ship generated files.
        ac_cv_prog_have_xmlto=no \
                autotools-multilib_src_configure

}

src_install() {
        autotools-multilib_src_install

        # for static libs the .la file is required if built with +X
        use static-libs || prune_libtool_files --all

        doman doc/*.1
        dodoc doc/*.txt
        dohtml -r doc
}




Reply via email to