jer         14/05/26 13:33:22

  Modified:             pppconfig-2.3.17-r1.ebuild ChangeLog
  Added:                pppconfig-2.3.21.ebuild
  Log:
  Version bump. Use mirror:// (bug #413341). Rewrite LINGUAS support using 
strip-linguas (maybe bug #403633).
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
A792A613)

Revision  Changes    Path
1.4                  net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild?r1=1.3&r2=1.4

Index: pppconfig-2.3.17-r1.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- pppconfig-2.3.17-r1.ebuild  9 Sep 2007 05:44:27 -0000       1.3
+++ pppconfig-2.3.17-r1.ebuild  26 May 2014 13:33:22 -0000      1.4
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild,v 1.3 
2007/09/09 05:44:27 josejx Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.17-r1.ebuild,v 1.4 
2014/05/26 13:33:22 jer Exp $
 
 DESCRIPTION="A text menu based utility for configuring ppp."
-SRC_URI="http://http.us.debian.org/debian/pool/main/p/pppconfig/${PN}_${PV}.tar.gz";
-HOMEPAGE="http://http.us.debian.org/debian/pool/main/p/pppconfig/";
+HOMEPAGE="http://packages.qa.debian.org/p/pppconfig.html";
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
 
 SLOT="0"
 LICENSE="GPL-2"



1.30                 net-dialup/pppconfig/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/ChangeLog?rev=1.30&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/ChangeLog?rev=1.30&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/ChangeLog?r1=1.29&r2=1.30

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/ChangeLog,v
retrieving revision 1.29
retrieving revision 1.30
diff -u -r1.29 -r1.30
--- ChangeLog   12 Nov 2007 15:19:10 -0000      1.29
+++ ChangeLog   26 May 2014 13:33:22 -0000      1.30
@@ -1,6 +1,13 @@
 # ChangeLog for net-dialup/pppconfig
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/ChangeLog,v 1.29 
2007/11/12 15:19:10 mrness Exp $
+# Copyright 2002-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppconfig/ChangeLog,v 1.30 
2014/05/26 13:33:22 jer Exp $
+
+*pppconfig-2.3.21 (26 May 2014)
+
+  26 May 2014; Jeroen Roovers <j...@gentoo.org> pppconfig-2.3.17-r1.ebuild,
+  +pppconfig-2.3.21.ebuild:
+  Version bump. Use mirror:// (bug #413341). Rewrite LINGUAS support using
+  strip-linguas (maybe bug #403633).
 
   12 Nov 2007; Alin Năstac <mrn...@gentoo.org> -pppconfig-2.3.15.ebuild:
   Remove old version.



1.1                  net-dialup/pppconfig/pppconfig-2.3.21.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.21.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.21.ebuild?rev=1.1&content-type=text/plain

Index: pppconfig-2.3.21.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-dialup/pppconfig/pppconfig-2.3.21.ebuild,v 1.1 
2014/05/26 13:33:22 jer Exp $

EAPI=5

inherit eutils

DESCRIPTION="A text menu based utility for configuring ppp"
HOMEPAGE="http://packages.qa.debian.org/p/pppconfig.html";
SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="nls"

RDEPEND="net-dialup/ppp
        dev-util/dialog
        dev-lang/perl"
DEPEND="nls? ( sys-devel/gettext )"

src_prepare() {
        if use nls; then
                strip-linguas -i po/
        fi
}

src_compile() {
        default

        if use nls; then
                local lang
                for lang in ${LINGUAS}; do
                        msgfmt -o po/${lang}.{m,p}o || die
                done
        fi
}

src_install () {
        dodir /etc/chatscripts /etc/ppp/resolv
        dosbin 0dns-down 0dns-up dns-clean
        newsbin pppconfig pppconfig.real
        dosbin "${FILESDIR}/pppconfig"
        doman man/pppconfig.8
        dodoc debian/{copyright,changelog}

        if use nls; then
                local lang
                for lang in ${LINGUAS}; do
                        insinto /usr/share/locale/${lang}/LC_MESSAGES
                        newins po/${lang}.mo pppconfig.mo
                done
        fi
}




Reply via email to