wired       14/10/09 09:51:50

  Modified:             ChangeLog
  Added:                bitlbee-3.2.1-r2.ebuild
  Removed:              bitlbee-3.2.1-r1.ebuild
  Log:
  init: let users choose if they want forks stopped
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key EB9B4AFA)

Revision  Changes    Path
1.172                net-im/bitlbee/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/bitlbee/ChangeLog?rev=1.172&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/bitlbee/ChangeLog?rev=1.172&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/bitlbee/ChangeLog?r1=1.171&r2=1.172

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-im/bitlbee/ChangeLog,v
retrieving revision 1.171
retrieving revision 1.172
diff -u -r1.171 -r1.172
--- ChangeLog   7 Oct 2014 07:09:23 -0000       1.171
+++ ChangeLog   9 Oct 2014 09:51:50 -0000       1.172
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/bitlbee
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/ChangeLog,v 1.171 2014/10/07 
07:09:23 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/ChangeLog,v 1.172 2014/10/09 
09:51:50 wired Exp $
+
+*bitlbee-3.2.1-r2 (09 Oct 2014)
+
+  09 Oct 2014; Alex Alexander <wi...@gentoo.org> -bitlbee-3.2.1-r1.ebuild,
+  +bitlbee-3.2.1-r2.ebuild, +files/bitlbee.confd-r1, files/bitlbee.initd-r1:
+  init: let users choose if they want forks stopped
 
 *bitlbee-3.2.1-r1 (07 Oct 2014)
 



1.1                  net-im/bitlbee/bitlbee-3.2.1-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/bitlbee/bitlbee-3.2.1-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/bitlbee/bitlbee-3.2.1-r2.ebuild?rev=1.1&content-type=text/plain

Index: bitlbee-3.2.1-r2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/bitlbee-3.2.1-r2.ebuild,v 1.1 
2014/10/09 09:51:50 wired Exp $

EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )

inherit eutils multilib user python-single-r1

DESCRIPTION="irc to IM gateway that support multiple IM protocols"
HOMEPAGE="http://www.bitlbee.org/";
SRC_URI="http://get.bitlbee.org/src/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="debug gnutls ipv6 +jabber libevent msn nss +oscar otr +plugins purple 
selinux
skype ssl test twitter +yahoo xinetd" # ldap - Bug 195758

COMMON_DEPEND="purple? ( net-im/pidgin )
        libevent? ( dev-libs/libevent )
        !libevent? ( >=dev-libs/glib-2.4 )
        otr? ( <net-libs/libotr-4 )
        gnutls? ( net-libs/gnutls )
        !gnutls? (
                nss? ( dev-libs/nss )
                !nss? ( ssl? ( dev-libs/openssl ) )
        )
        selinux? ( sec-policy/selinux-bitlbee )"
        # ldap? ( net-nds/openldap )"
DEPEND="${COMMON_DEPEND}
        virtual/pkgconfig
        skype? ( app-text/asciidoc )
        test? ( dev-libs/check )"

RDEPEND="${COMMON_DEPEND}
        virtual/logger
        skype? (
                dev-python/skype4py[${PYTHON_USEDEP}]
                net-im/skype
        )
        xinetd? ( sys-apps/xinetd )"

REQUIRED_USE="^^ ( purple || ( jabber msn oscar yahoo ) )
        msn? ( || ( gnutls nss ssl ) )
        jabber? ( !nss )"

pkg_setup() {
        if use jabber && ! use gnutls && ! use ssl ; then
                einfo
                elog "You have enabled support for Jabber but do not have SSL"
                elog "support enabled.  This *will* prevent bitlbee from being"
                elog "able to connect to SSL enabled Jabber servers.  If you 
need to"
                elog "connect to Jabber over SSL, enable ONE of the following 
use"
                elog "flags: gnutls or ssl"
                einfo
        fi

        use skype && python-single-r1_pkg_setup

        enewgroup bitlbee
        enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
}

src_prepare() {
        sed -i \
                -e "s@/usr/local/sbin/bitlbee@/usr/sbin/bitlbee@" \
                -e "s/nobody/bitlbee/" \
                -e "s/}/        disable         = yes\n}/" \
                doc/bitlbee.xinetd || die "sed failed in xinetd"

        sed -i \
                -e "s@mozilla-nss@nss@g" \
                configure || die "sed failed in configure"

        use skype && python_fix_shebang protocols/skype/skyped.py

        epatch "${FILESDIR}"/${PN}-3.2.1-configure.patch
        epatch "${FILESDIR}"/${PN}-3.2.1-tests.patch
        epatch "${FILESDIR}"/${PN}-3.0.5-parallel-make.patch
}

src_configure() {
        # ldap hard-disabled for now
        local myconf="--ldap=0"

        # setup plugins, protocol, ipv6 and debug
        for flag in debug ipv6 msn jabber oscar plugins purple skype twitter 
yahoo ; do
                if use ${flag} ; then
                        myconf="${myconf} --${flag}=1"
                else
                        myconf="${myconf} --${flag}=0"
                fi
        done

        # set otr
        if use otr && use plugins ; then
                myconf="${myconf} --otr=plugin"
        else
                if use otr ; then
                        ewarn "OTR support has been disabled automatically 
because it"
                        ewarn "requires the plugins USE flag."
                fi
                myconf="${myconf} --otr=0"
        fi

        # setup ssl use flags
        if use gnutls ; then
                myconf="${myconf} --ssl=gnutls"
                einfo "Using gnutls for SSL support"
        elif use ssl ; then
                myconf="${myconf} --ssl=openssl"
                einfo "Using openssl for SSL support"
        elif use nss ; then
                myconf="${myconf} --ssl=nss"
                einfo "Using nss for SSL support"
        else
                myconf="${myconf} --ssl=bogus"
                einfo "You will not have any encryption support enabled."
        fi

        # set event handler
        if use libevent ; then
                myconf="${myconf} --events=libevent"
        else
                myconf="${myconf} --events=glib"
        fi

        # NOTE: bitlbee's configure script is not an autotool creation,
        # so that is why we don't use econf.
        ./configure --prefix=/usr --datadir=/usr/share/bitlbee \
                --etcdir=/etc/bitlbee --plugindir=/usr/$(get_libdir)/bitlbee \
                --strip=0 ${myconf} || die "econf failed"

        sed -i \
                -e "/^EFLAGS/s:=:&${LDFLAGS} :" \
                Makefile.settings || die "sed failed"
}

src_install() {
        emake install install-etc install-doc install-dev DESTDIR="${D}"

        keepdir /var/lib/bitlbee
        fperms 700 /var/lib/bitlbee
        fowners bitlbee:bitlbee /var/lib/bitlbee

        dodoc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
        dodoc doc/user-guide/user-guide.txt
        dohtml doc/user-guide/*.html

        if use skype ; then
                newdoc protocols/skype/NEWS NEWS-skype
                newdoc protocols/skype/README README-skype
        fi

        doman doc/bitlbee.8 doc/bitlbee.conf.5

        if use xinetd ; then
                insinto /etc/xinetd.d
                newins doc/bitlbee.xinetd bitlbee
        fi

        newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
        newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee

        exeinto /usr/share/bitlbee
        cd utils
        doexe convert_purple.py bitlbee-ctl.pl
}

pkg_postinst() {
        chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
        [[ -d "${ROOT}"/var/run/bitlbee ]] &&
                chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee

        einfo
        elog "The bitlbee init script will now attempt to stop all processes 
owned by the"
        elog "bitlbee user, including per-client forks."
        elog
        elog "Tell the init script not to touch anything besides the main 
bitlbee process"
        elog "by changing the BITLBEE_STOP_ALL variable in"
        elog "  /etc/conf.d/bitlbee"
        einfo
}




Reply via email to