dev-zero    14/06/27 13:16:09

  Modified:             metadata.xml ChangeLog
  Added:                aria2-1.18.5.ebuild
  Log:
  Version bump (bug #514944), add USE flags to switch malloc() implementation.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0x1A5D023975B0583D!)

Revision  Changes    Path
1.12                 net-misc/aria2/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/metadata.xml?rev=1.12&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/metadata.xml?rev=1.12&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/metadata.xml?r1=1.11&r2=1.12

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/aria2/metadata.xml,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- metadata.xml        16 Oct 2013 20:57:56 -0000      1.11
+++ metadata.xml        27 Jun 2014 13:16:09 -0000      1.12
@@ -11,6 +11,7 @@
        </maintainer>
        <use>
                <flag name="bittorrent">Enable support for the bittorrent 
protocol.</flag>
+               <flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> to 
replace the malloc() implementation with a possibly faster one</flag>
                <flag name="libuv">Use <pkg>dev-libs/libuv</pkg> backend.</flag>
                <flag name="libxml2">Use <pkg>dev-libs/libxml2</pkg> for XML 
parsing (preferred) instead of <pkg>dev-libs/expat</pkg>.</flag>
                <flag name="nettle">Use <pkg>dev-libs/nettle</pkg> and 
<pkg>dev-libs/gmp</pkg> for bittorrent/metalink crypto instead of 
<pkg>dev-libs/libgcrypt</pkg> (when <pkg>dev-libs/openssl</pkg> is not being 
used).</flag>



1.95                 net-misc/aria2/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/ChangeLog?rev=1.95&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/ChangeLog?rev=1.95&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/ChangeLog?r1=1.94&r2=1.95

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v
retrieving revision 1.94
retrieving revision 1.95
diff -u -r1.94 -r1.95
--- ChangeLog   28 May 2014 07:27:39 -0000      1.94
+++ ChangeLog   27 Jun 2014 13:16:09 -0000      1.95
@@ -1,6 +1,12 @@
 # ChangeLog for net-misc/aria2
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.94 2014/05/28 
07:27:39 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.95 2014/06/27 
13:16:09 dev-zero Exp $
+
+*aria2-1.18.5 (27 Jun 2014)
+
+  27 Jun 2014; Tiziano Müller <dev-z...@gentoo.org> +aria2-1.18.5.ebuild,
+  metadata.xml:
+  Version bump (bug #514944), add USE flags to switch malloc() implementation.
 
   28 May 2014; Sergey Popov <pinkb...@gentoo.org> aria2-1.18.0.ebuild:
   Add ~amd64-linux and ~x86-linux, wrt bug #488294



1.1                  net-misc/aria2/aria2-1.18.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/aria2-1.18.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/aria2/aria2-1.18.5.ebuild?rev=1.1&content-type=text/plain

Index: aria2-1.18.5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.18.5.ebuild,v 1.1 
2014/06/27 13:16:09 dev-zero Exp $

EAPI="5"

inherit bash-completion-r1 eutils

DESCRIPTION="A download utility with segmented downloading with BitTorrent 
support"
HOMEPAGE="http://aria2.sourceforge.net/";
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"

LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls 
sqlite scripts ssl tcmalloc test xmlrpc"

CDEPEND="sys-libs/zlib:0=
        ssl? (
                app-misc/ca-certificates
                gnutls? ( >=net-libs/gnutls-1.2.9:0= )
                !gnutls? ( dev-libs/openssl:0= ) )
        adns? ( >=net-dns/c-ares-1.5.0:0= )
        bittorrent? (
                ssl? (
                        gnutls? (
                                nettle? ( >=dev-libs/nettle-2.4:0=[gmp] 
>=dev-libs/gmp-5:0= )
                                !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
                !ssl? (
                        nettle? ( >=dev-libs/nettle-2.4:0=[gmp] 
>=dev-libs/gmp-5:0= )
                        !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
        jemalloc? ( dev-libs/jemalloc )
        libuv? ( dev-libs/libuv:0= )
        metalink? (
                libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
                !libxml2? ( dev-libs/expat:0= ) )
        sqlite? ( dev-db/sqlite:3= )
        tcmalloc? ( dev-util/google-perftools )
        xmlrpc? (
                libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
                !libxml2? ( dev-libs/expat:0= ) )"

DEPEND="${CDEPEND}
        virtual/pkgconfig
        nls? ( sys-devel/gettext )
        test? ( >=dev-util/cppunit-1.12.0:0 )"
RDEPEND="${CDEPEND}
        nls? ( virtual/libiconv virtual/libintl )
        scripts? ( dev-lang/ruby )"

REQUIRED_USE="jemalloc? ( !tcmalloc )
        tcmalloc? ( !jemalloc )"

pkg_setup() {
        if use scripts && use !xmlrpc && use !metalink; then
                ewarn "Please note that you may need to enable USE=xmlrpc to 
run the aria2rpc"
                ewarn "and aria2mon scripts against the local aria2."
        fi
}

src_prepare() {
        epatch_user
        sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
}

src_configure() {
        local myconf=(
                # threads, epoll: check for best portability

                # do not try to compile and run a test LIBXML program
                --disable-xmltest
                # enable the shared library
                --enable-libaria2
                # zlib should always be available anyway
                --with-libz
                --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"

                # optional features
                $(use_enable bittorrent)
                $(use_enable metalink)
                $(use_enable nls)
                $(use_with sqlite sqlite3)
                $(use_with adns libcares)
                $(use_with libuv)
                $(use_with jemalloc)
                $(use_with tcmalloc)
        )

        # SSL := gnutls / openssl
        # USE=ssl
        #  + USE=gnutls -> gnutls
        #  + USE=-gnutls -> openssl

        if use ssl; then
                myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
        else
                myconf+=( --without-gnutls --without-openssl )
        fi

        # message-digest := nettle / gcrypt / openssl
        # bignum := nettle+gmp / gcrypt / openssl
        # bittorrent := message-digest + bignum
        # USE=bittorrent
        #  + USE=(ssl -gnutls) -> openssl
        #  + USE=nettle -> nettle+gmp
        #  + USE=-nettle -> gcrypt

        if use !bittorrent || use ssl && use !gnutls; then
                myconf+=( --without-libgcrypt --without-libnettle 
--without-libgmp )
        else
                myconf+=( $(use_with !nettle libgcrypt)
                        $(use_with nettle libnettle) $(use_with nettle libgmp) )
        fi

        # metalink+xmlrpc := libxml2 / expat
        # USE=(metalink || xmlrpc)
        #  + USE=libxml2 -> libxml2
        #  + USE=-libxml2 -> expat

        if use metalink || use xmlrpc; then
                myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
        else
                myconf+=( --without-libexpat --without-libxml2 )
        fi

        # Note:
        # - always enable gzip/http compression since zlib should always be 
available anyway
        # - always enable epoll since we can assume kernel 2.6.x
        # - other options for threads: solaris, pth, win32
        econf "${myconf[@]}"
}

src_install() {
        default
        rm -rf "${D}"/usr/share/doc/aria2 \
                "${D}"/usr/share/doc/${PF}/README{,.html}

        dobashcomp doc/bash_completion/aria2c
        use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
}

pkg_postinst() {
        if use xmlrpc || use metalink; then
                elog "If you would like to use the additional aria2mon and 
aria2rpc tools,"
                elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
        fi
}




Reply via email to