chainsaw    14/08/05 10:38:01

  Modified:             ChangeLog
  Added:                connman-1.24.ebuild
  Log:
  Version bump, as requested by Milton in bug #517574.
  
  (Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xB5058F9A)

Revision  Changes    Path
1.86                 net-misc/connman/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/connman/ChangeLog?rev=1.86&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/connman/ChangeLog?rev=1.86&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/connman/ChangeLog?r1=1.85&r2=1.86

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v
retrieving revision 1.85
retrieving revision 1.86
diff -u -r1.85 -r1.86
--- ChangeLog   2 May 2014 15:32:49 -0000       1.85
+++ ChangeLog   5 Aug 2014 10:38:01 -0000       1.86
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/connman
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.85 
2014/05/02 15:32:49 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.86 
2014/08/05 10:38:01 chainsaw Exp $
+
+*connman-1.24 (05 Aug 2014)
+
+  05 Aug 2014; Tony Vroon <chain...@gentoo.org> +connman-1.24.ebuild:
+  Version bump, as requested by Milton in bug #517574.
 
 *connman-1.23 (02 May 2014)
 *connman-1.22 (02 May 2014)



1.1                  net-misc/connman/connman-1.24.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/connman/connman-1.24.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/connman/connman-1.24.ebuild?rev=1.1&content-type=text/plain

Index: connman-1.24.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.24.ebuild,v 1.1 
2014/08/05 10:38:01 chainsaw Exp $

EAPI="5"
inherit base systemd

DESCRIPTION="Provides a daemon for managing internet connections"
HOMEPAGE="http://connman.net";
SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="bluetooth debug doc examples +ethernet ofono openvpn openconnect 
policykit tools vpnc +wifi"

RDEPEND=">=dev-libs/glib-2.16
        >=sys-apps/dbus-1.2.24
        >=net-firewall/iptables-1.4.8
        net-libs/gnutls
        bluetooth? ( net-wireless/bluez )
        ofono? ( net-misc/ofono )
        policykit? ( sys-auth/polkit )
        openvpn? ( net-misc/openvpn )
        vpnc? ( net-misc/vpnc )
        wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )"

DEPEND="${RDEPEND}
        >=sys-kernel/linux-headers-2.6.39"

PATCHES=( "${FILESDIR}/${PN}-1.16-execinfo-assumptions.patch" )

src_configure() {
        econf \
                --localstatedir=/var \
                --enable-client \
                --enable-datafiles \
                --enable-loopback=builtin \
                $(use_enable examples test) \
                $(use_enable ethernet ethernet builtin) \
                $(use_enable wifi wifi builtin) \
                $(use_enable bluetooth bluetooth builtin) \
                $(use_enable ofono ofono builtin) \
                $(use_enable openconnect openconnect builtin) \
                $(use_enable openvpn openvpn builtin) \
                $(use_enable policykit polkit builtin) \
                $(use_enable vpnc vpnc builtin) \
                $(use_enable debug) \
                $(use_enable tools) \
                --disable-iospm \
                --disable-hh2serial-gps
}

src_install() {
        emake DESTDIR="${D}" install
        dobin client/connmanctl || die "client installation failed"

        if use doc; then
                dodoc doc/*.txt
        fi
        keepdir /var/lib/${PN}
        newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
        newconfd "${FILESDIR}"/${PN}.confd ${PN}
        systemd_dounit "${FILESDIR}"/connman.service
}




Reply via email to