blueness    14/05/19 12:25:07

  Modified:             ChangeLog
  Added:                ipv6calc-0.97.0.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xF52D4BBA)

Revision  Changes    Path
1.76                 net-misc/ipv6calc/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ipv6calc/ChangeLog?rev=1.76&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ipv6calc/ChangeLog?rev=1.76&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ipv6calc/ChangeLog?r1=1.75&r2=1.76

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v
retrieving revision 1.75
retrieving revision 1.76
diff -u -r1.75 -r1.76
--- ChangeLog   21 Mar 2014 16:34:01 -0000      1.75
+++ ChangeLog   19 May 2014 12:25:07 -0000      1.76
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/ipv6calc
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.75 
2014/03/21 16:34:01 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.76 
2014/05/19 12:25:07 blueness Exp $
+
+*ipv6calc-0.97.0 (19 May 2014)
+
+  19 May 2014; Anthony G. Basile <bluen...@gentoo.org> +ipv6calc-0.97.0.ebuild:
+  Version bump
 
   21 Mar 2014; Tom Wijsman <tom...@gentoo.org> metadata.xml:
   Updated Aaron's e-mail address.



1.1                  net-misc/ipv6calc/ipv6calc-0.97.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.97.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.97.0.ebuild?rev=1.1&content-type=text/plain

Index: ipv6calc-0.97.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.97.0.ebuild,v 
1.1 2014/05/19 12:25:07 blueness Exp $

EAPI="5"
inherit eutils

DESCRIPTION="IPv6 address calculator"
HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html";
SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="geoip test"

RDEPEND="
        dev-libs/openssl
        geoip? ( >=dev-libs/geoip-1.4.7 )
"
DEPEND="${RDEPEND}
        test? ( dev-perl/Digest-SHA1 )
"

#dev-perl/URI is needed for web interface, that is not installed now

src_configure() {
        if use geoip; then
                myconf=$(use_enable geoip)
                myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
        fi
        econf \
                --disable-bundled-getopt \
                --disable-bundled-md5 \
                --disable-shared \
                --enable-dynamic-load \
                --enable-db-ieee \
                --enable-db-ipv4 \
                --disable-db-ipv6 \
                --disable-ip2location \
                ${myconf}
}

src_compile() {
        # Disable default CFLAGS (-O2 and -g)
        emake DEFAULT_CFLAGS=""
}

src_test() {
        if [[ ${EUID} -eq 0 ]]; then
                # Disable tests that fail as root
                echo true > ipv6logstats/test_ipv6logstats.sh
        fi
        default
}

src_install() {
        emake DESTDIR="${D}" install
        dodoc ChangeLog CREDITS README TODO USAGE
}




Reply via email to