tomka       15/01/19 12:32:36

  Modified:             metadata.xml ChangeLog
  Added:                wicd-1.7.3.ebuild
  Removed:              wicd-1.7.2.4-r2.ebuild
  Log:
  bump to 1.7.3, remove old
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.14                 net-misc/wicd/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/metadata.xml?rev=1.14&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/metadata.xml?rev=1.14&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/metadata.xml?r1=1.13&r2=1.14

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/wicd/metadata.xml,v
retrieving revision 1.13
retrieving revision 1.14
diff -u -r1.13 -r1.14
--- metadata.xml        2 Jun 2013 11:00:43 -0000       1.13
+++ metadata.xml        19 Jan 2015 12:32:36 -0000      1.14
@@ -14,6 +14,7 @@
        <flag name='mac4lin'>Change default icons to mac4lin icon set</flag>
        <flag name='ncurses'>Installs a ncurses UI</flag>
        <flag name='pm-utils'>Installs the pm-utils hooks for suspend/resume and
-               requires <pkg>sys-power/pm-utils</pkg></flag>
+       requires <pkg>sys-power/pm-utils</pkg></flag>
+       <flag name='gnome-shell'>Install gnome-shell extension</flag>
 </use>
 </pkgmetadata>



1.151                net-misc/wicd/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/ChangeLog?rev=1.151&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/ChangeLog?rev=1.151&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/ChangeLog?r1=1.150&r2=1.151

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v
retrieving revision 1.150
retrieving revision 1.151
diff -u -r1.150 -r1.151
--- ChangeLog   2 Aug 2014 18:18:19 -0000       1.150
+++ ChangeLog   19 Jan 2015 12:32:36 -0000      1.151
@@ -1,6 +1,14 @@
 # ChangeLog for net-misc/wicd
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.150 2014/08/02 
18:18:19 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.151 2015/01/19 
12:32:36 tomka Exp $
+
+*wicd-1.7.3 (19 Jan 2015)
+
+  19 Jan 2015; Thomas Kahle <to...@gentoo.org>
+  +files/wicd-1.7.3-add-missing-gnome-shell-extension.patch, 
+wicd-1.7.3.ebuild,
+  -files/wicd-1.7.1_pre20111210-fix-config-reading.patch,
+  -wicd-1.7.2.4-r2.ebuild, metadata.xml:
+  bump to 1.7.3, remove old
 
   02 Aug 2014; Agostino Sarubbo <a...@gentoo.org> wicd-1.7.2.4-r3.ebuild:
   Stable for ppc64, wrt bug #509752



1.1                  net-misc/wicd/wicd-1.7.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/wicd-1.7.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/wicd/wicd-1.7.3.ebuild?rev=1.1&content-type=text/plain

Index: wicd-1.7.3.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.7.3.ebuild,v 1.1 
2015/01/19 12:32:36 tomka Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="ncurses?,xml"

inherit eutils distutils-r1 linux-info readme.gentoo systemd

DESCRIPTION="A lightweight wired and wireless network manager for Linux"
HOMEPAGE="https://launchpad.net/wicd";
SRC_URI="http://launchpad.net/wicd/1.7/${PV}/+download/${P}.tar.gz
        mac4lin? ( 
http://dev.gentoo.org/~anarchy/dist/wicd-mac4lin-icons.tar.xz )
        ambiance? ( 
http://freetimesblog.altervista.org/blog/wp-content/uploads/downloads/2010/05/Icone-Wicd-Lucid.tar.gz
 )"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="doc X ambiance +gtk ioctl libnotify mac4lin ncurses nls +pm-utils 
gnome-shell"

DEPEND="nls? ( dev-python/Babel )"
RDEPEND="${PYTHON_DEPS}
        dev-python/dbus-python[${PYTHON_USEDEP}]
        X? (
                gtk? ( dev-python/pygtk )
                || (
                        x11-misc/ktsuss
                        x11-libs/gksu
                        kde-base/kdesu
                        )
        )
        || (
                net-misc/dhcpcd
                net-misc/dhcp
                net-misc/pump
        )
        net-wireless/wireless-tools
        net-wireless/wpa_supplicant
        || (
                sys-apps/net-tools
                sys-apps/ethtool
        )
        !gtk? ( dev-python/pygobject:2[${PYTHON_USEDEP}] )
        ioctl? ( dev-python/python-iwscan dev-python/python-wpactrl )
        libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
        ncurses? (
                dev-python/urwid
                dev-python/pygobject:2[${PYTHON_USEDEP}]
        )
        pm-utils? ( sys-power/pm-utils )
        gnome-shell? ( gnome-base/gnome-shell )
        "

src_prepare() {
        CONFIG_CHECK="~CFG80211_WEXT"
        local WARNING_CFG80211_WEXT="Wireless extensions have not been \
        configured in your kernel.  Wicd will not work unless CFG80211_WEXT is 
set."
        check_extra_config

        epatch "${FILESDIR}"/${PN}-init-sve-start.patch
        # The Categories entry in the .desktop files is outdated
        epatch "${FILESDIR}"/${PN}-1.7.2.4-fix-desktop-categories.patch
        # Upstream bug https://bugs.launchpad.net/wicd/+bug/1412413
        # Creates files -> give -p
        epatch -p1 "${FILESDIR}"/${P}-add-missing-gnome-shell-extension.patch
        # get rid of opts variable to fix bug 381885
        sed -i "/opts/d" "in/init=gentoo=wicd.in" || die
        # Need to ensure that generated scripts use Python 2 at run time.
        sed -e "s:self.python = '/usr/bin/python':self.python = 
'/usr/bin/python2':" \
          -i setup.py || die "sed failed"
        # Fix misc helper scripts:
        sed -e "s:/usr/bin/env python:/usr/bin/env python2:" \
                -i wicd/suspend.py wicd/autoconnect.py wicd/monitor.py
        if use nls; then
          # Asturian is faulty with PyBabel
          # (https://bugs.launchpad.net/wicd/+bug/928589)
          rm po/ast.po
          # zh_CN fails with newer PyBabel (Aug 2013)
          rm po/zh_CN.po
        else
          # nuke translations
          rm po/*.po
        fi

        DOC_CONTENTS="To start wicd at boot with openRC, add
                /etc/init.d/wicd to a runlevel and: (1) Remove all net.*
                initscripts (except for net.lo) from all runlevels (2) Add these
                scripts to the RC_PLUG_SERVICES line in /etc/rc.conf (For
                example, rc_hotplug=\"!net.eth* !net.wlan*\")"
}

src_configure() {
        local myconf
        use gtk || myconf="${myconf} --no-install-gtk"
        use libnotify || myconf="${myconf} --no-use-notifications"
        use ncurses || myconf="${myconf} --no-install-ncurses"
        use pm-utils || myconf="${myconf} --no-install-pmutils"
        use gnome-shell || myconf="${myconf} 
--no-install-gnome-shell-extensions"
        python_export_best
        "${EPYTHON}" ./setup.py configure --no-install-docs \
                --resume=/usr/share/wicd/scripts/ \
                --suspend=/usr/share/wicd/scripts/ \
                --verbose ${myconf}
}

src_install() {
        distutils-r1_src_install
        keepdir /var/lib/wicd/configurations
        keepdir /etc/wicd/scripts/{postconnect,disconnect,preconnect}
        keepdir /var/log/wicd
        use nls || rm -rf "${D}"/usr/share/locale
        systemd_dounit "${S}/other/wicd.service"

        if use mac4lin; then
                rm -rf "${D}"/usr/share/pixmaps/wicd || die "Failed to remove 
old icons"
                mv "${WORKDIR}"/wicd "${D}"/usr/share/pixmaps/
        fi
        if use ambiance; then
                # Overwrite tray icons with ambiance icon
                rm "${WORKDIR}/Icone Wicd Lucid"/signal*
                cp "${WORKDIR}/Icone Wicd Lucid"/*.png 
"${D}"/usr/share/pixmaps/wicd/
        fi
        readme.gentoo_src_install
}

pkg_postinst() {
        # Maintainer's note: the consolekit use flag short circuits a dbus rule 
and
        # allows the connection. Else, you need to be in the group.
        if ! has_version sys-auth/consolekit; then
                ewarn "Wicd-1.6 and newer requires your user to be in the 
'users' group. If"
                ewarn "you are not in that group, then modify 
/etc/dbus-1/system.d/wicd.conf"
        fi

        readme.gentoo_print_elog
}




Reply via email to