jer         14/04/13 13:25:19

  Modified:             ChangeLog
  Added:                youtube-dl-2014.04.13.ebuild
  Removed:              youtube-dl-2014.03.25.1.ebuild
                        youtube-dl-2014.03.27.1.ebuild
                        youtube-dl-2014.03.29.ebuild
                        youtube-dl-2014.03.30.1.ebuild
                        youtube-dl-2014.03.21.5.ebuild
                        youtube-dl-2014.03.24.1.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
A792A613)

Revision  Changes    Path
1.330                net-misc/youtube-dl/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/ChangeLog?rev=1.330&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/ChangeLog?rev=1.330&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/ChangeLog?r1=1.329&r2=1.330

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v
retrieving revision 1.329
retrieving revision 1.330
diff -u -r1.329 -r1.330
--- ChangeLog   11 Apr 2014 14:52:35 -0000      1.329
+++ ChangeLog   13 Apr 2014 13:25:19 -0000      1.330
@@ -1,6 +1,14 @@
 # ChangeLog for net-misc/youtube-dl
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.329 
2014/04/11 14:52:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.330 
2014/04/13 13:25:19 jer Exp $
+
+*youtube-dl-2014.04.13 (13 Apr 2014)
+
+  13 Apr 2014; Jeroen Roovers <j...@gentoo.org> 
-youtube-dl-2014.03.21.5.ebuild,
+  -youtube-dl-2014.03.24.1.ebuild, -youtube-dl-2014.03.25.1.ebuild,
+  -youtube-dl-2014.03.27.1.ebuild, -youtube-dl-2014.03.29.ebuild,
+  -youtube-dl-2014.03.30.1.ebuild, +youtube-dl-2014.04.13.ebuild:
+  Version bump.
 
 *youtube-dl-2014.04.11.2 (11 Apr 2014)
 



1.1                  net-misc/youtube-dl/youtube-dl-2014.04.13.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.04.13.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.04.13.ebuild?rev=1.1&content-type=text/plain

Index: youtube-dl-2014.04.13.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.04.13.ebuild,v 1.1 
2014/04/13 13:25:19 jer Exp $

EAPI=5

PYTHON_COMPAT=(python{2_6,2_7,3_3})
DISTUTILS_SINGLE_IMPL=true
inherit bash-completion-r1 distutils-r1 eutils

DESCRIPTION="Download videos from YouTube.com (and mores sites...)"
HOMEPAGE="http://rg3.github.com/youtube-dl/";
SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz";

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux 
~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="offensive test"

DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/nose[coverage(+)] )
"

S="${WORKDIR}/${PN}"

src_prepare() {
        if ! use offensive; then
                sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
                        youtube_dl/version.py || die
                local xxx=(
                        extremetube fourtube mofosex pornhd pornhub pornotube 
redtube
                        spankwire thisav trutube tube8 xbef xhamster xnxx xtube 
xvideos youjizz youporn
                )
                sed -i -e $( printf '/%s/d;' ${xxx[@]} ) 
youtube_dl/extractor/__init__.py || die
                rm $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
                        test/test_age_restriction.py || die
        fi
}

src_compile() {
        distutils-r1_src_compile
}

src_test() {
        emake test
}

src_install() {
        python_domodule youtube_dl
        dobin bin/${PN}
        dodoc CHANGELOG README.txt
        doman ${PN}.1
        newbashcomp ${PN}.bash-completion ${PN}
        python_fix_shebang "${ED}"
}




Reply via email to