blueness    14/05/26 21:36:05

  Modified:             ChangeLog
  Added:                litecoin-qt-0.8.7.1.ebuild
  Log:
  Version bump, bug #508934
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xF52D4BBA)

Revision  Changes    Path
1.3                  net-p2p/litecoin-qt/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/litecoin-qt/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/litecoin-qt/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/litecoin-qt/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   28 Dec 2013 20:54:54 -0000      1.2
+++ ChangeLog   26 May 2014 21:36:05 -0000      1.3
@@ -1,6 +1,12 @@
 # ChangeLog for net-p2p/litecoin-qt
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/ChangeLog,v 1.2 
2013/12/28 20:54:54 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/ChangeLog,v 1.3 
2014/05/26 21:36:05 blueness Exp $
+
+*litecoin-qt-0.8.7.1 (26 May 2014)
+
+  26 May 2014; Anthony G. Basile <bluen...@gentoo.org>
+  +litecoin-qt-0.8.7.1.ebuild:
+  Version bump, bug #508934
 
 *litecoin-qt-0.8.6.1 (28 Dec 2013)
 



1.1                  net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild?rev=1.1&content-type=text/plain

Index: litecoin-qt-0.8.7.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-p2p/litecoin-qt/litecoin-qt-0.8.7.1.ebuild,v 1.1 
2014/05/26 21:36:05 blueness Exp $

EAPI=5

DB_VER="4.8"

LANGS="af_ZA ar bg bs ca ca_ES cs cy da de el_GR en eo es es_CL et eu_ES fa 
fa_IR fi fr fr_CA gu_IN he hi_IN hr hu it ja la lt lv_LV nb nl pl pt_BR pt_PT 
ro_RO ru sk sr sv th_TH tr uk zh_CN zh_TW"
inherit db-use eutils fdo-mime gnome2-utils kde4-functions qt4-r2

MyPV="${PV/_/-}"
MyPN="litecoin"
MyP="${MyPN}-${MyPV}"

DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine."
HOMEPAGE="https://litecoin.org/";
SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> 
${MyP}.tar.gz"

LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain || ( CC-BY-SA-3.0 LGPL-2.1 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dbus ipv6 kde +qrcode upnp"

RDEPEND="
        dev-libs/boost[threads(+)]
        dev-libs/openssl:0[-bindist]
        qrcode? (
                media-gfx/qrencode
        )
        upnp? (
                net-libs/miniupnpc
        )
        sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
        <=dev-libs/leveldb-1.12.0[-snappy]
        dev-qt/qtgui:4
        dbus? (
                dev-qt/qtdbus:4
        )
"
DEPEND="${RDEPEND}
        >=app-shells/bash-4.1
"

DOCS="doc/README.md doc/release-notes.md"

S="${WORKDIR}/${MyP}"

src_prepare() {
        epatch "${FILESDIR}"/${MyPN}-sys_leveldb.patch
        rm -r src/leveldb

        cd src || die

        local filt= yeslang= nolang=

        for lan in $LANGS; do
                if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
                        ewarn "Language '$lan' no longer supported. Ebuild 
needs update."
                fi
        done

        for ts in $(ls qt/locale/*.ts)
        do
                x="${ts/*bitcoin_/}"
                x="${x/.ts/}"
                if ! use "linguas_$x"; then
                        nolang="$nolang $x"
                        rm "$ts"
                        filt="$filt\\|$x"
                else
                        yeslang="$yeslang $x"
                fi
        done

        filt="bitcoin_\\(${filt:2}\\)\\.\(qm\|ts\)"
        sed "/${filt}/d" -i 'qt/bitcoin.qrc'
        einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
}

src_configure() {
        OPTS=()

        use dbus && OPTS+=("USE_DBUS=1")
        if use upnp; then
                OPTS+=("USE_UPNP=1")
        else
                OPTS+=("USE_UPNP=-")
        fi

        use qrcode && OPTS+=("USE_QRCODE=1")
        use ipv6 || OPTS+=("USE_IPV6=-")

        OPTS+=("USE_SYSTEM_LEVELDB=1")
        OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
        OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")

        if has_version '>=dev-libs/boost-1.52'; then
                OPTS+=("LIBS+=-lboost_chrono\$\$BOOST_LIB_SUFFIX")
        fi

        #The litecoin codebase is mostly taken from bitcoin-qt
        eqmake4 bitcoin-qt.pro "${OPTS[@]}"
}

#Tests are broken with and without our litecoin-sys_leveldb.patch
#src_test() {
#       cd src || die
#       emake -f makefile.unix "${OPTS[@]}" test_litecoin
#       ./test_litecoin || die 'Tests failed'
#}

src_install() {
        qt4-r2_src_install

        dobin ${PN}

        insinto /usr/share/pixmaps
        newins "share/pixmaps/bitcoin.ico" "${PN}.ico"

        make_desktop_entry "${PN} %u" "Litecoin-Qt" 
"/usr/share/pixmaps/${PN}.ico" "Qt;Network;P2P;Office;Finance;" 
"MimeType=x-scheme-handler/litecoin;\nTerminal=false"

        newman contrib/debian/manpages/bitcoin-qt.1 ${PN}.1

        if use kde; then
                insinto /usr/share/kde4/services
                newins contrib/debian/bitcoin-qt.protocol ${PN}.protocol
        fi
}

update_caches() {
        gnome2_icon_cache_update
        fdo-mime_desktop_database_update
        buildsycoca
}

pkg_postinst() {
        update_caches
}

pkg_postrm() {
        update_caches
}




Reply via email to