zx2c4       14/04/25 12:50:37

  Modified:             ChangeLog
  Added:                uhd-3.7.1.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
A5DE03AE)

Revision  Changes    Path
1.11                 net-wireless/uhd/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-wireless/uhd/ChangeLog?rev=1.11&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-wireless/uhd/ChangeLog?rev=1.11&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-wireless/uhd/ChangeLog?r1=1.10&r2=1.11

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v
retrieving revision 1.10
retrieving revision 1.11
diff -u -r1.10 -r1.11
--- ChangeLog   22 Feb 2014 00:32:38 -0000      1.10
+++ ChangeLog   25 Apr 2014 12:50:37 -0000      1.11
@@ -1,6 +1,11 @@
 # ChangeLog for net-wireless/uhd
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.10 
2014/02/22 00:32:38 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.11 
2014/04/25 12:50:37 zx2c4 Exp $
+
+*uhd-3.7.1 (25 Apr 2014)
+
+  25 Apr 2014; Jason A. Donenfeld <zx...@gentoo.org> +uhd-3.7.1.ebuild:
+  Version bump.
 
 *uhd-3.7.0 (22 Feb 2014)
 *uhd-3.6.2 (22 Feb 2014)



1.1                  net-wireless/uhd/uhd-3.7.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-wireless/uhd/uhd-3.7.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-wireless/uhd/uhd-3.7.1.ebuild?rev=1.1&content-type=text/plain

Index: uhd-3.7.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/uhd-3.7.1.ebuild,v 1.1 
2014/04/25 12:50:37 zx2c4 Exp $

EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit versionator python-single-r1 cmake-utils multilib

DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
HOMEPAGE="http://code.ettus.com/redmine/ettus/projects/uhd/wiki";

image_version=uhd-images_00$(get_version_component_range 
1).00$(get_version_component_range 2).00$(get_version_component_range 3)-release
SRC_URI="https://github.com/EttusResearch/uhd/archive/release_00$(get_version_component_range
 1)_00$(get_version_component_range 2)_00$(get_version_component_range 
3).tar.gz -> EttusResearch-UHD-$(get_version_component_range 
1).$(get_version_component_range 2).$(get_version_component_range 3).tar.gz \
        
http://files.ettus.com/binaries/maint_images/archive/${image_version}.tar.gz";
#https://github.com/EttusResearch/UHD-Mirror/tags
#http://files.ettus.com/binaries/master_images/archive
KEYWORDS="~amd64 ~arm ~x86"
S="${WORKDIR}"/uhd-release_00$(get_version_component_range 
1)_00$(get_version_component_range 2)_00$(get_version_component_range 3)/host

LICENSE="GPL-3"
SLOT="0/1"
IUSE=""
RDEPEND="virtual/libusb:1
        dev-libs/boost:="
DEPEND="${RDEPEND}
        dev-python/cheetah"

src_prepare() {
        #this may not be needed in 3.4.3 and above, please verify
        sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR 
${LIBRARY_DIR}/uhd)#g' CMakeLists.txt
}

src_install() {
        cmake-utils_src_install
        python_fix_shebang "${ED}"/usr/$(get_libdir)/${PN}/utils/
        insinto /lib/udev/rules.d/
        doins "${S}"/utils/uhd-usrp.rules
        insinto /usr/share/${PN}
        doins -r "${WORKDIR}"/"${image_version}"/share/uhd/images
}




Reply via email to