jlec        14/06/03 06:54:27

  Modified:             ChangeLog
  Added:                biopython-1.64.ebuild
  Log:
  sci-biology/biopython: Version Bump, thanks Martin Mokrejs 
<mmokr...@fold.natur.cuni.cz> preparing the ebuild
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
B9D4F231BD1558AB!)

Revision  Changes    Path
1.76                 sci-biology/biopython/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-biology/biopython/ChangeLog?rev=1.76&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-biology/biopython/ChangeLog?rev=1.76&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-biology/biopython/ChangeLog?r1=1.75&r2=1.76

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v
retrieving revision 1.75
retrieving revision 1.76
diff -u -r1.75 -r1.76
--- ChangeLog   7 May 2014 11:00:43 -0000       1.75
+++ ChangeLog   3 Jun 2014 06:54:27 -0000       1.76
@@ -1,6 +1,12 @@
 # ChangeLog for sci-biology/biopython
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.75 
2014/05/07 11:00:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.76 
2014/06/03 06:54:27 jlec Exp $
+
+*biopython-1.64 (03 Jun 2014)
+
+  03 Jun 2014; Justin Lecher <j...@gentoo.org> +biopython-1.64.ebuild:
+  Version Bump, thanks Martin Mokrejs <mmokr...@fold.natur.cuni.cz> preparing
+  the ebuild
 
 *biopython-1.63-r1 (07 May 2014)
 



1.1                  sci-biology/biopython/biopython-1.64.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-biology/biopython/biopython-1.64.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-biology/biopython/biopython-1.64.ebuild?rev=1.1&content-type=text/plain

Index: biopython-1.64.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.64.ebuild,v 1.1 
2014/06/03 06:54:27 jlec Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 eutils

DESCRIPTION="Python modules for computational molecular biology"
HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/";
SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz";

LICENSE="HPND"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="mysql postgres"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
        dev-python/matplotlib[${PYTHON_USEDEP}]
        dev-python/networkx[${PYTHON_USEDEP}]
        dev-python/numpy[${PYTHON_USEDEP}]
        dev-python/rdflib[${PYTHON_USEDEP}]
        dev-python/pygraphviz[${PYTHON_USEDEP}]
        dev-python/reportlab[${PYTHON_USEDEP}]
        media-gfx/pydot[${PYTHON_USEDEP}]
        mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
        postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
        sys-devel/flex"

DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )

python_test() {
        cd Tests || die
        ${PYTHON} run_tests.py || die
}

python_install_all() {
        distutils-r1_python_install_all

        dodir /usr/share/${PN}
        cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
}




Reply via email to