calchan     14/04/25 16:12:00

  Modified:             ChangeLog
  Added:                ngspice-26.ebuild
  Log:
  Version bump (bug #504896).
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.8                  sci-electronics/ngspice/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/ngspice/ChangeLog?rev=1.8&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/ngspice/ChangeLog?rev=1.8&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/ngspice/ChangeLog?r1=1.7&r2=1.8

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-electronics/ngspice/ChangeLog,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- ChangeLog   20 Feb 2013 00:32:43 -0000      1.7
+++ ChangeLog   25 Apr 2014 16:12:00 -0000      1.8
@@ -1,6 +1,11 @@
 # ChangeLog for sci-electronics/ngspice
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ngspice/ChangeLog,v 1.7 
2013/02/20 00:32:43 calchan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ngspice/ChangeLog,v 1.8 
2014/04/25 16:12:00 calchan Exp $
+
+*ngspice-26 (25 Apr 2014)
+
+  25 Apr 2014; Denis Dupeyron <calc...@gentoo.org> +ngspice-26.ebuild:
+  Version bump (bug #504896).
 
   20 Feb 2013; Denis Dupeyron <calc...@gentoo.org> -ngspice-23.ebuild,
   ngspice-24.ebuild, ngspice-25.ebuild:



1.1                  sci-electronics/ngspice/ngspice-26.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/ngspice/ngspice-26.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/ngspice/ngspice-26.ebuild?rev=1.1&content-type=text/plain

Index: ngspice-26.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ngspice/ngspice-26.ebuild,v 
1.1 2014/04/25 16:12:00 calchan Exp $

EAPI="3"

inherit autotools eutils

DESCRIPTION="The Next Generation Spice (Electronic Circuit Simulator)."
SRC_URI="mirror://sourceforge/ngspice/${P}.tar.gz
        mirror://sourceforge/ngspice/${PN}-${PV}-manual.pdf"
HOMEPAGE="http://ngspice.sourceforge.net";
LICENSE="BSD GPL-2"

SLOT="0"
IUSE="X debug readline"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"

DEPEND="sys-libs/ncurses
        readline? ( >=sys-libs/readline-5.0 )
        X? ( x11-libs/libXaw
                x11-libs/libXt
                x11-libs/libX11
                sci-visualization/xgraph )"

RDEPEND="$DEPEND"

src_prepare() {
        sed -e '/CFLAGS=/s: -s::' -i configure.ac || die "sed failed"
        sed -e 's/_CFLAGS -O2/_CFLAGS/' -i configure.ac || die "sed failed"
        sed -e 's/LDFLAGS =/LDFLAGS +=/' -i src/xspice/icm/makedefs.in || die 
"sed failed"
        sed -e '/AM_INIT_AUTOMAKE/s:-Werror::' -i configure.ac || die "sed 
failed"
        eautoreconf
}

src_configure() {
        local MYCONF
        if use debug ; then
                MYCONF="--enable-debug \
                        --enable-ftedebug \
                        --enable-cpdebug \
                        --enable-asdebug \
                        --enable-stepdebug \
                        --enable-pzdebug"
        else
                MYCONF="--disable-debug \
                        --disable-ftedebug \
                        --disable-cpdebug \
                        --disable-asdebug \
                        --disable-stepdebug \
                        --disable-pzdebug"
        fi
        # Those don't compile
        MYCONF="${MYCONF} \
                --disable-sensdebug \
                --disable-blktmsdebug \
                --disable-smltmsdebug"

        econf \
                ${MYCONF} \
                --enable-xspice \
                --enable-cider \
                --enable-ndev \
                --disable-xgraph \
                --disable-dependency-tracking \
                --disable-rpath \
                $(use_with X x) \
                $(use_with readline)
}

# These will need to be looked at some day:
# --enable-adms
# --enable-nodelimiting
# --enable-predictor
# --enable-newtrunc
# --enable-openmp

src_install () {
        local infoFile
        for infoFile in doc/ngspice.info*; do
                echo 'INFO-DIR-SECTION EDA' >> ${infoFile}
                echo 'START-INFO-DIR-ENTRY' >> ${infoFile}
                echo '* NGSPICE: (ngspice). Electronic Circuit Simulator.' >> 
${infoFile}
                echo 'END-INFO-DIR-ENTRY' >> ${infoFile}
        done

        emake DESTDIR="${D}" install || die "make install failed"
        dodoc ANALYSES AUTHORS BUGS ChangeLog DEVICES NEWS \
                README Stuarts_Poly_Notes || die "failed to install 
documentation"

        insinto /usr/share/doc/${PF}
        doins "${DISTDIR}"/${PN}-${PV}-manual.pdf || die "failed to install 
manual"

        # We don't need ngmakeidx to be installed
        rm "${D}"/usr/bin/ngmakeidx
}

src_test () {
        # Bug 108405
        true
}




Reply via email to