xarthisius    14/11/25 15:26:17

  Modified:             ChangeLog
  Added:                hdf5-1.8.14.ebuild
  Removed:              hdf5-1.8.12.ebuild hdf5-1.8.11.ebuild
  Log:
  Version bump, drop old
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0x5D21B852895192F9)

Revision  Changes    Path
1.119                sci-libs/hdf5/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/hdf5/ChangeLog?rev=1.119&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/hdf5/ChangeLog?rev=1.119&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/hdf5/ChangeLog?r1=1.118&r2=1.119

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v
retrieving revision 1.118
retrieving revision 1.119
diff -u -r1.118 -r1.119
--- ChangeLog   4 Jun 2014 16:05:55 -0000       1.118
+++ ChangeLog   25 Nov 2014 15:26:17 -0000      1.119
@@ -1,6 +1,13 @@
 # ChangeLog for sci-libs/hdf5
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.118 2014/06/04 
16:05:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.119 2014/11/25 
15:26:17 xarthisius Exp $
+
+*hdf5-1.8.14 (25 Nov 2014)
+
+  25 Nov 2014; Kacper Kowalik <xarthis...@gentoo.org>
+  +files/hdf5-1.8.14-implicits.patch, +hdf5-1.8.14.ebuild,
+  -files/hdf5-1.8.11-implicits.patch, -hdf5-1.8.11.ebuild, -hdf5-1.8.12.ebuild:
+  Version bump, drop old
 
 *hdf5-1.8.13 (04 Jun 2014)
 



1.1                  sci-libs/hdf5/hdf5-1.8.14.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/hdf5/hdf5-1.8.14.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/hdf5/hdf5-1.8.14.ebuild?rev=1.1&content-type=text/plain

Index: hdf5-1.8.14.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.14.ebuild,v 1.1 
2014/11/25 15:26:17 xarthisius Exp $

EAPI=5

FORTRAN_NEEDED=fortran
AUTOTOOLS_AUTORECONF=1

inherit autotools-utils eutils fortran-2 flag-o-matic toolchain-funcs multilib

MY_P=${PN}-${PV/_p/-patch}

DESCRIPTION="General purpose library and file format for storing scientific 
data"
HOMEPAGE="http://www.hdfgroup.org/HDF5/";
SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MY_P}/src/${MY_P}.tar.bz2";

LICENSE="NCSA-HDF"
SLOT="0/${PV%%_p*}"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux"
IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"

REQUIRED_USE="
        cxx? ( !mpi ) mpi? ( !cxx )
        threads? ( !cxx !mpi !fortran )
        fortran2003? ( fortran )"

RDEPEND="
        mpi? ( virtual/mpi[romio] )
        szip? ( >=sci-libs/szip-2.1:0= )
        zlib? ( sys-libs/zlib:0= )"

DEPEND="${RDEPEND}
        sys-devel/libtool:2
        >=sys-devel/autoconf-2.69"

S="${WORKDIR}/${MY_P}"

PATCHES=(
        "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
        "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
        "${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
        "${FILESDIR}"/${PN}-1.8.14-implicits.patch
)

pkg_setup() {
        tc-export CXX CC AR # workaround for bug 285148
        if use fortran; then
                use fortran2003 && FORTRAN_STANDARD=2003
                fortran-2_pkg_setup
        fi
        if use mpi; then
                if has_version 'sci-libs/hdf5[-mpi]'; then
                        ewarn "Installing hdf5 with mpi enabled with a previous 
hdf5 with mpi disabled may fail."
                        ewarn "Try to uninstall the current hdf5 prior to 
enabling mpi support."
                fi
                export CC=mpicc
                use fortran && export FC=mpif90
        elif has_version 'sci-libs/hdf5[mpi]'; then
                ewarn "Installing hdf5 with mpi disabled while having hdf5 
installed with mpi enabled may fail."
                ewarn "Try to uninstall the current hdf5 prior to disabling mpi 
support."
        fi
}

src_prepare() {
        # respect gentoo examples directory
        sed \
                -e "s:hdf5_examples:doc/${PF}/examples:g" \
                -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || 
die
        sed \
                -e '/docdir/d' \
                -i config/commence.am || die
        if ! use examples; then
                sed -e '/^install:/ s/install-examples//' \
                        -i Makefile.am || die #409091
        fi
        # enable shared libs by default for h5cc config utility
        sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in || die
        # bug #419677
        use prefix && \
                append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir) \
                -Wl,-rpath,"${EPREFIX}"/$(get_libdir)
        autotools-utils_src_prepare
}

src_configure() {
        local myeconfargs=(
                --enable-production
                --docdir="${EPREFIX}"/usr/share/doc/${PF}
                --enable-deprecated-symbols
                $(use_enable prefix sharedlib-rpath)
                $(use_enable debug debug all)
                $(use_enable debug codestack)
                $(use_enable cxx)
                $(use_enable fortran)
                $(use_enable fortran2003)
                $(use_enable mpi parallel)
                $(use_enable threads threadsafe)
                $(use_with szip szlib)
                $(use_with threads pthread)
                $(use_with zlib)
        )
        autotools-utils_src_configure
}




Reply via email to