xarthisius    15/01/14 13:05:39

  Modified:             ChangeLog
  Added:                yt-3.1.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
0x5D21B852895192F9)

Revision  Changes    Path
1.5                  sci-visualization/yt/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-visualization/yt/ChangeLog?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-visualization/yt/ChangeLog?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-visualization/yt/ChangeLog?r1=1.4&r2=1.5

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-visualization/yt/ChangeLog,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- ChangeLog   3 Oct 2014 21:22:36 -0000       1.4
+++ ChangeLog   14 Jan 2015 13:05:39 -0000      1.5
@@ -1,6 +1,11 @@
 # ChangeLog for sci-visualization/yt
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/yt/ChangeLog,v 1.4 
2014/10/03 21:22:36 xarthisius Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/yt/ChangeLog,v 1.5 
2015/01/14 13:05:39 xarthisius Exp $
+
+*yt-3.1 (14 Jan 2015)
+
+  14 Jan 2015; Kacper Kowalik <xarthis...@gentoo.org> +yt-3.1.ebuild:
+  Version bump
 
   03 Oct 2014; Kacper Kowalik <xarthis...@gentoo.org> -yt-3.0.ebuild:
   Drop old



1.1                  sci-visualization/yt/yt-3.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-visualization/yt/yt-3.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-visualization/yt/yt-3.1.ebuild?rev=1.1&content-type=text/plain

Index: yt-3.1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-visualization/yt/yt-3.1.ebuild,v 1.1 
2015/01/14 13:05:39 xarthisius Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 flag-o-matic

DESCRIPTION="Astrophysical Simulation Analysis and Vizualization package"
HOMEPAGE="http://yt-project.org/";
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

CDEPEND="media-libs/freetype:2
        media-libs/libpng:0=
        sci-libs/hdf5:="
RDEPEND="${CDEPEND}
        dev-python/ipython[notebook,${PYTHON_USEDEP}]
        dev-python/pyx[${PYTHON_USEDEP}]
        dev-python/numpy[${PYTHON_USEDEP}]
        dev-python/h5py[${PYTHON_USEDEP}]
        dev-python/matplotlib[${PYTHON_USEDEP}]
        dev-python/sympy[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}
        >=dev-python/cython-0.19[${PYTHON_USEDEP}]
        >=dev-python/setuptools-0.7[${PYTHON_USEDEP}]
        test? ( ${RDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
        )"

python_prepare_all() {
        append-flags -fno-strict-aliasing
        sed -i yt/utilities/setup.py \
                -e "s:/usr:${EPREFIX}/usr:g" || die
        distutils-r1_python_prepare_all
}

python_test() {
        pushd "${BUILD_DIR}"/lib > /dev/null
        nosetests -sv || die "Tests fail with ${EPYTHON} ${PWD}"
        popd > /dev/null
}




Reply via email to