robbat2     14/06/27 08:02:37

  Added:                metadata.xml sas3ircu-5.ebuild Manifest ChangeLog
  Log:
  Initial commit, quick ebuild by myself.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.1                  sys-block/sas3ircu/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
<maintainer>
        <email>robb...@gentoo.org</email>
        <name>Robin H. Johnson</name>
</maintainer>
<use>
        <flag name="efi">Install EFI variant as well</flag>
</use>
</pkgmetadata>



1.1                  sys-block/sas3ircu/sas3ircu-5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/sas3ircu-5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/sas3ircu-5.ebuild?rev=1.1&content-type=text/plain

Index: sas3ircu-5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-block/sas3ircu/sas3ircu-5.ebuild,v 1.1 
2014/06/27 08:02:37 robbat2 Exp $

EAPI=5
inherit mount-boot

DESCRIPTION="LSI MPT-SAS3 controller management tool"
HOMEPAGE="http://www.lsi.com/support/Pages/download-results.aspx?component=Storage+Component&productfamily=Host+Bus+Adapters&productcode=0&assettype=Miscellaneous&productname=&keyword=SAS3IRCU";
LICENSE="LSI"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~ppc64 ~amd64-fbsd ~sparc-solaris 
~x64-solaris ~x86-solaris"
IUSE="efi doc"
RESTRICT="strip fetch mirror"
DEPEND=""
RDEPEND=""
QA_PREBUILT="opt/lsi/sas3ircu boot/efi/sas3ircu.efi"

MY_PN=SAS3IRCU
MY_P="${MY_PN}_P${PV}"

DISTFILE_BIN=${MY_P}.zip
DISTFILE_DOC=SAS3IRCU_UG.pdf

SRC_URI="
http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_12G_P${PV}/${DISTFILE_BIN}
doc? ( 
http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/${DISTFILE_DOC} )
"

LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN";

S="${WORKDIR}/${MY_P}"

pkg_nofetch() {
        elog "LSI has a mandatory click-through license on thier binaries."
        elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the 
Mangement Software section."
        elog "After downloading, move ${MY_P} into $DISTDIR"
        if use doc; then
                elog "Please also download 'SAS-3 Integrated RAID Configuration 
Utility User Guide' (${DISTFILE_DOC}) "
                elog "and also place it into $DISTDIR"
        fi
}

supportedcards() {
        elog "This binary supports should support ALL cards, including, but not"
        elog "limited to the following series:"
        elog ""
        elog "LSI SAS 3004"
        elog "LSI SAS 3008"
}

src_unpack() {
        unpack ${DISTFILE_BIN}
}

src_install() {
        exeinto /opt/lsi/
        use amd64 || use x86 && doexe sas3ircu_linux_x86_rel/sas3ircu
        use ppc64 && doexe sas3ircu_linux_x86_rel/sas3ircu
        use amd64-fbsd && doexe sas3ircu_freebsd_amd64_rel/sas3ircu
        use x86-fbsd && doexe sas3ircu_freebsd_i386_rel/sas3ircu
        use x64-solaris || use x86-solaris && doexe 
sas3ircu_solaris_x86_rel/sas3ircu
        use sparc-solaris && doexe sas3ircu_solaris_sparc_rel/sas3ircu
        if use efi; then
                exeinto /boot/efi/
                doexe sas3ircu_udk_uefi__x64_rel/sas3ircu.efi
        fi
        dodoc IRCU_MPT_GEN3_Phase5.0-06.00.00.00.pdf
        dodoc README_SAS3IRCU_P${PV}.txt
        use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
}



1.1                  sys-block/sas3ircu/Manifest

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/Manifest?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/Manifest?rev=1.1&content-type=text/plain

Index: Manifest
===================================================================
DIST SAS3IRCU_P5.zip 2655605 SHA256 
8a05cefa544063c61a5eddd8030e48375545a74e0480c735ad5ed76a99c04d28 SHA512 
233ec5ea8e32123652382a9072831fa35f496ce0755d8fd7113139f43e57837053e00eb7cae5f5273177510444f384fc6f08f7278232fe3d6601771ee214d9dc
 WHIRLPOOL 
643f935d5b1162e91df6af820bf4b70930974630a89cb772cb003e3e30b98a50ca7c9c9c63a309eab5fdf4bd759cc7c11bf4bf925c10edbdd6fa92a600f61d5f
DIST SAS3IRCU_UG.pdf 690245 SHA256 
0920984018e0873d65c0587c1ee436d3e72e6de3558730d61c33b53f4fad64b4 SHA512 
9e7a47f32bd19b708b1eedd63d7d7112a17c8da952b74630196dc2891cd14f758394dcc14b8be05666e6133a3bb10e77784bd62749fe4b1e2d7f7c71ae26fe2b
 WHIRLPOOL 
ef0f2dd0c5d807bd0f82ac56fcfec23d2c16b15a7567dc7a29d0c15b076d4b1f0aa160fe2d1c9cc679579eb41e51ab7b6639f1e35c3a5124ebf088536ba7d8df
EBUILD sas3ircu-5.ebuild 2343 SHA256 
31bd90bda3ed02b17d448d20e920d978f433a300242e256e0006aa02f55a0404 SHA512 
98ac2a442b93a881ab086852eaa3fa66df98d195107359fe3a0ef356fa3d080dfa4789a463885332a1eb958d9aed7e6439ee498009f3a7be0cb25ddcd139721f
 WHIRLPOOL 
b6bdb71b1b934a26943c4cf5d103e06fd1e2b35e7a9067ba5b71ed8266c875bdf17e9b540d09db644581ab0d5e2e7f94b1d2a97146cfe5bf8f03b724cf5e66be
MISC metadata.xml 298 SHA256 
5ed61cc11ae221bce652c7de67fd46d89d00e6dd9d4e7fe5ed98ad479f202192 SHA512 
7a44221d3d678e386d473d61ebdce13bbc8b406ea05074c69895c9b49164ae874cd2ea7024ac9388e5ff890626cbff1c53304f1b2fa54017d2997f19f7ca7fa1
 WHIRLPOOL 
9aab395c69c51eeb945fc7336b54577b76d75816af7113d9966b787834c4cd45d45a6cc68899b4a9385a214e78259640da36f4d3391446ebbfe9437d4ee04aeb



1.1                  sys-block/sas3ircu/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-block/sas3ircu/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for sys-block/sas3ircu
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sys-block/sas3ircu/ChangeLog,v 1.1 
2014/06/27 08:02:37 robbat2 Exp $

*sas3ircu-5 (27 Jun 2014)

  27 Jun 2014; Robin H. Johnson <robb...@gentoo.org> +metadata.xml,
  +sas3ircu-5.ebuild:
  Initial commit, quick ebuild by myself.




Reply via email to