monsieurp    15/07/28 08:48:42

  Modified:             ChangeLog
  Added:                mpe2-1.0.6_p1-r2.ebuild
  Log:
  EAPI 5 bump. Set up proper (optional) Java support and suppress QA warning. 
Fixes bug 298242.
  
  Signed-off-by: Patrice Clement <monsie...@gentoo.org>
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
93491BB8)

Revision  Changes    Path
1.12                 sys-cluster/mpe2/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/mpe2/ChangeLog?rev=1.12&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/mpe2/ChangeLog?rev=1.12&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/mpe2/ChangeLog?r1=1.11&r2=1.12

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/ChangeLog,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- ChangeLog   6 Jan 2013 18:48:37 -0000       1.11
+++ ChangeLog   28 Jul 2015 08:48:42 -0000      1.12
@@ -1,6 +1,12 @@
 # ChangeLog for sys-cluster/mpe2
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/ChangeLog,v 1.11 
2013/01/06 18:48:37 jsbronder Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/ChangeLog,v 1.12 
2015/07/28 08:48:42 monsieurp Exp $
+
+*mpe2-1.0.6_p1-r2 (28 Jul 2015)
+
+  28 Jul 2015; Patrice Clement <monsie...@gentoo.org> +mpe2-1.0.6_p1-r2.ebuild:
+  EAPI 5 bump. Set up proper (optional) Java support and suppress QA warning.
+  Fixes bug 298242.
 
   06 Jan 2013; Justin Bronder <jsbron...@gentoo.org> mpe2-1.0.6_p1.ebuild,
   mpe2-1.0.6_p1-r1.ebuild:



1.1                  sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild?rev=1.1&content-type=text/plain

Index: mpe2-1.0.6_p1-r2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild,v 
1.1 2015/07/28 08:48:42 monsieurp Exp $

EAPI=5

FORTRAN_NEEDED=fortran

inherit eutils fortran-2 java-pkg-opt-2 toolchain-funcs

MY_P=${P/_/}
DESCRIPTION="MPI development tools"
HOMEPAGE="http://www-unix.mcs.anl.gov/perfvis/download/index.htm";
SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${PN%2}/${MY_P}.tar.gz";

LICENSE="mpich2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="minimal fortran threads debug"

COMMON_DEPEND="!minimal? ( x11-libs/libXtst
                x11-libs/libXi )
        || ( sys-cluster/openmpi[fortran?,threads?]
                sys-cluster/mpich2[fortran?,threads?] )"

DEPEND="!minimal? ( >=virtual/jdk-1.6 )
        ${COMMON_DEPEND}"

RDEPEND="
!minimal? ( >=virtual/jre-1.6 )
        ${COMMON_DEPEND}"

S="${WORKDIR}"/${MY_P}
MPE_IMP=""

# README:
# This ebuild is created to handle building with both mpich2 and openmpi.
# However, without empi (in the science overlay), and some further
# conversion to use mpi.eclass, we can only handle one implementation
# at a time.  I still believe it's better to have the ebuild setup
# correctly in preperation.

pkg_setup() {
        fortran-2_pkg_setup
        local i

        if has_version sys-cluster/openmpi; then
                MPE_IMP=openmpi
        elif has_version sys-cluster/mpich2; then
                MPE_IMP=mpich2
        else
                die "Unknown MPI implementation"
        fi

        export JFLAGS="${JFLAGS} $(java-pkg_javac-args)"

        if [[ "${MPE_IMP}" == openmpi ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" 
]; then
                echo
                elog "Currently src_test fails on collchk with openmpi, hence"
                elog "testing is disabled by default.  If you would like to"
                elog "force testing, please add MPE_FORCE_OPENMPI_TEST=1"
                elog "to your environment."
                echo
        fi

        einfo "Building with support for: sys-cluster/${MPE_IMP}"

        if ! minimal; then
                java-pkg-opt-2_pkg_setup
        fi
}

src_prepare() {
        # Don't assume path contains ./
        sed -i 's,\($MPERUN\) $pgm,\1 ./$pgm,' sbin/mpetestexeclog.in
        epatch "${FILESDIR}"/slog2sdk-trace_rlog-makefile-fixes.patch
        epatch "${FILESDIR}"/slog2sdk-trace_sample-makefile-fixes.patch

        if ! minimal; then
                java-pkg-opt-2_src_prepare
        fi
}

src_configure() {
        local c="--with-mpicc=/usr/bin/mpicc"

        if use fortran; then
                c="${c} --with-mpif77=/usr/bin/mpif77"
        else
                c="${c} --disable-f77"
        fi

        if use minimal; then
                c="${c} --enable-slog2=no --disable-rlog --disable-sample"
        else
                c="${c} --with-java2=$(java-config --jdk-home) 
--enable-slog2=build"
        fi

        if [[ "${MPE_IMP}" == openmpi ]]; then
                c="${c} --disable-rlog --disable-sample"
        fi

        econf ${c} \
                --sysconfdir=/etc/${PN} \
                --datadir=/usr/share/${PN} \
                --with-htmldir=/usr/share/${PN} \
                --with-docdir=/usr/share/${PN} \
                --enable-collchk \
                --enable-wrappers \
                $(use_enable !minimal graphics) \
                $(use_enable threads threadlogging) \
                $(use_enable debug g)
}

src_test() {
        local rc

        cd "${S}"
        if [[ "${MPE_IMP}" == mpich2 ]]; then
                echo "MPD_SECRETWORD=junk" > "${T}"/mpd.conf
                chmod 600 "${T}"/mpd.conf
                export MPD_CONF_FILE="${T}/mpd.conf"
                "${ROOT}"usr/bin/mpd -d --pidfile="${T}"/mpd.pid
        elif [[ "${MPE_IMP}" == openmpi* ]] && [ -z 
"${MPE2_FORCE_OPENMPI_TEST}" ]; then
                elog
                elog "Skipping tests for openmpi"
                elog
                return 0
        fi

        # No parallel make:
        # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
        emake -j1 \
                CC="${S}"/bin/mpecc \
                FC="${S}"/bin/mpefc \
                MPERUN="${ROOT}/usr/bin/mpiexec -n 4" \
                CLOG2TOSLOG2="${S}/src/slog2sdk/bin/clog2TOslog2" \
                check;
                rc=${?}
        if [[ "${MPE_IMP}" == mpich2 ]]; then
                "${ROOT}"usr/bin/mpdallexit || kill $(<"${T}"/mpd.pid)
        fi

        return ${rc}
}

src_install() {
        # No parallel make:
        # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
        emake -j1 DESTDIR="${D}" install || die
        rm -f "${D}"/usr/sbin/mpeuninstall || die
}




Reply via email to