polynomial-c    14/10/05 18:36:45

  Modified:             ChangeLog
  Added:                make-4.1.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key 0x981CA6FC)

Revision  Changes    Path
1.120                sys-devel/make/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/make/ChangeLog?rev=1.120&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/make/ChangeLog?rev=1.120&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/make/ChangeLog?r1=1.119&r2=1.120

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v
retrieving revision 1.119
retrieving revision 1.120
diff -u -r1.119 -r1.120
--- ChangeLog   18 Jan 2014 03:11:00 -0000      1.119
+++ ChangeLog   5 Oct 2014 18:36:45 -0000       1.120
@@ -1,6 +1,11 @@
 # ChangeLog for sys-devel/make
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.119 2014/01/18 
03:11:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.120 2014/10/05 
18:36:45 polynomial-c Exp $
+
+*make-4.1 (05 Oct 2014)
+
+  05 Oct 2014; Lars Wendler <polynomia...@gentoo.org> +make-4.1.ebuild:
+  Version bump.
 
   18 Jan 2014; Mike Frysinger <vap...@gentoo.org> make-3.82-r4.ebuild,
   make-4.0-r1.ebuild:



1.1                  sys-devel/make/make-4.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/make/make-4.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/make/make-4.1.ebuild?rev=1.1&content-type=text/plain

Index: make-4.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-4.1.ebuild,v 1.1 
2014/10/05 18:36:45 polynomial-c Exp $

EAPI=4

inherit flag-o-matic eutils

DESCRIPTION="Standard tool to compile source trees"
HOMEPAGE="http://www.gnu.org/software/make/make.html";
SRC_URI="mirror://gnu//make/${P}.tar.bz2"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd 
~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux 
~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint 
~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="guile nls static"

CDEPEND="guile? ( >=dev-scheme/guile-1.8 )"
DEPEND="${CDEPEND}
        nls? ( sys-devel/gettext )"
RDEPEND="${CDEPEND}
        nls? ( virtual/libintl )"

src_prepare() {
        epatch \
                "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
}

src_configure() {
        use static && append-ldflags -static
        econf \
                --program-prefix=g \
                $(use_with guile) \
                $(use_enable nls)
}

src_install() {
        emake DESTDIR="${D}" install
        dodoc AUTHORS NEWS README*
        if [[ ${USERLAND} == "GNU" ]] ; then
                # we install everywhere as 'gmake' but on GNU systems,
                # symlink 'make' to 'gmake'
                dosym gmake /usr/bin/make
                dosym gmake.1 /usr/share/man/man1/make.1
        fi
}




Reply via email to