kumba       15/02/01 08:12:56

  Modified:             ChangeLog
  Added:                mips-sources-3.18.5.ebuild
  Removed:              mips-sources-3.18.3.ebuild
  Log:
  Update to 3.18.5, fix compile failure in IP27 RTC platform driver, update to 
linux-mips-git 20150130.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
D25D95E3)

Revision  Changes    Path
1.154                sys-kernel/mips-sources/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/mips-sources/ChangeLog?rev=1.154&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/mips-sources/ChangeLog?rev=1.154&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/mips-sources/ChangeLog?r1=1.153&r2=1.154

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/ChangeLog,v
retrieving revision 1.153
retrieving revision 1.154
diff -u -r1.153 -r1.154
--- ChangeLog   21 Jan 2015 02:31:16 -0000      1.153
+++ ChangeLog   1 Feb 2015 08:12:56 -0000       1.154
@@ -1,6 +1,13 @@
 # ChangeLog for sys-kernel/mips-sources
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/ChangeLog,v 1.153 
2015/01/21 02:31:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/ChangeLog,v 1.154 
2015/02/01 08:12:56 kumba Exp $
+
+*mips-sources-3.18.5 (01 Feb 2015)
+
+  01 Feb 2015; Joshua Kinard <ku...@gentoo.org> +mips-sources-3.18.5.ebuild,
+  -mips-sources-3.18.3.ebuild:
+  Update to 3.18.5, fix compile failure in IP27 RTC platform driver, update to
+  linux-mips-git 20150130.
 
   21 Jan 2015; Patrick Lauer <patr...@gentoo.org> metadata.xml:
   Remove unneded useflag description from metadata.xml



1.1                  sys-kernel/mips-sources/mips-sources-3.18.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.18.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.18.5.ebuild?rev=1.1&content-type=text/plain

Index: mips-sources-3.18.5.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.18.5.ebuild,v 
1.1 2015/02/01 08:12:56 kumba Exp $

# EAPI Version
EAPI="5"

# INCLUDED:
# 1) linux sources from kernel.org
# 2) linux-mips.org GIT snapshot diff
# 3) Generic Fixes
# 4) Patch for the IOC3 Metadriver (IP27, IP30)
# 5) Patch for IP30 Support
# 6) Experimental patches (if needed)

#//------------------------------------------------------------------------------

# Version Data
OKV=${PV/_/-}
GITDATE="20150130"                      # Date of diff between kernel.org and 
lmo GIT
GENPATCHREV="2"                         # Tarball revision for patches

# Directories
S="${WORKDIR}/linux-${OKV}-${GITDATE}"
MIPS_PATCHES="${WORKDIR}/mips-patches"

# Kernel-2 Vars
K_SECURITY_UNSUPPORTED="1"
K_NOUSENAME="0"
K_NOUSEPR="0"
K_USEPV="0"
ETYPE="sources"

# Inherit Eclasses
inherit kernel-2 eutils
detect_version

# Version Data
F_KV="${PVR}"
BASE_KV="$(get_version_component_range 1-2).0"
[[ "${EXTRAVERSION}" = -rc* ]] && KVE="${EXTRAVERSION}"

# Portage Vars
HOMEPAGE="http://www.linux-mips.org/ http://www.gentoo.org/";
SLOT="${OKV}"
KEYWORDS="-* ~mips"
IUSE="cobalt ip27 ip28 ip30 ip32r10k"
DEPEND=">=sys-devel/gcc-4.6.0"
RDEPEND=""

# Machine Support Control Variables
DO_IP22="test"                          # If "yes", enable IP22 support         
(SGI Indy, Indigo2 R4x00)
DO_IP27="yes"                           #                  IP27 support         
(SGI Origin)
DO_IP28="test"                          #                  IP28 support         
(SGI Indigo2 Impact R10000)
DO_IP30="yes"                           #                  IP30 support         
(SGI Octane)
DO_IP32="yes"                           #                  IP32 support         
(SGI O2, R5000/RM5200 Only)
DO_CBLT="test"                          #                  Cobalt Support       
(Cobalt Microsystems)

# Machine Stable Version Variables
SV_IP22=""                              # If set && DO_IP22 == "no", indicates 
last "good" IP22 version
SV_IP27=""                              #           DO_IP27 == "no",            
           IP27
SV_IP28=""                              #           DO_IP28 == "no",            
           IP28
SV_IP30=""                              #           DO_IP30 == "no",            
           IP30
SV_IP32=""                              #           DO_IP32 == "no",            
           IP32
SV_CBLT=""                              #           DO_CBLT == "no",            
           Cobalt

DESCRIPTION="Linux-Mips GIT sources for MIPS-based machines, dated ${GITDATE}"
SRC_URI="${KERNEL_URI}
         mirror://gentoo/mipsgit-${BASE_KV}${KVE}-${GITDATE}.diff.xz
         mirror://gentoo/${PN}-${BASE_KV}-patches-v${GENPATCHREV}.tar.xz"

UNIPATCH_STRICTORDER="1"
UNIPATCH_LIST="${DISTDIR}/mipsgit-${BASE_KV}${KVE}-${GITDATE}.diff.xz"

#//------------------------------------------------------------------------------

# Eblit Handling Functions
#
# They'll likely be superseded someday by better ideas, possibly elibs.

# eblit-core
# Usage: <function> [version]
# Main eblit engine
eblit-core() {
        local e v func=$1 ver=$2
        for v in ${ver:+-}${ver} -${PVR} -${PV} "" ; do
                e="${FILESDIR}/eblits/${func}${v}.eblit"
                if [[ -e ${e} ]] ; then
                        . "${e}"
                        [[ ${func} == pkg_* ]] && eval "${func}() { eblit-run 
${func} ${ver} ; }"
                        return 0
                fi
        done
        return 1
}

# eblit-include
# Usage: [--skip] <function> [version]
# Includes an "eblit" -- a chunk of common code among ebuilds in a given
# package so that its functions can be sourced and utilized within the
# ebuild.
eblit-include() {
        local skipable=false r=0
        [[ $1 == "--skip" ]] && skipable=true && shift
        [[ $1 == pkg_* ]] && skipable=true

        [[ -z $1 ]] && die "Usage: eblit-include <function> [version]"
        eblit-core $1 $2
        r="$?"
        ${skipable} && return 0
        [[ "$r" -gt "0" ]] && die "Could not locate requested eblit '$1' in 
${FILESDIR}/eblits/"
}

# eblit-run-maybe
# Usage: <function>
# Runs a function if it is defined in an eblit
eblit-run-maybe() {
        [[ $(type -t "$@") == "function" ]] && "$@"
}

# eblit-run
# Usage: <function> [version]
# Runs a function defined in an eblit
eblit-run() {
        eblit-include --skip common "${*:2}"
        eblit-include "$@"
        eblit-run-maybe eblit-$1-pre
        eblit-${PN}-$1
        eblit-run-maybe eblit-$1-post
}

# eblit-pkg
# Usage: <phase> [version]
# Runs the pkg_* functions AND evals them so they're included in the binpkgs
eblit-pkg() {
        [[ -z $1 ]] && die "Usage: eblit-pkg <phase> [version]"
        eblit-core pkg_$1 $2
}

#//------------------------------------------------------------------------------

load_eblit_funcs() {
        # This is a sanity check to avoid QA issues.  It prevents
        # eblits from being referenced during metadata operations.
        [ -n "${MIPS_SOURCES_EBLITS_LOADED}" ] && return

        # All are in ${FILESDIR}/eblits
        # If a message for a given machine needs to change,
        # then we create a new eblit and increment the
        # version and reference it here.
        eblit-include err_disabled_mach v1
        eblit-include err_only_one_mach_allowed v1
        eblit-include show_ip22_info v3
        eblit-include show_ip27_info v2
        eblit-include show_ip28_info v1
        eblit-include show_ip30_info v3
        eblit-include show_ip32_info v3
        eblit-include show_cobalt_info v1

        # This makes sure pkg_setup & pkg_postinst gets into any binpkg.
        # Neccessary because we can't guarantee FILESDIR is around for binpkgs.
        eblit-pkg setup v1
        eblit-pkg postinst v1

        # Eblit load complete
        MIPS_SOURCES_EBLITS_LOADED=1
}

pkg_setup() {
        load_eblit_funcs
        pkg_setup
}

src_unpack() { eblit-run src_unpack v4 ; }

#//------------------------------------------------------------------------------




Reply via email to