mgorny      15/01/16 19:10:37

  Modified:             ChangeLog
  Added:                pshs-0.2.6.ebuild
  Log:
  Version bump. Adds path prefixing support to improve security a bit.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.14                 www-servers/pshs/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-servers/pshs/ChangeLog?rev=1.14&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-servers/pshs/ChangeLog?rev=1.14&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-servers/pshs/ChangeLog?r1=1.13&r2=1.14

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v
retrieving revision 1.13
retrieving revision 1.14
diff -u -r1.13 -r1.14
--- ChangeLog   25 Dec 2014 19:03:24 -0000      1.13
+++ ChangeLog   16 Jan 2015 19:10:37 -0000      1.14
@@ -1,6 +1,11 @@
 # ChangeLog for www-servers/pshs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.13 
2014/12/25 19:03:24 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.14 
2015/01/16 19:10:37 mgorny Exp $
+
+*pshs-0.2.6 (16 Jan 2015)
+
+  16 Jan 2015; Michał Górny <mgo...@gentoo.org> +pshs-0.2.6.ebuild:
+  Version bump. Adds path prefixing support to improve security a bit.
 
 *pshs-0.2.5 (25 Dec 2014)
 



1.1                  www-servers/pshs/pshs-0.2.6.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-servers/pshs/pshs-0.2.6.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-servers/pshs/pshs-0.2.6.ebuild?rev=1.1&content-type=text/plain

Index: pshs-0.2.6.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-0.2.6.ebuild,v 1.1 
2015/01/16 19:10:37 mgorny Exp $

EAPI=5

inherit autotools-utils

DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
HOMEPAGE="https://bitbucket.org/mgorny/pshs/";
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2";

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+magic +netlink qrcode ssl upnp"

RDEPEND=">=dev-libs/libevent-2:0=
        magic? ( sys-apps/file:0= )
        qrcode? ( media-gfx/qrencode:0= )
        ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
                dev-libs/openssl:0= )
        upnp? ( net-libs/miniupnpc:0= )"
DEPEND="${RDEPEND}
        netlink? ( sys-apps/iproute2
                >=sys-kernel/linux-headers-2.6.27 )"
# libnetlink is static only ATM

src_configure() {
        myeconfargs=(
                $(use_enable magic libmagic)
                $(use_enable netlink)
                $(use_enable qrcode qrencode)
                $(use_enable ssl)
                $(use_enable upnp)
        )

        autotools-utils_src_configure
}




Reply via email to