pinkbyte    15/01/14 05:35:54

  Modified:             ChangeLog
  Added:                magick-rotation-1.6.2-r1.ebuild
  Removed:              magick-rotation-1.6.2.ebuild
  Log:
  Revision bump: migrate to python-single-r1 eclass, wrt bug #531620, thanks to 
Aaron Bauman <bauman.aaron AT gmail.com>. Add missing dependencies on 
dev-python/pygtk and x11-libs/libXrandr. Require python interpreter with XML 
support. Add support for user patches via epatch_user. Use udev eclass to 
install rules in proper location. Drop old revision
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
0x1F357D42)

Revision  Changes    Path
1.4                  x11-misc/magick-rotation/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/magick-rotation/ChangeLog?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/magick-rotation/ChangeLog?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/magick-rotation/ChangeLog?r1=1.3&r2=1.4

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-misc/magick-rotation/ChangeLog,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- ChangeLog   24 Jan 2013 09:07:22 -0000      1.3
+++ ChangeLog   14 Jan 2015 05:35:54 -0000      1.4
@@ -1,6 +1,16 @@
 # ChangeLog for x11-misc/magick-rotation
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/magick-rotation/ChangeLog,v 1.3 
2013/01/24 09:07:22 pinkbyte Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/magick-rotation/ChangeLog,v 1.4 
2015/01/14 05:35:54 pinkbyte Exp $
+
+*magick-rotation-1.6.2-r1 (14 Jan 2015)
+
+  14 Jan 2015; Sergey Popov <pinkb...@gentoo.org>
+  -magick-rotation-1.6.2.ebuild, +magick-rotation-1.6.2-r1.ebuild:
+  Revision bump: migrate to python-single-r1 eclass, wrt bug #531620, thanks to
+  Aaron Bauman <bauman.aaron AT gmail.com>. Add missing dependencies on
+  dev-python/pygtk and x11-libs/libXrandr. Require python interpreter with XML
+  support. Add support for user patches via epatch_user. Use udev eclass to
+  install rules in proper location. Drop old revision
 
   24 Jan 2013; Sergey Popov <pinkb...@gentoo.org> magick-rotation-1.6.2.ebuild:
   Restrict tests, cause there are no tests in package and default src_test



1.1                  x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild?rev=1.1&content-type=text/plain

Index: magick-rotation-1.6.2-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/x11-misc/magick-rotation/magick-rotation-1.6.2-r1.ebuild,v
 1.1 2015/01/14 05:35:54 pinkbyte Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="xml"
inherit eutils python-single-r1 toolchain-funcs udev user versionator

MY_PV=$(get_version_component_range 1-2)

DESCRIPTION="Application that rotates tablet pc's screen automatically, 
depending on orientation"
HOMEPAGE="https://launchpad.net/magick-rotation";
SRC_URI="http://launchpad.net/magick-rotation/trunk/${MY_PV}/+download/${P}.tar.bz2";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"

DEPEND="${PYTHON_DEPS}
        x11-libs/libX11
        x11-libs/libXrandr"

RDEPEND="${DEPEND}
        dev-python/pygobject[${PYTHON_USEDEP}]
        dev-python/pygtk:2[${PYTHON_USEDEP}]
        dev-python/py-notify[${PYTHON_USEDEP}]
        x11-apps/xinput"

# there are no tests in package, default 'make check' does wrong things, bug 
#453672
RESTRICT="test"

pkg_setup() {
        python-single-r1_pkg_setup
        enewgroup magick
}

src_prepare() {
        # Remove unneeded files
        rm -r apt_* installer_gtk.py MAGICK-INSTALL gset_addkeyval.py 
MagickIcons/MagickSplash.png MagickUninstall || die 'removing unneeded files 
failed'

        # Fix Python shebangs
        python_fix_shebang "${S}"

        epatch_user
}

src_compile() {
        my_compile() {
                echo $(tc-getCC) $*
                $(tc-getCC) $* || die 'compilation failed'
        }

        local suffix=
        if use amd64; then
                suffix=64
        else
                suffix=32
        fi
        my_compile "${CFLAGS} ${LDFLAGS} check.c -lX11 -lXrandr -o 
checkmagick${suffix}"
}

src_install() {
        #TODO: add installation of GNOME Shell 3.2 extension
        dobin   checkmagick*

        udev_dorules 62-magick.rules

        insinto /usr/share/${PN}
        doins   *.py

        insinto /usr/share/${PN}/MagickIcons
        doins   MagickIcons/*.png

        exeinto /usr/share/${PN}
        doexe   magick-rotation
        doexe   xrotate.py

        dodoc *.txt ChangeLog

        make_desktop_entry /usr/share/${PN}/${PN} "Magick Rotation" 
/usr/share/${PN}/MagickIcons/magick-rotation-enabled.png "System;Utility;"
}

pkg_postinst() {
        optfeature() {
                elog "  [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] 
${1} (${2})"
        }

        elog
        elog "In order to use Magick Rotation with an on-screen keyboard and 
handwriting,"
        elog "the following additional package may also be installed for use at 
run-time:"
        elog
        optfeature 'media-gfx/cellwriter' "Magick Rotation's default onscreen 
keyboard"
        elog

        ewarn "in order to use Magick Rotation you have to be in the 'magick' 
group."
        ewarn "Just run 'gpasswd -a <USER> magick', then have <USER> re-login."
}




Reply via email to