pinkbyte    14/11/05 09:45:49

  Modified:             ChangeLog
  Added:                xcape-1.1.ebuild
  Log:
  Version bump, wrt bug #527860. Fix manpage installation path, use correct 
pkg-config, add support for Gentoo Prefix
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0x1F357D42)

Revision  Changes    Path
1.2                  x11-misc/xcape/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/xcape/ChangeLog?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/xcape/ChangeLog?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/xcape/ChangeLog?r1=1.1&r2=1.2

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-misc/xcape/ChangeLog,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- ChangeLog   10 Mar 2013 08:50:29 -0000      1.1
+++ ChangeLog   5 Nov 2014 09:45:49 -0000       1.2
@@ -1,6 +1,12 @@
 # ChangeLog for x11-misc/xcape
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/ChangeLog,v 1.1 2013/03/10 
08:50:29 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/ChangeLog,v 1.2 2014/11/05 
09:45:49 pinkbyte Exp $
+
+*xcape-1.1 (05 Nov 2014)
+
+  05 Nov 2014; Sergey Popov <pinkb...@gentoo.org> +xcape-1.1.ebuild:
+  Version bump, wrt bug #527860. Fix manpage installation path, use correct
+  pkg-config, add support for Gentoo Prefix
 
 *xcape-1.0 (10 Mar 2013)
 



1.1                  x11-misc/xcape/xcape-1.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/xcape/xcape-1.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/xcape/xcape-1.1.ebuild?rev=1.1&content-type=text/plain

Index: xcape-1.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/xcape-1.1.ebuild,v 1.1 
2014/11/05 09:45:49 pinkbyte Exp $

EAPI="5"

inherit eutils toolchain-funcs

DESCRIPTION="Utility to make modifier keys send custom key events when pressed 
on their own"
HOMEPAGE="https://github.com/alols/xcape";
SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"

RDEPEND="x11-libs/libX11
        x11-libs/libXtst"
DEPEND="${RDEPEND}
        virtual/pkgconfig"

src_prepare() {
        # Fix path to man and to pkg-config
        sed -i \
                -e "/MANDIR/s:local:share:" \
                -e "s/pkg-config/$(tc-getPKG_CONFIG)/" \
                Makefile || die

        epatch_user
}

src_compile() {
        emake CC="$(tc-getCC)"
}

src_install() {
        emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}




Reply via email to