lordvan     14/05/08 11:25:13

  Modified:             ChangeLog
  Added:                clamav-0.98.3.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )

Revision  Changes    Path
1.476                app-antivirus/clamav/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-antivirus/clamav/ChangeLog?rev=1.476&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-antivirus/clamav/ChangeLog?rev=1.476&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-antivirus/clamav/ChangeLog?r1=1.475&r2=1.476

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v
retrieving revision 1.475
retrieving revision 1.476
diff -u -r1.475 -r1.476
--- ChangeLog   4 May 2014 08:30:38 -0000       1.475
+++ ChangeLog   8 May 2014 11:25:13 -0000       1.476
@@ -1,6 +1,11 @@
 # ChangeLog for app-antivirus/clamav
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.475 
2014/05/04 08:30:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.476 
2014/05/08 11:25:13 lordvan Exp $
+
+*clamav-0.98.3 (08 May 2014)
+
+  08 May 2014; Thomas Raschbacher <lord...@gentoo.org> +clamav-0.98.3.ebuild:
+  version bump. This now *requires* dev-libs/openssl
 
   04 May 2014; Agostino Sarubbo <a...@gentoo.org> clamav-0.98.1.ebuild:
   Stable for x86, wrt bug #506588



1.1                  app-antivirus/clamav/clamav-0.98.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-antivirus/clamav/clamav-0.98.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-antivirus/clamav/clamav-0.98.3.ebuild?rev=1.1&content-type=text/plain

Index: clamav-0.98.3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.98.3.ebuild,v 
1.1 2014/05/08 11:25:13 lordvan Exp $

EAPI=5

inherit eutils flag-o-matic user systemd

DESCRIPTION="Clam Anti-Virus Scanner"
HOMEPAGE="http://www.clamav.net/";
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="bzip2 clamdtop iconv ipv6 milter selinux static-libs uclibc"

CDEPEND="bzip2? ( app-arch/bzip2 )
        clamdtop? ( sys-libs/ncurses )
        iconv? ( virtual/libiconv )
        milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
        dev-libs/libtommath
        >=sys-libs/zlib-1.2.2
        dev-libs/openssl
        sys-devel/libtool"
# openssl is now *required* see this link as to why
# 
http://www.clamav.net/lang/en/2014/02/22/introducing-openssl-as-a-dependency-to-clamav/
DEPEND="${CDEPEND}
        virtual/pkgconfig"
RDEPEND="${CDEPEND}
        selinux? ( sec-policy/selinux-clamav )"

DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )

pkg_setup() {
        enewgroup clamav
        enewuser clamav -1 -1 /dev/null clamav
}

src_prepare() {
        use ppc64 && append-flags -mminimal-toc
        use uclibc && export ac_cv_type_error_t=yes
}

src_configure() {
        econf \
                --disable-experimental \
                --disable-fanotify \
                --enable-id-check \
                --with-dbdir="${EPREFIX}"/var/lib/clamav \
                --with-system-tommath \
                --with-zlib="${EPREFIX}"/usr \
                $(use_enable bzip2) \
                $(use_enable clamdtop) \
                $(use_enable ipv6) \
                $(use_enable milter) \
                $(use_enable static-libs static) \
                $(use_with iconv)
}

src_install() {
        default

        rm -rf "${ED}"/var/lib/clamav
        newinitd "${FILESDIR}"/clamd.initd-r6 clamd
        newconfd "${FILESDIR}"/clamd.conf-r1 clamd

        systemd_dotmpfilesd "${FILESDIR}/tmpfiles.d/clamav.conf"
        systemd_newunit "${FILESDIR}/clamd_at.service" "clamd@.service"
        systemd_dounit "${FILESDIR}/clamd.service"
        systemd_dounit "${FILESDIR}/freshclamd.service"

        keepdir /var/lib/clamav
        fowners clamav:clamav /var/lib/clamav
        keepdir /var/log/clamav
        fowners clamav:clamav /var/log/clamav

        dodir /etc/logrotate.d
        insinto /etc/logrotate.d
        newins "${FILESDIR}"/clamav.logrotate clamav

        # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
        sed -i -e "s:^\(Example\):\# \1:" \
                -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.pid:" 
\
                -e "s:.*\(LocalSocket\) .*:\1 
${EPREFIX}/var/run/clamav/clamd.sock:" \
                -e "s:.*\(User\) .*:\1 clamav:" \
                -e "s:^\#\(LogFile\) .*:\1 
${EPREFIX}/var/log/clamav/clamd.log:" \
                -e "s:^\#\(LogTime\).*:\1 yes:" \
                -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
                "${ED}"/etc/clamd.conf.sample || die
        sed -i -e "s:^\(Example\):\# \1:" \
                -e "s:.*\(PidFile\) .*:\1 
${EPREFIX}/var/run/clamav/freshclam.pid:" \
                -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
                -e "s:^\#\(UpdateLogFile\) .*:\1 
${EPREFIX}/var/log/clamav/freshclam.log:" \
                -e "s:^\#\(NotifyClamd\).*:\1 ${EPREFIX}/etc/clamd.conf:" \
                -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
                -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
                "${ED}"/etc/freshclam.conf.sample || die

        if use milter ; then
                # MilterSocket one to include ' /' because there is a 2nd line 
for
                # inet: which we want to leave
                dodoc "${FILESDIR}"/clamav-milter.README.gentoo
                sed -i -e "s:^\(Example\):\# \1:" \
                        -e "s:.*\(PidFile\) .*:\1 
${EPREFIX}/var/run/clamav/clamav-milter.pid:" \
                        -e "s+^\#\(ClamdSocket\) .*+\1 
unix:${EPREFIX}/var/run/clamav/clamd.sock+" \
                        -e "s:.*\(User\) .*:\1 clamav:" \
                        -e "s+^\#\(MilterSocket\) /.*+\1 
unix:${EPREFIX}/var/run/clamav/clamav-milter.sock+" \
                        -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
                        -e "s:^\#\(LogFile\) .*:\1 
${EPREFIX}/var/log/clamav/clamav-milter.log:" \
                        "${ED}"/etc/clamav-milter.conf.sample || die
                cat >> "${ED}"/etc/conf.d/clamd <<-EOF
                        MILTER_NICELEVEL=19
                        START_MILTER=no
                EOF

                systemd_newunit "${FILESDIR}/clamav-milter.service-r1" 
clamav-milter.service
        fi

        for i in clamd freshclam clamav-milter
        do
                [[ -f "${D}"/etc/"${i}".conf.sample ]] && mv 
"${D}"/etc/"${i}".conf{.sample,}
        done

        prune_libtool_files --all
}

pkg_postinst() {
        if use milter ; then
                elog "For simple instructions how to setup the clamav-milter 
read the"
                elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
        fi
        if test -z $(find "${ROOT}"var/lib/clamav -maxdepth 1 -name 'main.c*' 
-print -quit) ; then
                ewarn "You must run freshclam manually to populate the virus 
database files"
                ewarn "before starting clamav for the first time.\n"
        fi
}




Reply via email to