tomka       14/07/21 11:39:22

  Modified:             ChangeLog
  Added:                anki-2.0.28.ebuild
  Removed:              anki-2.0.20.ebuild anki-2.0.26.ebuild
  Log:
  bump to 2.0.28, remove old
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.82                 app-misc/anki/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/ChangeLog?rev=1.82&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/ChangeLog?rev=1.82&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/ChangeLog?r1=1.81&r2=1.82

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v
retrieving revision 1.81
retrieving revision 1.82
diff -u -r1.81 -r1.82
--- ChangeLog   24 May 2014 10:12:18 -0000      1.81
+++ ChangeLog   21 Jul 2014 11:39:22 -0000      1.82
@@ -1,6 +1,12 @@
 # ChangeLog for app-misc/anki
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.81 2014/05/24 
10:12:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.82 2014/07/21 
11:39:22 tomka Exp $
+
+*anki-2.0.28 (21 Jul 2014)
+
+  21 Jul 2014; Thomas Kahle <to...@gentoo.org> +anki-2.0.28.ebuild,
+  -anki-2.0.20.ebuild, -anki-2.0.26.ebuild:
+  bump to 2.0.28, remove old
 
   24 May 2014; Agostino Sarubbo <a...@gentoo.org> anki-2.0.24.ebuild:
   Stable for x86, wrt bug #507520



1.1                  app-misc/anki/anki-2.0.28.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/anki-2.0.28.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/anki-2.0.28.ebuild?rev=1.1&content-type=text/plain

Index: anki-2.0.28.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.28.ebuild,v 1.1 
2014/07/21 11:39:22 tomka Exp $

EAPI=5

PYTHON_COMPAT=( python2_6 python2_7 )
PYTHON_REQ_USE="sqlite"

inherit eutils python-single-r1

DESCRIPTION="A spaced-repetition memory training program (flash cards)"
HOMEPAGE="http://ichi2.net/anki/";
SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="latex +recording +sound"

RDEPEND="${PYTHON_DEPS}
         dev-python/PyQt4[X,svg,webkit]
         >=dev-python/httplib2-0.7.4
         dev-python/beautifulsoup:python-2
         dev-python/send2trash
         recording? ( media-sound/lame
                                  >=dev-python/pyaudio-0.2.4 )
         sound? ( media-video/mplayer )
         latex? ( app-text/texlive
                          app-text/dvipng )"
DEPEND=""

pkg_setup(){
        python-single-r1_pkg_setup
}

src_prepare() {
        rm -r thirdparty || die
        sed -i -e "s/updates=True/updates=False/" \
                aqt/profiles.py || die
}

# Nothing to configure or compile
src_configure() {
        true;
}

src_compile() {
        true;
}

src_install() {
        doicon ${PN}.png
        domenu ${PN}.desktop
        doman ${PN}.1

        dodoc README README.development
        python_domodule aqt anki
        python_doscript anki/anki
}

pkg_preinst() {
        if has_version "<app-misc/anki-2" ; then
                elog "Anki 2 is a rewrite of Anki with many new features and"
                elog "a new database format.  On the first run your decks are"
                elog "converted to the new format and a backup of your Anki-1"
                elog "decks is created.  Please read the following:"
                elog "http://ankisrs.net/anki2.html";
        fi
}




Reply via email to