patrick     14/05/07 03:59:38

  Modified:             ChangeLog
  Added:                hyperdex-9999.ebuild
  Log:
  Add -9999 ebuild
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.19                 dev-db/hyperdex/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/hyperdex/ChangeLog?rev=1.19&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/hyperdex/ChangeLog?rev=1.19&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/hyperdex/ChangeLog?r1=1.18&r2=1.19

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v
retrieving revision 1.18
retrieving revision 1.19
diff -u -r1.18 -r1.19
--- ChangeLog   7 May 2014 03:38:14 -0000       1.18
+++ ChangeLog   7 May 2014 03:59:38 -0000       1.19
@@ -1,6 +1,11 @@
 # ChangeLog for dev-db/hyperdex
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.18 2014/05/07 
03:38:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.19 2014/05/07 
03:59:38 patrick Exp $
+
+*hyperdex-9999 (07 May 2014)
+
+  07 May 2014; Patrick Lauer <patr...@gentoo.org> +hyperdex-9999.ebuild:
+  Add -9999 ebuild
 
 *hyperdex-1.2.0-r1 (07 May 2014)
 



1.1                  dev-db/hyperdex/hyperdex-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/hyperdex/hyperdex-9999.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/hyperdex/hyperdex-9999.ebuild?rev=1.1&content-type=text/plain

Index: hyperdex-9999.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-9999.ebuild,v 1.1 
2014/05/07 03:59:38 patrick Exp $
EAPI=5

PYTHON_COMPAT=( python2_7)
inherit eutils python-r1 autotools git-r3

DESCRIPTION="A searchable distributed Key-Value Store"

HOMEPAGE="http://hyperdex.org";
LICENSE="BSD"
SLOT="0"
KEYWORDS=""

EGIT_REPO_URI="https://github.com/rescrv/HyperDex.git";

SRC_URI="http://dev.gentooexperimental.org/~patrick/autotools-java.tar";

IUSE="+python"
# need to add ruby and java useflags too

DEPEND="dev-cpp/glog
        dev-cpp/sparsehash
        dev-libs/cityhash
        dev-libs/libpo6
        dev-libs/libe
        dev-libs/busybee
        dev-libs/popt
        dev-libs/replicant
        dev-libs/json-c"
RDEPEND="${DEPEND}"

src_prepare() {
        cd m4; tar xf "${DISTDIR}/autotools-java.tar"
        cd ..
        sed -i -e 's~json/json.h~json-c/json.h~' configure.ac 
common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
        eautoreconf
}
src_configure() {
        econf --disable-static \
                $(use_enable python python-bindings)
}

src_install() {
        emake DESTDIR="${D}" install || die "Failed to install"
        newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to 
install init script"
        newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to 
install config file"
        find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
}




Reply via email to