titanofold    15/07/15 11:24:52

  Modified:             ChangeLog
  Added:                pgadmin3-1.20.0-r2.ebuild
  Log:
  Fix bug 554872 with patch from upstream. Also, added epatch_user line.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x5713AA03D1BBFDA0)

Revision  Changes    Path
1.108                dev-db/pgadmin3/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgadmin3/ChangeLog?rev=1.108&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgadmin3/ChangeLog?rev=1.108&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgadmin3/ChangeLog?r1=1.107&r2=1.108

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v
retrieving revision 1.107
retrieving revision 1.108
diff -u -r1.107 -r1.108
--- ChangeLog   11 Jul 2015 19:13:27 -0000      1.107
+++ ChangeLog   15 Jul 2015 11:24:52 -0000      1.108
@@ -1,6 +1,12 @@
 # ChangeLog for dev-db/pgadmin3
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.107 
2015/07/11 19:13:27 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.108 
2015/07/15 11:24:52 titanofold Exp $
+
+*pgadmin3-1.20.0-r2 (15 Jul 2015)
+
+  15 Jul 2015; Aaron W. Swenson <titanof...@gentoo.org>
+  +pgadmin3-1.20.0-r2.ebuild, +files/pgadmin3-menu-assert.patch:
+  Fix bug 554872 with patch from upstream. Also, added epatch_user line.
 
   11 Jul 2015; Mikle Kolyada <zlog...@gentoo.org> pgadmin3-1.20.0-r1.ebuild:
   x86 stable wrt bug #551322



1.1                  dev-db/pgadmin3/pgadmin3-1.20.0-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.20.0-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.20.0-r2.ebuild?rev=1.1&content-type=text/plain

Index: pgadmin3-1.20.0-r2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.20.0-r2.ebuild,v 
1.1 2015/07/15 11:24:52 titanofold Exp $

EAPI="5"

inherit eutils multilib versionator wxwidgets

DESCRIPTION="wxWidgets GUI for PostgreSQL"
HOMEPAGE="http://www.pgadmin.org/";
SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"

LICENSE="POSTGRESQL"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
SLOT="0"
IUSE="debug +databasedesigner"

DEPEND="x11-libs/wxGTK:=[X,debug=]
        >=dev-db/postgresql-8.4.0:=
        >=dev-libs/libxml2-2.6.18
        >=dev-libs/libxslt-1.1"
RDEPEND="${DEPEND}"

pkg_setup() {
        local pgslot=$(postgresql-config show)

        if [[ ${pgslot//.} < 84 ]] ; then
                eerror "PostgreSQL slot must be set to 8.4 or higher."
                eerror "    postgresql-config set 8.4"
                die "PostgreSQL slot is not set to 8.4 or higher."
        fi
}

src_prepare() {
        epatch "${FILESDIR}/pgadmin3-desktop.patch" \
                   "${FILESDIR}/pgadmin3-menu-assert.patch"

        epatch_user
}

src_configure() {
        WX_GTK_PV=$(best_version x11-libs/wxGTK[X,debug=])
        WX_GTK_VER=$(get_version_component_range 1-2 
${WX_GTK_PV#x11-libs/wxGTK-})

        need-wxwidgets unicode

        econf --with-wx-version=${WX_GTK_VER} \
                $(use_enable debug) \
                $(use_enable databasedesigner)
}

src_install() {
        emake DESTDIR="${D}" install

        newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png

        domenu "${S}/pkg/pgadmin3.desktop"

        # Fixing world-writable files
        fperms -R go-w /usr/share
}




Reply via email to