jauhien     15/04/12 20:02:27

  Modified:             soci-3.2.2.ebuild ChangeLog
  Added:                soci-3.2.3.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key 
B2EFA1D4)

Revision  Changes    Path
1.4                  dev-db/soci/soci-3.2.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild?r1=1.3&r2=1.4

Index: soci-3.2.2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- soci-3.2.2.ebuild   28 Dec 2014 15:19:00 -0000      1.3
+++ soci-3.2.2.ebuild   12 Apr 2015 20:02:27 -0000      1.4
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild,v 1.3 
2014/12/28 15:19:00 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild,v 1.4 
2015/04/12 20:02:27 jauhien Exp $
 
 EAPI=5
 
@@ -20,7 +20,7 @@
        mysql? ( virtual/mysql )
        odbc? ( dev-db/unixODBC )
        oracle? ( dev-db/oracle-instantclient-basic )
-       postgres? ( dev-db/postgresql )
+       postgres? ( dev-db/postgresql:= )
        sqlite? ( dev-db/sqlite:3 )
 "
 RDEPEND=${DEPEND}



1.4                  dev-db/soci/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/ChangeLog?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/ChangeLog?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/ChangeLog?r1=1.3&r2=1.4

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-db/soci/ChangeLog,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- ChangeLog   28 Dec 2014 15:19:00 -0000      1.3
+++ ChangeLog   12 Apr 2015 20:02:27 -0000      1.4
@@ -1,6 +1,11 @@
 # ChangeLog for dev-db/soci
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/ChangeLog,v 1.3 2014/12/28 
15:19:00 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/ChangeLog,v 1.4 2015/04/12 
20:02:27 jauhien Exp $
+
+*soci-3.2.3 (12 Apr 2015)
+
+  12 Apr 2015;  <jauh...@gentoo.org> +soci-3.2.3.ebuild, soci-3.2.2.ebuild:
+  version bump
 
   28 Dec 2014; Aaron W. Swenson <titanof...@gentoo.org> soci-3.2.2.ebuild:
   Rename virtual/postgresql to dev-db/postgresql



1.1                  dev-db/soci/soci-3.2.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/soci-3.2.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/soci-3.2.3.ebuild?rev=1.1&content-type=text/plain

Index: soci-3.2.3.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/soci-3.2.3.ebuild,v 1.1 
2015/04/12 20:02:27 jauhien Exp $

EAPI=5

inherit cmake-utils

KEYWORDS="~amd64 ~x86"

DESCRIPTION="A db access library for C++ that makes the illusion of embedding 
SQL queries in the regular C++ code"
HOMEPAGE="http://soci.sourceforge.net/";
SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
LICENSE="Boost-1.0"
SLOT="0"
IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite"

DEPEND="boost? ( dev-libs/boost )
        firebird? ( dev-db/firebird )
        mysql? ( virtual/mysql )
        odbc? ( dev-db/unixODBC )
        oracle? ( dev-db/oracle-instantclient-basic )
        postgres? ( dev-db/postgresql:= )
        sqlite? ( dev-db/sqlite:3 )
"
RDEPEND=${DEPEND}

src_configure() {
        local mycmakeargs="$(cmake-utils_use_with boost )
                $(cmake-utils_use empty SOCI_EMPTY)
                $(cmake-utils_use_with firebird FIREBIRD)
                $(cmake-utils_use_with mysql MYSQL)
                $(cmake-utils_use_with odbc ODBC)
                $(cmake-utils_use_with oracle ORACLE)
                $(cmake-utils_use_with postgres POSTGRESQL)
                $(cmake-utils_use_with sqlite SQLITE3)
                -DWITH_DB2=OFF" #use MYCMAKEARGS if you want enable IBM DB2 
support
        cmake-utils_src_configure
}

src_install() {
        cmake-utils_src_install
        dodoc AUTHORS CHANGES
        if use doc; then
                dohtml -r doc/*
        fi
}




Reply via email to