[gentoo-commits] gentoo-x86 commit in dev-go/go-net: go-net-9999.ebuild ChangeLog

2015-08-05 Thread William Hubbs (williamh)
williamh15/08/05 16:46:10

  Modified: go-net-.ebuild ChangeLog
  Log:
  add support for golang-vcs-snapshot to live ebuild
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x30C46538)

Revision  ChangesPath
1.9  dev-go/go-net/go-net-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.9view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.9content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?r1=1.8r2=1.9

Index: go-net-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- go-net-.ebuild  6 Jul 2015 21:40:30 -   1.8
+++ go-net-.ebuild  5 Aug 2015 16:46:10 -   1.9
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.8 
2015/07/06 21:40:30 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.9 
2015/08/05 16:46:10 williamh Exp $
 
 EAPI=5
 EGO_PN=golang.org/x/net/...
@@ -12,6 +12,7 @@
KEYWORDS=~amd64
EGIT_COMMIT=dfe268fd2bb5c793f4c083803609fce9806c6f80
SRC_URI=https://github.com/golang/net/archive/${EGIT_COMMIT}.tar.gz - 
${P}.tar.gz
+   inherit golang-vcs-snapshot
 fi
 inherit golang-build
 
@@ -23,35 +24,6 @@
 DEPEND=dev-go/go-text:=
 RDEPEND=
 
-if [[ ${PV} != ** ]]; then
-src_unpack() {
-   local f
-
-   for f in ${A}
-   do
-   case ${f} in
-   *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
-   local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
-   debug-print ${FUNCNAME}: unpacking ${f} to 
${destdir}
-
-   # XXX: check whether the directory structure 
inside is
-   # fine? i.e. if the tarball has actually a 
parent dir.
-   mkdir -p ${destdir} || die
-   tar -C ${destdir} -x --strip-components 1 \
-   -f ${DISTDIR}/${f} || die
-   ;;
-   *)
-   debug-print ${FUNCNAME}: falling back to 
unpack for ${f}
-
-   # fall back to the default method
-   unpack ${f}
-   ;;
-   esac
-   done
-}
-fi
-
 src_prepare() {
# disable broken tests
sed -e 's:TestReadProppatch(:_\0:' \



1.13 dev-go/go-net/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.13view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.13content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?r1=1.12r2=1.13

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v
retrieving revision 1.12
retrieving revision 1.13
diff -u -r1.12 -r1.13
--- ChangeLog   6 Jul 2015 21:40:30 -   1.12
+++ ChangeLog   5 Aug 2015 16:46:10 -   1.13
@@ -1,6 +1,9 @@
 # ChangeLog for dev-go/go-net
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.12 2015/07/06 
21:40:30 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.13 2015/08/05 
16:46:10 williamh Exp $
+
+  05 Aug 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
+  add support for golang-vcs-snapshot to live ebuild
 
   06 Jul 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
   Add the slot dependency for go-text






[gentoo-commits] gentoo-x86 commit in dev-go/go-net: go-net-9999.ebuild ChangeLog

2015-07-06 Thread William Hubbs (williamh)
williamh15/07/06 16:55:33

  Modified: go-net-.ebuild ChangeLog
  Log:
  Add a subslot of the version number so we know which version is installed
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x30C46538)

Revision  ChangesPath
1.7  dev-go/go-net/go-net-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.7view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.7content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?r1=1.6r2=1.7

Index: go-net-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- go-net-.ebuild  29 Jun 2015 03:48:53 -  1.6
+++ go-net-.ebuild  6 Jul 2015 16:55:33 -   1.7
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.6 
2015/06/29 03:48:53 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.7 
2015/07/06 16:55:33 williamh Exp $
 
 EAPI=5
 EGO_PN=golang.org/x/net/...
@@ -18,7 +18,7 @@
 DESCRIPTION=Go supplementary network libraries
 HOMEPAGE=https://godoc.org/golang.org/x/net;
 LICENSE=BSD
-SLOT=0
+SLOT=0/${PV}
 IUSE=
 DEPEND=dev-go/go-text
 RDEPEND=



1.11 dev-go/go-net/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.11view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.11content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?r1=1.10r2=1.11

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v
retrieving revision 1.10
retrieving revision 1.11
diff -u -r1.10 -r1.11
--- ChangeLog   1 Jul 2015 20:24:19 -   1.10
+++ ChangeLog   6 Jul 2015 16:55:33 -   1.11
@@ -1,6 +1,9 @@
 # ChangeLog for dev-go/go-net
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.10 2015/07/01 
20:24:19 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.11 2015/07/06 
16:55:33 williamh Exp $
+
+  06 Jul 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
+  Add a subslot of the version number so we know which version is installed
 
 *go-net-0_pre20150604 (01 Jul 2015)
 






[gentoo-commits] gentoo-x86 commit in dev-go/go-net: go-net-9999.ebuild ChangeLog

2015-07-06 Thread William Hubbs (williamh)
williamh15/07/06 21:40:30

  Modified: go-net-.ebuild ChangeLog
  Log:
  Add the slot dependency for go-text
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x30C46538)

Revision  ChangesPath
1.8  dev-go/go-net/go-net-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.8view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.8content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?r1=1.7r2=1.8

Index: go-net-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- go-net-.ebuild  6 Jul 2015 16:55:33 -   1.7
+++ go-net-.ebuild  6 Jul 2015 21:40:30 -   1.8
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.7 
2015/07/06 16:55:33 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.8 
2015/07/06 21:40:30 williamh Exp $
 
 EAPI=5
 EGO_PN=golang.org/x/net/...
@@ -20,7 +20,7 @@
 LICENSE=BSD
 SLOT=0/${PV}
 IUSE=
-DEPEND=dev-go/go-text
+DEPEND=dev-go/go-text:=
 RDEPEND=
 
 if [[ ${PV} != ** ]]; then



1.12 dev-go/go-net/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.12view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.12content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?r1=1.11r2=1.12

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- ChangeLog   6 Jul 2015 16:55:33 -   1.11
+++ ChangeLog   6 Jul 2015 21:40:30 -   1.12
@@ -1,6 +1,9 @@
 # ChangeLog for dev-go/go-net
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.11 2015/07/06 
16:55:33 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.12 2015/07/06 
21:40:30 williamh Exp $
+
+  06 Jul 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
+  Add the slot dependency for go-text
 
   06 Jul 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
   Add a subslot of the version number so we know which version is installed






[gentoo-commits] gentoo-x86 commit in dev-go/go-net: go-net-9999.ebuild ChangeLog

2015-06-28 Thread William Hubbs (williamh)
williamh15/06/29 03:48:53

  Modified: go-net-.ebuild ChangeLog
  Log:
  Make live ebuild copyable
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x30C46538)

Revision  ChangesPath
1.6  dev-go/go-net/go-net-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.6view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.6content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?r1=1.5r2=1.6

Index: go-net-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- go-net-.ebuild  25 Jun 2015 19:24:07 -  1.5
+++ go-net-.ebuild  29 Jun 2015 03:48:53 -  1.6
@@ -1,12 +1,20 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.5 
2015/06/25 19:24:07 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.6 
2015/06/29 03:48:53 williamh Exp $
 
 EAPI=5
-inherit golang-build golang-vcs
 EGO_PN=golang.org/x/net/...
 EGO_SRC=golang.org/x/net
 
+if [[ ${PV} = ** ]]; then
+   inherit golang-vcs
+else
+   KEYWORDS=~amd64
+   EGIT_COMMIT=dfe268fd2bb5c793f4c083803609fce9806c6f80
+   SRC_URI=https://github.com/golang/net/archive/${EGIT_COMMIT}.tar.gz - 
${P}.tar.gz
+fi
+inherit golang-build
+
 DESCRIPTION=Go supplementary network libraries
 HOMEPAGE=https://godoc.org/golang.org/x/net;
 LICENSE=BSD
@@ -15,6 +23,35 @@
 DEPEND=dev-go/go-text
 RDEPEND=
 
+if [[ ${PV} != ** ]]; then
+src_unpack() {
+   local f
+
+   for f in ${A}
+   do
+   case ${f} in
+   *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+   local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+   debug-print ${FUNCNAME}: unpacking ${f} to 
${destdir}
+
+   # XXX: check whether the directory structure 
inside is
+   # fine? i.e. if the tarball has actually a 
parent dir.
+   mkdir -p ${destdir} || die
+   tar -C ${destdir} -x --strip-components 1 \
+   -f ${DISTDIR}/${f} || die
+   ;;
+   *)
+   debug-print ${FUNCNAME}: falling back to 
unpack for ${f}
+
+   # fall back to the default method
+   unpack ${f}
+   ;;
+   esac
+   done
+}
+fi
+
 src_prepare() {
# disable broken tests
sed -e 's:TestReadProppatch(:_\0:' \



1.9  dev-go/go-net/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.9view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.9content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?r1=1.8r2=1.9

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- ChangeLog   25 Jun 2015 19:24:07 -  1.8
+++ ChangeLog   29 Jun 2015 03:48:53 -  1.9
@@ -1,6 +1,9 @@
 # ChangeLog for dev-go/go-net
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.8 2015/06/25 
19:24:07 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.9 2015/06/29 
03:48:53 williamh Exp $
+
+  29 Jun 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
+  Make live ebuild copyable
 
   25 Jun 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
   Convert live ebuild to the new eclasses






[gentoo-commits] gentoo-x86 commit in dev-go/go-net: go-net-9999.ebuild ChangeLog

2015-06-25 Thread William Hubbs (williamh)
williamh15/06/25 19:24:07

  Modified: go-net-.ebuild ChangeLog
  Log:
  Convert live ebuild to the new eclasses
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x30C46538)

Revision  ChangesPath
1.5  dev-go/go-net/go-net-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.5view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.5content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?r1=1.4r2=1.5

Index: go-net-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- go-net-.ebuild  8 Jun 2015 19:34:50 -   1.4
+++ go-net-.ebuild  25 Jun 2015 19:24:07 -  1.5
@@ -1,50 +1,25 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.4 
2015/06/08 19:34:50 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.5 
2015/06/25 19:24:07 williamh Exp $
 
 EAPI=5
-inherit git-r3
+inherit golang-build golang-vcs
+EGO_PN=golang.org/x/net/...
+EGO_SRC=golang.org/x/net
 
-KEYWORDS=
 DESCRIPTION=Go supplementary network libraries
-GO_PN=golang.org/x/${PN##*-}
-HOMEPAGE=https://godoc.org/${GO_PN};
-EGIT_REPO_URI=https://go.googlesource.com/${PN##*-};
+HOMEPAGE=https://godoc.org/golang.org/x/net;
 LICENSE=BSD
 SLOT=0
 IUSE=
-DEPEND==dev-lang/go-1.4
-   dev-go/go-text
+DEPEND=dev-go/go-text
 RDEPEND=
-S=${WORKDIR}/src/${GO_PN}
-EGIT_CHECKOUT_DIR=${S}
-STRIP_MASK=*.a
 
 src_prepare() {
# disable broken tests
-   sed -e 's:TestReadProppatch(:_\0:' -i webdav/xml_test.go || die
+   sed -e 's:TestReadProppatch(:_\0:' \
+   -i src/${EGO_SRC}/webdav/xml_test.go || die
sed -e 's:TestPingGoogle(:_\0:' \
-e 's:TestNonPrivilegedPing(:_\0:' \
-   -i icmp/ping_test.go || die
-}
-
-src_compile() {
-   # Create a writable GOROOT in order to avoid sandbox violations.
-   GOROOT=${WORKDIR}/goroot
-   cp -sR ${EPREFIX}/usr/lib/go ${GOROOT} || die
-   rm -rf ${GOROOT}/src/${GO_PN} \
-   ${GOROOT}/pkg/linux_${ARCH}/${GO_PN} || die
-   GOROOT=${GOROOT} GOPATH=${WORKDIR} go install -v -x -work 
${GO_PN}/... || die
-}
-
-src_test() {
-   GOROOT=${GOROOT} GOPATH=${WORKDIR} \
-   go test -x -v ${GO_PN}/... || die $?
-}
-
-src_install() {
-   insinto /usr/lib/go
-   find ${WORKDIR}/{pkg,src} -name '.git*' -exec rm -rf {} \; 2/dev/null
-   insopts -m0644 -p # preserve timestamps for bug 551486
-   doins -r ${WORKDIR}/{pkg,src}
+   -i src/${EGO_SRC}/icmp/ping_test.go || die
 }



1.8  dev-go/go-net/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.8view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?rev=1.8content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/ChangeLog?r1=1.7r2=1.8

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- ChangeLog   9 Jun 2015 06:52:46 -   1.7
+++ ChangeLog   25 Jun 2015 19:24:07 -  1.8
@@ -1,6 +1,9 @@
 # ChangeLog for dev-go/go-net
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.7 2015/06/09 
06:52:46 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/ChangeLog,v 1.8 2015/06/25 
19:24:07 williamh Exp $
+
+  25 Jun 2015; William Hubbs willi...@gentoo.org go-net-.ebuild:
+  Convert live ebuild to the new eclasses
 
   09 Jun 2015; Zac Medico zmed...@gentoo.org go-net-1.4.2_p20150604.ebuild:
   Disable TestNonPrivilegedPing for 1.4.2_p20150604.






[gentoo-commits] gentoo-x86 commit in dev-go/go-net: go-net-9999.ebuild ChangeLog

2015-05-21 Thread Zac Medico (zmedico)
zmedico 15/05/21 06:16:46

  Modified: go-net-.ebuild ChangeLog
  Log:
  Add src_test.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
FDE8EF85AE5719A3)

Revision  ChangesPath
1.2  dev-go/go-net/go-net-.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.2view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?rev=1.2content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-go/go-net/go-net-.ebuild?r1=1.1r2=1.2

Index: go-net-.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- go-net-.ebuild  18 May 2015 07:53:59 -  1.1
+++ go-net-.ebuild  21 May 2015 06:16:46 -  1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.1 
2015/05/18 07:53:59 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-net/go-net-.ebuild,v 1.2 
2015/05/21 06:16:46 zmedico Exp $
 
 EAPI=5
 inherit git-r3
@@ -29,6 +29,55 @@
GOROOT=${GOROOT} GOPATH=${WORKDIR} go install -v -x -work 
${GO_PN}/... || die
 }
 
+src_test() {
+   GOROOT=${GOROOT} GOPATH=${WORKDIR} \
+   go test -run ^(Example(WithTimeout|Parse)|$(
+   echo -n '|Test(Background|TODO|WithCancel|ParentFinishesChild|'
+   echo -n 'ChildFinishesFirst|Deadline|Timeout|CanceledTimeout|'
+   echo -n 'Values|Allocs|SimultaneousCancels|InterlockedCancels|'
+   echo -n 'LayersCancel|LayersTimeout|CancelRemoves|EntityLength|'
+   echo -n 
'Unescape|UnescapeEscape|Parser|NodeConsistency|Renderer|'
+   echo -n 
'Tokenizer|MaxBuffer|MaxBufferReconstruction|Passthrough|'
+   echo -n 
'BufAPI|ConvertNewlines|ReaderEdgeCases|Known|Hits|Misses|'
+   echo -n 
'ForeignObject|Decode|Encode|Names|Sniff|Reader|FromMeta|'
+   echo -n 'XML|MarshalAndParseExtension|ParseIPv4Header|'
+   echo -n 
'MarshalAndParseMessageForIPv4|MarshalAndParseMessageForIPv6|'
+   echo -n 'MarshalAndParseMultipartMessageForIPv4|'
+   echo -n 'MarshalAndParseMultipartMessageForIPv6|IDNA|Punycode|'
+   echo -n 'PunycodeErrors|MarshalHeader|ParseHeader|ICMPString|'
+   echo -n 
'ICMPFilter|UDPSinglePacketConnWithMultipleGroupListeners|'
+   echo -n 'UDPMultiplePacketConnWithMultipleGroupListeners|'
+   echo -n 
'UDPPerInterfaceSinglePacketConnWithSingleGroupListener|'
+   echo -n 'PacketConnConcurrentReadWriteUnicastUDP|'
+   echo -n 
'PacketConnReadWriteUnicastUDP|ConnUnicastSocketOptions|'
+   echo -n 'PacketConnUnicastSocketOptions|ParseHeader|ICMPString|'
+   echo -n 
'ICMPFilter|UDPSinglePacketConnWithMultipleGroupListeners|'
+   echo -n 'UDPMultiplePacketConnWithMultipleGroupListeners|'
+   echo -n 
'UDPPerInterfaceSinglePacketConnWithSingleGroupListener|'
+   echo -n 
'PacketConnConcurrentReadWriteUnicastUDP|ConnInitiatorPathMTU|'
+   echo -n 'ConnResponderPathMTU|PacketConnReadWriteUnicastUDP|'
+   echo -n 
'ConnUnicastSocketOptions|PacketConnUnicastSocketOptions|'
+   echo -n 
'LimitListener|LimitListenerError|PerHost|FromURL|SOCKS5|'
+   echo -n 'NodeLabel|Find|ICANN|PublicSuffix|SlowPublicSuffix|'
+   echo -n 
'EffectiveTLDPlusOne|SlashClean|DirResolve|Walk|Dir|MemFS|'
+   echo -n 
'MemFSRoot|MemFileReaddir|MemFile|MemFileWriteAllocs|WalkFS|'
+   echo -n 'ParseIfHeader|WalkToRoot|MemLSCanCreate|MemLSLookup|'
+   echo -n 'MemLSConfirm|MemLSNonCanonicalRoot|MemLSExpiry|MemLS|'
+   echo -n 'ParseTimeout|MemPS|ReadLockInfo|ReadPropfind|'
+   echo -n 'SecWebSocketAccept|HybiClientHandshake|'
+   echo -n 'HybiClientHandshakeWithHeader|HybiServerHandshake|'
+   echo -n 'HybiServerHandshakeNoSubProtocol|'
+   echo -n 'HybiServerHandshakeHybiBadVersion|HybiShortTextFrame|'
+   echo -n 'HybiShortMaskedTextFrame|HybiShortBinaryFrame|'
+   echo -n 'HybiControlFrame|HybiLongFrame|HybiClientRead|'
+   echo -n 
'HybiShortRead|HybiServerRead|HybiServerReadWithoutMasking|'
+   echo -n 
'HybiClientReadWithMasking|HybiServerFirefoxHandshake|Echo|'
+   echo -n 'Addr|Count|WithQuery|WithProtocol|WithTwoProtocol|'
+   echo -n 
'WithBadProtocol|HTTP|TrailingSpaces|DialConfigBadVersion|'
+   echo -n 'SmallBuffer|ParseAuthority|Close))$') \
+   -x -v