slyfox      15/08/01 15:40:50

  Modified:             ChangeLog
  Added:                http-4000.2.20.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
611FF3AA)

Revision  Changes    Path
1.52                 dev-haskell/http/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-haskell/http/ChangeLog?rev=1.52&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-haskell/http/ChangeLog?rev=1.52&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-haskell/http/ChangeLog?r1=1.51&r2=1.52

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v
retrieving revision 1.51
retrieving revision 1.52
diff -u -r1.51 -r1.52
--- ChangeLog   6 Jun 2015 11:34:15 -0000       1.51
+++ ChangeLog   1 Aug 2015 15:40:50 -0000       1.52
@@ -1,6 +1,11 @@
 # ChangeLog for dev-haskell/http
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.51 
2015/06/06 11:34:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.52 
2015/08/01 15:40:50 slyfox Exp $
+
+*http-4000.2.20 (01 Aug 2015)
+
+  01 Aug 2015; Sergei Trofimovich <sly...@gentoo.org> +http-4000.2.20.ebuild:
+  Version bump.
 
   06 Jun 2015; Justin Lecher <j...@gentoo.org> metadata.xml:
   Add github to remote-id in metadata.xml



1.1                  dev-haskell/http/http-4000.2.20.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-haskell/http/http-4000.2.20.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-haskell/http/http-4000.2.20.ebuild?rev=1.1&content-type=text/plain

Index: http-4000.2.20.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.2.20.ebuild,v 1.1 
2015/08/01 15:40:50 slyfox Exp $

EAPI=5

# ebuild generated by hackport 0.4.4.9999
#hackport: flags: -warp-tests,-mtl1,-warn-as-error,-old-base,-network23

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

MY_PN="HTTP"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP";
SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="conduit10 +network-uri"

RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
        >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
        >=dev-lang/ghc-7.4.1:=
        >=dev-haskell/old-time-1.0:=[profile?] 
<dev-haskell/old-time-1.2:=[profile?]
        network-uri? ( >=dev-haskell/network-2.6:=[profile?] 
<dev-haskell/network-2.7:=[profile?]
                        >=dev-haskell/network-uri-2.6:=[profile?] 
<dev-haskell/network-uri-2.7:=[profile?] )
        !network-uri? ( >=dev-haskell/network-2.2.1.5:=[profile?] 
<dev-haskell/network-2.6:=[profile?] )
"
DEPEND="${RDEPEND}
        >=dev-haskell/cabal-1.8
        dev-lang/ghc
        test? ( >=dev-haskell/httpd-shed-0.4 <dev-haskell/httpd-shed-0.5
                >=dev-haskell/hunit-1.2.0.1 <dev-haskell/hunit-1.3
                >=dev-haskell/puremd5-0.2.4 <dev-haskell/puremd5-2.2
                >=dev-haskell/split-0.1.3 <dev-haskell/split-0.3
                >=dev-haskell/test-framework-0.2.0 
<dev-haskell/test-framework-0.9
                >=dev-haskell/test-framework-hunit-0.3.0 
<dev-haskell/test-framework-hunit-0.4 )
"

S="${WORKDIR}/${MY_P}"

src_configure() {
        haskell-cabal_src_configure \
                $(cabal_flag conduit10 conduit10) \
                --flag=-mtl1 \
                $(cabal_flag network-uri network-uri) \
                --flag=-network23 \
                --flag=-old-base \
                --flag=-warn-as-error \
                --flag=-warp-tests
}




Reply via email to