ercpe       15/01/23 17:51:17

  Modified:             ChangeLog
  Added:                java-sdk-docs-1.8.0.31.ebuild
                        java-sdk-docs-1.7.0.76.ebuild
  Log:
  Version bump of java-sdk-docs wrt bug #537214
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
77C501ED)

Revision  Changes    Path
1.115                dev-java/java-sdk-docs/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/java-sdk-docs/ChangeLog?rev=1.115&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/java-sdk-docs/ChangeLog?rev=1.115&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/java-sdk-docs/ChangeLog?r1=1.114&r2=1.115

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v
retrieving revision 1.114
retrieving revision 1.115
diff -u -r1.114 -r1.115
--- ChangeLog   22 Nov 2014 08:29:09 -0000      1.114
+++ ChangeLog   23 Jan 2015 17:51:17 -0000      1.115
@@ -1,6 +1,13 @@
 # ChangeLog for dev-java/java-sdk-docs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.114 
2014/11/22 08:29:09 ercpe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.115 
2015/01/23 17:51:17 ercpe Exp $
+
+*java-sdk-docs-1.7.0.76 (23 Jan 2015)
+*java-sdk-docs-1.8.0.31 (23 Jan 2015)
+
+  23 Jan 2015; Johann Schmitz <er...@gentoo.org> 
+java-sdk-docs-1.7.0.76.ebuild,
+  +java-sdk-docs-1.8.0.31.ebuild:
+  Version bump of java-sdk-docs wrt bug #537214
 
 *java-sdk-docs-1.8.0.25 (22 Nov 2014)
 



1.1                  dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild?rev=1.1&content-type=text/plain

Index: java-sdk-docs-1.8.0.31.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild,v 
1.1 2015/01/23 17:51:17 ercpe Exp $

EAPI="5"

inherit versionator

DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html";

[[ "$(get_version_component_range 4)" == 0 ]] \
        || MY_PV_EXT="u$(get_version_component_range 4)"

MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
ORIG_NAME="jdk-${MY_PV}-docs-all.zip"

DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
HOMEPAGE="http://download.oracle.com/javase/8/docs/";
SRC_URI="${ORIG_NAME}"

LICENSE="oracle-java-documentation-8"
SLOT="1.8"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"

DEPEND="app-arch/unzip:0"

RESTRICT="fetch"

S="${WORKDIR}/docs"

pkg_nofetch() {
        einfo "Please download ${ORIG_NAME} from "
        einfo "${DOWNLOAD_URL}"
        einfo "(agree to the license) and place it in ${DISTDIR}"

        einfo "If you find the file on the download page replaced with a higher"
        einfo "version, please report to the bug 67266 (link below)."
        einfo "If emerge fails because of a checksum error it is possible that"
        einfo "the upstream release changed without renaming. Try downloading 
the file"
        einfo "again (or a newer revision if available). Otherwise report this 
to"
        einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
}

src_install(){
        insinto /usr/share/doc/${P}/html
        doins index.html

        for i in *; do
                [[ -d $i ]] && doins -r $i
        done
}



1.1                  dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild?rev=1.1&content-type=text/plain

Index: java-sdk-docs-1.7.0.76.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild,v 
1.1 2015/01/23 17:51:17 ercpe Exp $

EAPI=5

inherit versionator

MY_PV="$(get_version_component_range 2)u$(get_version_component_range 4)"

DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html#jdk-${MY_PV}-apidocs-oth-JPR";
ORIG_NAME="jdk-${MY_PV}-docs-all.zip"

DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
HOMEPAGE="http://download.oracle.com/javase/7/docs/";
SRC_URI="${ORIG_NAME}"

LICENSE="oracle-java-documentation-7"
SLOT="1.7"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""

DEPEND="app-arch/unzip"

RESTRICT="fetch"

S="${WORKDIR}/docs"

pkg_nofetch() {
        einfo "Please download ${ORIG_NAME} from "
        einfo "${DOWNLOAD_URL}"
        einfo "(agree to the license) and place it in ${DISTDIR}"

        einfo "If you find the file on the download page replaced with a higher"
        einfo "version, please report to the bug 67266 (link below)."
        einfo "If emerge fails because of a checksum error it is possible that"
        einfo "the upstream release changed without renaming. Try downloading 
the file"
        einfo "again (or a newer revision if available). Otherwise report this 
to"
        einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
}

src_install(){
        insinto /usr/share/doc/${P}/html
        doins index.html

        for i in *; do
                [[ -d $i ]] && doins -r $i
        done
}




Reply via email to