mr_bones_    14/05/06 20:48:51

  Modified:             ChangeLog
  Added:                nasm-2.11.03.ebuild
  Removed:              nasm-2.10.05.ebuild nasm-2.11.02.ebuild
                        nasm-2.11.ebuild
  Log:
  version bump; clean old
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.115                dev-lang/nasm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/nasm/ChangeLog?rev=1.115&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/nasm/ChangeLog?rev=1.115&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/nasm/ChangeLog?r1=1.114&r2=1.115

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v
retrieving revision 1.114
retrieving revision 1.115
diff -u -r1.114 -r1.115
--- ChangeLog   14 Apr 2014 21:10:15 -0000      1.114
+++ ChangeLog   6 May 2014 20:48:51 -0000       1.115
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lang/nasm
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.114 2014/04/14 
21:10:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.115 2014/05/06 
20:48:51 mr_bones_ Exp $
+
+*nasm-2.11.03 (06 May 2014)
+
+  06 May 2014; Michael Sterrett <mr_bon...@gentoo.org> +nasm-2.11.03.ebuild,
+  -nasm-2.10.05.ebuild, -nasm-2.11.02.ebuild, -nasm-2.11.ebuild:
+  version bump; clean old
 
 *nasm-2.11.02 (14 Apr 2014)
 



1.1                  dev-lang/nasm/nasm-2.11.03.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/nasm/nasm-2.11.03.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/nasm/nasm-2.11.03.ebuild?rev=1.1&content-type=text/plain

Index: nasm-2.11.03.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.11.03.ebuild,v 1.1 
2014/05/06 20:48:51 mr_bones_ Exp $

EAPI=5
inherit flag-o-matic

DESCRIPTION="groovy little assembler"
HOMEPAGE="http://nasm.sourceforge.net/";
SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz";

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux 
~x86-linux ~x64-macos"
IUSE="doc"

DEPEND="dev-lang/perl
        doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
RDEPEND=""

S=${WORKDIR}/${P/_}

src_configure() {
        strip-flags
        econf
}

src_compile() {
        emake nasmlib.o
        emake all
        use doc && emake doc
}

src_install() {
        emake INSTALLROOT="${D}" install install_rdf
        dodoc AUTHORS CHANGES ChangeLog README TODO
        if use doc ; then
                doinfo doc/info/*
                dohtml doc/html/*
                dodoc doc/nasmdoc.*
        fi
}




Reply via email to