jauhien     15/04/11 14:05:16

  Modified:             rust-1.0.0_alpha2.ebuild ChangeLog
  Added:                rust-1.0.0_beta.ebuild
  Log:
  version bump, close bug #546012
  
  (Portage version: 2.2.18/cvs/Linux i686, unsigned Manifest commit)

Revision  Changes    Path
1.4                  dev-lang/rust/rust-1.0.0_alpha2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-1.0.0_alpha2.ebuild?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-1.0.0_alpha2.ebuild?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-1.0.0_alpha2.ebuild?r1=1.3&r2=1.4

Index: rust-1.0.0_alpha2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-1.0.0_alpha2.ebuild,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- rust-1.0.0_alpha2.ebuild    8 Apr 2015 08:22:09 -0000       1.3
+++ rust-1.0.0_alpha2.ebuild    11 Apr 2015 14:05:16 -0000      1.4
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-1.0.0_alpha2.ebuild,v 
1.3 2015/04/08 08:22:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-1.0.0_alpha2.ebuild,v 
1.4 2015/04/11 14:05:16 jauhien Exp $
 
 EAPI=5
 



1.15                 dev-lang/rust/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/ChangeLog?rev=1.15&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/ChangeLog?rev=1.15&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/ChangeLog?r1=1.14&r2=1.15

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v
retrieving revision 1.14
retrieving revision 1.15
diff -u -r1.14 -r1.15
--- ChangeLog   8 Apr 2015 08:22:09 -0000       1.14
+++ ChangeLog   11 Apr 2015 14:05:16 -0000      1.15
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lang/rust
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.14 2015/04/08 
08:22:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.15 2015/04/11 
14:05:16 jauhien Exp $
+
+*rust-1.0.0_beta (11 Apr 2015)
+
+  11 Apr 2015;  <jauh...@gentoo.org> +rust-1.0.0_beta.ebuild,
+  rust-1.0.0_alpha2.ebuild:
+  version bump, close bug #546012
 
   08 Apr 2015; Michał Górny <mgo...@gentoo.org> rust-1.0.0_alpha2.ebuild:
   Drop old Python implementations



1.1                  dev-lang/rust/rust-1.0.0_beta.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-1.0.0_beta.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-1.0.0_beta.ebuild?rev=1.1&content-type=text/plain

Index: rust-1.0.0_beta.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-1.0.0_beta.ebuild,v 1.1 
2015/04/11 14:05:16 jauhien Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit eutils python-any-r1

MY_PV="rustc-1.0.0-beta"
DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="http://www.rust-lang.org/";

SRC_URI="http://static.rust-lang.org/dist/${MY_PV}-src.tar.gz
        x86?   ( 
http://static.rust-lang.org/stage0-snapshots/rust-stage0-2015-03-27-5520801-linux-i386-1ef82402ed16f5a6d2f87a9a62eaa83170e249ec.tar.bz2
 )
        amd64? ( 
http://static.rust-lang.org/stage0-snapshots/rust-stage0-2015-03-27-5520801-linux-x86_64-ef2154372e97a3cb687897d027fd51c8f2c5f349.tar.bz2
 )"

LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="1.0"
KEYWORDS="~amd64 ~x86"

IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"

CDEPEND="libcxx? ( sys-libs/libcxx )
        >=app-eselect/eselect-rust-0.2_pre20150206
        !dev-lang/rust:0
"
DEPEND="${CDEPEND}
        ${PYTHON_DEPS}
        >=dev-lang/perl-5.0
        clang? ( sys-devel/clang )
        system-llvm? ( >=sys-devel/llvm-3.6.0[multitarget(-)] )
"
RDEPEND="${CDEPEND}
"

S=${WORKDIR}/${MY_PV}

src_unpack() {
        unpack "${MY_PV}-src.tar.gz" || die
        mkdir "${MY_PV}/dl" || die
        cp "${DISTDIR}/rust-stage0"* "${MY_PV}/dl/" || die
}

src_prepare() {
        local postfix="gentoo-${SLOT}"
        sed -i -e "s/CFG_FILENAME_EXTRA=.*/CFG_FILENAME_EXTRA=${postfix}/" 
mk/main.mk || die
}

src_configure() {
        export CFG_DISABLE_LDCONFIG="notempty"

        "${ECONF_SOURCE:-.}"/configure \
                --prefix="${EPREFIX}/usr" \
                --libdir="${EPREFIX}/usr/lib/${P}" \
                --mandir="${EPREFIX}/usr/share/${P}/man" \
                --disable-manage-submodules \
                --disable-verify-install \
                $(use_enable clang) \
                $(use_enable debug) \
                $(use_enable debug llvm-assertions) \
                $(use_enable !debug optimize) \
                $(use_enable !debug optimize-cxx) \
                $(use_enable !debug optimize-llvm) \
                $(use_enable !debug optimize-tests) \
                $(use_enable doc docs) \
                $(use_enable libcxx libcpp) \
                $(usex system-llvm "--llvm-root=${EPREFIX}/usr" " ") \
                || die
}

src_compile() {
        emake VERBOSE=1
}

src_install() {
        default

        mv "${D}/usr/bin/rustc" "${D}/usr/bin/rustc-${PV}" || die
        mv "${D}/usr/bin/rustdoc" "${D}/usr/bin/rustdoc-${PV}" || die
        mv "${D}/usr/bin/rust-gdb" "${D}/usr/bin/rust-gdb-${PV}" || die

        dodoc COPYRIGHT LICENSE-APACHE LICENSE-MIT

        rm "${D}/usr/share/doc/rust" -rf

        # le kludge that fixes https://github.com/Heather/gentoo-rust/issues/41
        mv "${D}/usr/lib/rust-${PV}/rust-${PV}/rustlib"/* 
"${D}/usr/lib/rust-${PV}/rustlib/"
        rmdir "${D}/usr/lib/rust-${PV}/rust-${PV}/rustlib"
        mv "${D}/usr/lib/rust-${PV}/rust-${PV}/"/* "${D}/usr/lib/rust-${PV}/"
        rmdir "${D}/usr/lib/rust-${PV}/rust-${PV}/"

        mv "${D}/usr/share/doc/rust"/* "${D}/usr/share/doc/rust-${PV}/"
        rmdir "${D}/usr/share/doc/rust/"

        cat <<-EOF > "${T}"/50${P}
        LDPATH="/usr/lib/${P}"
        MANPATH="/usr/share/${P}/man"
        EOF
        doenvd "${T}"/50${P}

        dodir /etc/env.d/rust
        touch "${D}/etc/env.d/rust/provider-${P}" || die
}

pkg_postinst() {
        eselect rust update --if-unset

        elog "Rust uses slots now, use 'eselect rust list'"
        elog "and 'eselect rust set' to list and set rust version."
        elog "For more information see 'eselect rust help'"
        elog "and http://wiki.gentoo.org/wiki/Project:Eselect/User_guide";

        elog "Rust installs a helper script for calling GDB now,"
        elog "for your convenience it is installed under 
/usr/bin/rust-gdb-${PV}."

        if has_version app-editors/emacs || has_version app-editors/emacs-vcs; 
then
                elog "install app-emacs/rust-mode to get emacs support for 
rust."
        fi

        if has_version app-editors/gvim || has_version app-editors/vim; then
                elog "install app-vim/rust-mode to get vim support for rust."
        fi

        if has_version 'app-shells/zsh'; then
                elog "install app-shells/rust-zshcomp to get zsh completion for 
rust."
        fi
}

pkg_postrm() {
        eselect rust unset --if-invalid
}




Reply via email to