jauhien     14/11/30 12:45:15

  Modified:             rust-999-r1.ebuild rust-9999-r3.ebuild ChangeLog
  Log:
  support for rust-lldb symlink
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0xB2EFA1D4)

Revision  Changes    Path
1.4                  dev-lang/rust/rust-999-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild?r1=1.3&r2=1.4

Index: rust-999-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- rust-999-r1.ebuild  22 Nov 2014 12:20:44 -0000      1.3
+++ rust-999-r1.ebuild  30 Nov 2014 12:45:15 -0000      1.4
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild,v 1.3 
2014/11/22 12:20:44 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild,v 1.4 
2014/11/30 12:45:15 jauhien Exp $
 
 EAPI="5"
 
@@ -22,7 +22,7 @@
 REQUIRED_USE="libcxx? ( clang )"
 
 CDEPEND="libcxx? ( sys-libs/libcxx )
-       >=app-admin/eselect-rust-0.2_pre20141011
+       >=app-admin/eselect-rust-0.2_pre20141128
        !dev-lang/rust:0
 "
 DEPEND="${CDEPEND}
@@ -92,6 +92,7 @@
 
        mv "${D}/usr/bin/rustc" "${D}/usr/bin/rustc-${PV}" || die
        mv "${D}/usr/bin/rustdoc" "${D}/usr/bin/rustdoc-${PV}" || die
+       mv "${D}/usr/bin/rust-lldb" "${D}/usr/bin/rust-lldb-${PV}" || die
 
        cat <<-EOF > "${T}"/50${P}
        LDPATH="/usr/lib/${P}"
@@ -110,6 +111,11 @@
        elog "and 'eselect rust set' to list and set rust version."
        elog "For more information see 'eselect rust help'"
        elog "and http://wiki.gentoo.org/wiki/Project:Eselect/User_guide";
+
+       elog "Rust installs a helper script for calling LLDB now,"
+       elog "for your convenience it is installed under 
/usr/bin/rust-lldb-${PV},"
+       elog "but note, that there is no LLDB ebuild in the tree currently,"
+       elog "so you are on your own if you want to use it."
 }
 
 pkg_postrm() {



1.3                  dev-lang/rust/rust-9999-r3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild?r1=1.2&r2=1.3

Index: rust-9999-r3.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- rust-9999-r3.ebuild 21 Nov 2014 10:39:00 -0000      1.2
+++ rust-9999-r3.ebuild 30 Nov 2014 12:45:15 -0000      1.3
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild,v 1.2 
2014/11/21 10:39:00 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild,v 1.3 
2014/11/30 12:45:15 jauhien Exp $
 
 EAPI="5"
 
@@ -20,7 +20,7 @@
 REQUIRED_USE="libcxx? ( clang )"
 
 CDEPEND="libcxx? ( sys-libs/libcxx )
-       >=app-admin/eselect-rust-0.2_pre20141011
+       >=app-admin/eselect-rust-0.2_pre20141128
        !dev-lang/rust:0
 "
 DEPEND="${CDEPEND}
@@ -86,6 +86,7 @@
 
        mv "${D}/usr/bin/rustc" "${D}/usr/bin/rustc-${PV}" || die
        mv "${D}/usr/bin/rustdoc" "${D}/usr/bin/rustdoc-${PV}" || die
+       mv "${D}/usr/bin/rust-lldb" "${D}/usr/bin/rust-lldb-${PV}" || die
 
        cat <<-EOF > "${T}"/50${P}
        LDPATH="/usr/lib/${P}"
@@ -104,6 +105,11 @@
        elog "and 'eselect rust set' to list and set rust version."
        elog "For more information see 'eselect rust help'"
        elog "and http://wiki.gentoo.org/wiki/Project:Eselect/User_guide";
+
+       elog "Rust installs a helper script for calling LLDB now,"
+       elog "for your convenience it is installed under 
/usr/bin/rust-lldb-${PV},"
+       elog "but note, that there is no LLDB ebuild in the tree currently,"
+       elog "so you are on your own if you want to use it."
 }
 
 pkg_postrm() {



1.9                  dev-lang/rust/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/ChangeLog?rev=1.9&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/ChangeLog?rev=1.9&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/rust/ChangeLog?r1=1.8&r2=1.9

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- ChangeLog   22 Nov 2014 12:20:44 -0000      1.8
+++ ChangeLog   30 Nov 2014 12:45:15 -0000      1.9
@@ -1,6 +1,10 @@
 # ChangeLog for dev-lang/rust
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.8 2014/11/22 
12:20:44 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.9 2014/11/30 
12:45:15 jauhien Exp $
+
+  30 Nov 2014; Jauhien Piatlicki <jauh...@gentoo.org> rust-999-r1.ebuild,
+  rust-9999-r3.ebuild:
+  support for rust-lldb symlink
 
   22 Nov 2014; Jauhien Piatlicki <jauh...@gentoo.org> rust-999-r1.ebuild:
   remove rust-0.12.0-libdir.patch from nightly




Reply via email to